Base folder remains default

Insync, Linux (PopOS/Ubuntu 19.04)

I just installed Insync, added my Google Drive account, set the base folder to /home/user/gdrive and selected some folders to sync but it was downloading them to the default location (/home/user/Insync/email/Google Drive).

After several attempts to remove/add the account it started working correctly, looks like it happened when I skipped the configuration (ignore rules) in the initial wizard by pressing the big “Not now” (or whatever it was called) button, and later added the ignore rules and selected the folders to sync via the main menu.


Thanks for this @Alex_P. Glad to hear that you’re not encountering problems anymore.

We have version 3.0.15 available on the website now!

1 Like

I’m currently running v3.0.15.40277 on the latest version of MacOS and have the same problem. Nothing I do seems to get a custom base folder to stick. I’m trying to point to an external drive.

Hi @John_Papola! When changing the base folder, you currently have to click “Sync” for the change to apply (during the initial onboarding or after the fact). Do you remember clicking “Sync”?

We are looking to improve the experience surrounding setting base folders, so thanks for this feedback! We have some changes lined up in upcoming updates.

1 Like

@gio I have clicked sync and nothing happens. I’ve unchecked all the folders, hit sync and they’re removed from the default folder. Check one while pointing to the custom folder… and it still syncs to the default.

The function appears to be completely broken for me.

Hi @John_Papola,

Could you confirm if you have at least one file/folder synced (marked by a green check) prior to changing your Base Folder?

I’ve tried it both ways. I’ve changed the base folder with at least one folder already synced AND I’ve reset and deleted everything and then attempted to set the base folder before syncing anything.

Neither have worked.

I see. Thanks for the update and apologies for the trouble! Did you get a chance to update to 3.0.16 to see if this issue persists? Let me know how it goes. :slight_smile:

Similar problem with lubuntu 18.04. I can change the default location, but it seems to only apply the selected folder . If I then try to apply the change to another folder not yet synced, I get an error message: the folder you chose already has a synced folder. Anyways, I’m reverting back to version 2.x for the time being.


I also have this problem. I tried all the solutions described above and the base folder doesn’t seem to be saved (that is, it will use the old base folder).

I’m using Xubuntu 18.4 and Insync v3.0.21.40435.


Confirm this bug still exists on Ubuntu 19.04 with
I have updated both the Insync app from 3.0.20 and the Ubuntu base from 18.04 and have experienced this error in both cases.

Hi all! Could you update to 3.0.22 and let me know if this bug still persists? If it does, shoot me an email at with the link to this post. Please include your log files and OS version.

Thank you!

Hello @miamoran,

Thanks for the update. It seems that the update to 2.0.22 solved this problem.

IMPORTANT NOTE: some things are still not working well, but it’s just a matter of restarting Insync. That is, after the Base Folder is changed, it’s necessary to restart Insync to have everything working well!

I’ve been travels a bunch this month but will check on the update when I get back to the office tomorrow. Thanks!

I was having the same problem, with version 3.0.27 (in Arch Linux). But after an update to 3.0.28 it is working.

1 Like

The same problem. Ubuntu 16.04, insync_3.1.3.40790-xenial.

With this bug the application has became dangerous.
It can delete files massively just because the base folder is wrong.

Hi @Andrey_Green,

Could you walk me through your setup? Did you try to change it during onboarding as per the first post here, or did you try changing by clicking the gear icon beside My Drive and selecting “Change”?

I have the same issue. ZorinOS based on Ubuntu 20.04. I try to change it by clicking the gear icon beside My Drive and selecting “Change”. I then hit apply. It looks like it tried to change. Restarting insync and its back to “OneDrive Biz”. I do not know about “changing it during onboarding” – like uninstall and reinstall?

I assume there must be some sort of file that tells insync on restart what folders to look to, and that the change gear feature is not effectively making the desired change? But I do not know where to find this file to change it myself.

Every time I reboot my computer or insync I get this issue, and have to deal with the potential for massive deletes.


Thanks for the help.

Hi @Keith_Dodd,

Appreciate you walking me through your setup and how persistent this issue has been. Please send me the following:

  • logs.db
  • out.txt
  • data folder
  • live folder

These should be in ~/.config/Insync. You can email it to and include a link to this post :slight_smile: