Context Menu on OSX 10.11 (El Capitan)


#42

… insync menu is now showing up in finder - uncheckd and rechecked in System . Extensions …

I also could not see the insync in finder menu when right clicking on folders. I went into Mac System /Extensions and un-checked insync, moved out of system preferences thinking it may reset it. and then back into Systems / Extensions and ticked the insync extension ‘back on’ … insync is now showing up by right clicking any finder folder not in my google drive but it shows up in the SERVICES menu at the bottom of the Finder Menu … for existing folders it shows up options to control insync/gdrive.

… below is what shows when right clicking a folder which already exists in insync or gdrive.


#43

Hi there,

My inSync is having the same problem where the context menu doesn’t show and the finder icon overlay doesn’t show. In my environment, the System Preference > Extension doesn’t show the Finder or InSync extension either, so I cannot disable-then-enable it. I’ve been having this problem for months by now. I don’t remember which version of OSX or InSync I was using back when the problem started…

Things I tried:

  • Restarting OSX and relaunching Finder
  • Reinstalling InSync. Tried both the app itself and related files in ~/Library and /Library

I haven’t done the SIP-disable work around, but as I’m on El Captan 10.11.5 + InSync v.1.3.8.x, it seems irrelevant by now.

Could anyone here help me fix it? @jimperio ?
Many thanks.


#44

Can anyone help me please?
One of my colleagues just started having the same problem…

Thanks.


#45

I am having the same problem - the “add to insync” context menu item is not present, but is visible in the services sub-menu.


#46

I finally found a fix for this problem – it will affect anyone who is using multiple Finder Sync applications – I’ve edited the below quote to make it more relevant to Insync users:

The problem is that Apple does not allow multiple Finder Sync extensions to run simultaneously for registered folders. Dropbox, I believe, registers your home directory, unfortunately, which causes the Google Drive folder not to show overlays or context menu. It’s really a bug with Apple’s API. In order to fix this, you need to go to System Preferences -> Extensions , and uncheck Dropbox (or any other Finder Sync application such as Box or Adobe Core Sync Helper). Then restart Finder and restart the Insync. They should now appear.


#47

@Tom_Szekeres, this is the correct answer. To add: uncheck ALL other Finder extensions (I ran into issues with Adobe CC) if you want to ensure that InSync does turn off.


#48

This was a HUGE help! Thanks! I was able to turn on both extensions for dropbox and InSync and they both show up in finder.


#49

We’ve posted an updated how-to guide on fixing the Finder Sync extension (file icon overlays and context menu) here


#50

Almost a year later…

Unfortunately, I’ve found that, even with all other Finder extensions disabled, InSync still stops registering on some folders when they’re created, requiring turning the extension off and then back on to get things working again. This, coupled with bugginess in setting sharing permissions, has lead me to drop InSync across multiple organizations and go back to vanilla Google Drive. Performance has been better across all platforms since we did this.