Fedora 27 Installation "Failed to synchronize cache for repo 'insync', disabling."


#1

Hello, all.

I was wondering if I could get some help here. I have successfully installed insync on Fedora 27; however, every type I do a dnf install in terminal, I get the following:

Failed to synchronize cache for repo 'insync', disabling.

It is quite annoying.

I assume that the repo hasn’t been updated for Fedora 27 yet. It would be nice to know when this is going to happen. I have checked other forum posts, but nothing is this new.

Any help would be great.

Cheers!


#2

Insync team, it has been over 24 hours and there is yet no reply. I am unimpressed, to be quite honest. I would like an answer ASAP, or are you going to start issuing refunds for people that are having significant trouble with this software?


#3

Hello, I just temporarily changed the insync.repo file from $releasever to 26 and it worked. Alternatively, you can just download the rpm and install that?


#4

Yes, that worked! A nice “short term” fix.

I say short term, because it doesn’t look like they’re putting much effort into updating this software. Might bite the bullet and go with Dropbox.


#5

Personally I think that is a good product and haven’t had any issue with it so far to be honest. BTW, I am not in any way associated to the company :slight_smile:


#6

Sorry for the late response! Tagging our engineer @jimperio and he will get back to you.


#7

Hello @crowdanr we’ll be updating the repos within this week, really sorry about that!


#8

Same here, no major complaints so far. I personally think it is natural that it takes a couple of days for a new repository to be available, because some proper testing needs to be done. F27 has been released merely a week ago, give the guys some time to catch up :wink: Other softwares also take some time (eg. Oracle hasn’t released yet a VirtualBox version for F27).

Having said that, what I do believe insync could do in the meantime as a workaround is to redirect F27 repo queries to F26 repo (just as Oracle does with VirtualBox). If you try to access http://download.virtualbox.org/virtualbox/rpm/fedora/f27 there is no error, but you end up on http://download.virtualbox.org/virtualbox/rpm/fedora/f26


#9

I’m sorry, but no. There are regular release cycles for the majority of the distros that they support. So, to give this company a heads up… Fedora 28 will be released in six months. That gives you enough time to sort out repositories, fixes and compatibility issues.


#10

Fair enough, they could indeed test it before the stable release, with the alpha and beta versions. I am personally used to waiting for a few days (provided the previous version works), but your point is valid.


#11

You said that several weeks ago.


#12

You’ve got some unhappy customers. See Doesn’t work on Ubuntu 17.10.


#13

Hello everyone, we’re really sorry for the delay, but our YUM repo has now been updated to support Fedora 27.


#14

Hi Friends:

I’m still getting this on Fedora-26 (and have been for a week or two).

Failed to synchronize cache for repo 'insync', disabling.

Has this been fixed?

Here is my inSync.repo contents:

[insync]
name=insync repo
baseurl=http://yum.insynchq.com/[DISTRIBUTION]/$releasever/
gpgcheck=1
gpgkey=https://d2t3ff60b2tol4.cloudfront.net/repomd.xml.key
enabled=1
metadata_expire=120m

#15

Bumping this because I seem to be running into this warning on Fedora 30:

insync repo                                     3.6 kB/s | 300  B     00:00    
Failed to synchronize cache for repo 'insync'
Ignoring repositories: insync

Contents of repo file

[insync]
name=insync repo
baseurl=http://yum.insynchq.com/fedora/$releasever/
gpgcheck=1
gpgkey=https://d2t3ff60b2tol4.cloudfront.net/repomd.xml.key
enabled=1
metadata_expire=120m

#16

I’ve been the same problem, I’m waiting for a solution from support.