Files disappearing after moving/deleting

There is an issue happening for about a month with the folders synced to my laptop: whenever I move or delete a file, all other files “disappear” for all folders. The folder structure, however, remains the same (basically, I can see the folders, but not their content). But it appears to me that these files are being kept somehow “hidden”, because when I create a new file in one of those folders using Google Drive on browser, Insync downloads the new file to my machine and all files appear once again. If I don’t create new files, though, there is no way of making the old files appear again. Sometimes they appear again after reboot, but it happens only sporidically (sorry, it’s difficult to describe exactly what is happening)

I’m using Linux Mint 18.1 Serena 64-bit

Anyone has seen any similar issues?
Best Regards

When directories and files all “disappear”, can you see them from a shell? Just trying to isolate if it is the UI failing somewhere (it seems that is what it is).

Tested it: I have browsed the folders using the terminal to see if I could find any files. They are not there. So, it’s like they have been erased. The only weird thing is that, if I create a file on Drive through the browser and this file is synced, all the old files appear again instantly, no download delay.

That is quite odd. Maybe @terpua can shed some light then. I don’t run Linux, but macOS.

@Gabriel_Ullmann: Apologies for the trouble. Please send your logs to for investigation: How to find the log files.

1 Like

I am having similar issues but mine do not reappear when I add another file to the folder. I just searched drive and found one of the files and it shows it is in the correct folder but does not show in the list. All of my folders show that they are empty. I run insync on both a home and school computer and had to move the drive location of the folder at work. I am not sure if this caused the issue but I am panicking since I can’t see any of my files and it appears it is deleting many important files. Did you find a solution?

For me I believe one of the problems was a shared folder, in which there was a Windows “thumbs.db” file. During synchronization, I would always see an error “You don’t have permission to delete thumbs.db” (or some similar message) on the Insync “Errors” tab. After unsharing the folder, and syncing my files again the problem was solved.