[fixed] CentOS stream 9 Linux first login - Unexpected error CurlError: 60

Im using CentOS stream 9 x86_64 kernel version 5.14.0-402.el9.x86_64.
I installed the repo key and repo and used dnf to install the rpm, which all worked fine.

When I run Insync and try to login on using the web method it just hangs. If I use the alternative method with key from google drive I get ;

Unexpected error CurlError: (60, ‘SSL certificate problem: unable to get local issuer certificate’)

I removed the package many times and retried many time with no success.

I am having the same problem with 3.8.7.50508. I am packaging it for NixOS, using ubuntu binary package:

INFO     2024-01-07 19:01:58,517 [httpclient:request:192] Curl error CurlError(60, 'SSL certificate problem: unable to get local issuer certificate') while requesting to 'accounts.google.com'.

fixed with new update to insync-3.8.7.50516 . . . Thanks!!

1 Like

Thank you for the update, @ryjguy7 ! :slight_smile:

@hellwolf, let me know if updating to the latest version resolves the error.

I am getting new errors:

js: Failed to load https://app.posthog.com/decide/?v=2&ip=1&_=1709337015547&ver=1.26.0: The value of the 'Access-Control-Allow-Origin' header in the response must not be the wildcard '*' when the request's credentials mode is 'include'. Origin 'file://' is therefore not allowed access. The credentials mode of requests initiated by the XMLHttpRequest is controlled by the withCredentials attribute.