[FIXED] InSync crashing when "open window app" is selected in tray button (Debian 11)

Insync seems to be working correctly, except when I try to open its window. There was no problem two days ago.

insync show also fails.

I’m running Insync 3.7.7 (from apt repositories) in Debian 11.

Error:

Failed to create OpenGL context for format QSurfaceFormat(version 2.0, options QFlags<QSurfaceFormat::FormatOption>(), depthBufferSize 24, redBufferSize -1, greenBufferSize -1, blueBufferSize -1, alphaBufferSize -1, stencilBufferSize 8, samples 0, swapBehavior QSurfaceFormat::DefaultSwapBehavior, swapInterval 1, colorSpace QSurfaceFormat::DefaultColorSpace, profile  QSurfaceFormat::NoProfile) 
Fatal Python error: Aborted

(many lines cut off)

Current thread 0x00007f465121c740 (most recent call first):
  File "idesklinux/htmlui_impl.py", line 96 in show
  File "idesklinux/qtutil.py", line 55 in wrapper
  File "ideskui/htmlui.py", line 73 in show
  File "ideskcore/insync_core.py", line 104 in show_app_dialog
  File "ideskcore/insync_core.py", line 101 in on_tray_icon_click
  File "idesklinux/statusmenu_impl.py", line 46 in on_activation
  File "idesklinux/app.py", line 85 in start
  File "idesklinux/app.py", line 90 in run
  File "insynclinux/gui/cli.py", line 94 in start
  File "site-packages/click/core.py", line 760 in invoke
  File "site-packages/click/core.py", line 1404 in invoke
  File "site-packages/click/core.py", line 1657 in invoke
  File "site-packages/click/core.py", line 1055 in main
  File "site-packages/click/core.py", line 1130 in __call__
  File "insynclinux/gui/insync.py", line 19 in <module>

This started happenning to me, too. Out of nothing. Ubuntu 18.04 with upstream kernel and Mesa 22.

Here’s more info: 20.04 Insync GUI (version 3.7.7.50360) crashes . It is a known bug. Downgrading to 3.7.6 should help.

1 Like

Hey @peci1 and @jander,

A fix has been lined up for the Debian 11 crashing issue on 3.7.7! We’re running a few more tests to ensure that we have a smooth release :slight_smile:

Same here (Insync version 3.7.7.50360 on Ubuntu 20.04)

1 Like

Hi @spyrostheodoridis !

Could you send the output of:
lsb_release -c
apt-cache policy insync

Thank you!

FWIW, I am having the same problem with Debian Sid.

$ lsb_release -c
Codename:       sid
$ apt-cache policy insync
insync:
  Installed: 3.7.7.50360-buster
  Candidate: 3.7.7.50360-buster
  Version table:
 *** 3.7.7.50360-buster 500
        500 http://apt.insync.io/debian buster/non-free amd64 Packages
        100 /var/lib/dpkg/status

Downgrading to 3.7.6 works.

Hey all, please give these builds a try and let us know if the crashing issue persists:

Insync 3.7.8 for Linux users

Hi Mia,
here’s the output:
$ lsb_release -c
Codename: focal
apt-cache policy insync
insync:
Installed: 3.7.7.50360-focal
Candidate: 3.7.7.50360-focal
Version table:
*** 3.7.7.50360-focal 500
500 http://apt.insync.io/ubuntu focal/non-free amd64 Packages
100 /var/lib/dpkg/status

Hi Mia,
the problem still persists even after the 3.7.8 update.
Spyros

The newer builds still crash in Debian 11.
Version 3.7.6 working fine.

1 Like

@jander @spyrostheodoridis Thank you for the feedback and my apologies for the persistent issue on 3.7.8.

Could you please email your logs.db and out.txt files to support@insynchq.com with the link to this post, if you have not? We will look into the crashing issues so we can line up a permanent fix for it.

Hello! For Debian 11 (Bullseye) users who tried the v3.7.8, could you please download this again? https://www.insynchq.com/downloads

For reference, the previous release I posted provided a Buster build instead of Bullseye, and this might be a factor as to why some users have reported that it’s not working as expected. We truly apologize for overlooking this detail.

Let us know how it goes! @jander @finotti

I got insync_3.7.8.50362-focal_amd64.deb from here and it is working fine on Debian 11. The packages for xenial and bionic still crash.

I didn’t send the logs… Where can I find logs.db and out.txt? If they still matter I’ll be happy to help.

Anyway, the issue seems to be solved.

Can we get an rpm to test this? I’m on opensuse tumbleweed.

Hi @klm,

I’ll raise this to our engineer. Is it related to openSUSE Leap 15.4 Support by any chance?

Hi @jander,

You may still send your logs.db and out.txt files. Apologies for not including this in the previous replies; the logs can be found in ~/.config/Insync.

Doesn’t seem like it. My error is pretty much like this one, insync will load into the tray but will crash if I try to open it. I’m using the insync repo (http://yum.insync.io/opensuse-tumbleweed/rolling/) but it’s still at 3.7.0.

@klm Gotcha, will update you once I have more info from our team :slight_smile:

@klm Btw, could you run insync start --no-daemon and send the output either here or via email (support@insynchq.com)? Thanks :slight_smile: