Fontconfig warnings and errors

Ubuntu 19.04
GNOME Shell 3.32.2
Insync 3.0.22.40446

/home/user/.config/Insync/out.txt is 10.5 MB, with over 47,000 lines of Fontconfig warnings and errors. For example:

Fontconfig warning: "/etc/fonts/conf.d/70-no-bitmaps.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/80-delicious.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/80-delicious.conf", line 5: unknown element "its:translateRule"
Fontconfig error: "/etc/fonts/conf.d/80-delicious.conf", line 5: invalid attribute 'translate'
Fontconfig error: "/etc/fonts/conf.d/80-delicious.conf", line 5: invalid attribute 'selector'
Fontconfig error: "/etc/fonts/conf.d/80-delicious.conf", line 6: invalid attribute 'xmlns:its'
Fontconfig error: "/etc/fonts/conf.d/80-delicious.conf", line 6: invalid attribute 'version'
Fontconfig warning: "/etc/fonts/conf.d/90-synthetic.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/90-synthetic.conf", line 5: unknown element "its:translateRule"
Fontconfig error: "/etc/fonts/conf.d/90-synthetic.conf", line 5: invalid attribute 'translate'
Fontconfig error: "/etc/fonts/conf.d/90-synthetic.conf", line 5: invalid attribute 'selector'
Fontconfig error: "/etc/fonts/conf.d/90-synthetic.conf", line 6: invalid attribute 'xmlns:its'
Fontconfig error: "/etc/fonts/conf.d/90-synthetic.conf", line 6: invalid attribute 'version'
Fontconfig error: Cannot load config file from /etc/fonts/fonts.conf

Any thoughts?

1 Like

I had related fontconfig errors and warnings, the following fixed it for me:

2 Likes

Let me know if the solution linked works for you also @jmooring!

I terminated insync, then:

rm ~/.config/Insync/out.txt
cd /usr/lib/insync/
sudo ln -s -f /usr/lib/x86_64-linux-gnu/libfontconfig.so.1 libfontconfig.so.1
sudo ln -s -f /usr/lib/x86_64-linux-gnu/libfreetype.so.6 libfreetype.so.6

Then I restarted Insync and examined ~/.config/Insync/out.txt. The fontconfig warnings and errors are no longer present.

Please note that this is not a solution; it is a hack. Please fix the underlying problem. Thanks.

1 Like

Thank you soooooo much @jmooring for this help.

I’m running Pop!_OS 20.04 and this managed to solve my problem…

It’s kinda bizarre since Insync worked at first and stopped working after a week or two. Couldn’t find why!!!

I didn’t receive a response from the support team yet :expressionless: . I can’t see why it’s not solved yet!

Thanks again! My precious hard work can be synced again!!!