HiDPI / Retina displays and Insync version 1.2.3


#1

HI,

Just like to mention that using HiDPI laptop screen on linux, the new Insync menu is ridiculously small.

I am running Linux Mint 17 on a Dell M3800 workstation which has a Quad HD screen (like a MacBook Pro Retina screen)
Resolution is 3200 x 1800 pixels.

Consequently, the InSync menu is shown approximately half the size it should be.
I have a screenshot of this but I can’t upload it as I’m a ‘new user’ and Discourse won’t let me.

M


#2

Hi @Marcus_Baw ,

Apologies for the new user image ban. It’s been removed. Would you please show us a screenshot? Thanks!


#3

My laptop screen is 15" so you can see there’s a lot of pixels on there. Try scaling the uploaded screenshot until it’s 15" diagonally and you’ll get an idea what the menu looks like on my screen. The InSync menu is about 1/2 the size it should be.

Possible solutions: Could you include some kind of setting for an user interface scaling factor? (perhaps in an ‘Advanced Settings’ panel or similar) In my case I would want to be able to set the scaling factor to 2.00, but there may be others with an intermediate screen resolution who would want some non-integer between 1.00 and 2.00.

M


#4

I have the same issue, have you in plan to resolve this? I have an 4k screen and I have difficulties to read the UI of insync.
thanks


#5

@Marcus_Baw @kimlop: We are aware of this issue and currently working on a fix :smile:

Thank you for your support and understanding.


#6

Hi there, I just upgraded to a new laptop and I’m having the same problem. I hope you find a solution soon. Cheers.


#7

@spacepluk We are now working on this. Fix will be available real soon.

Thank you for your patience. :smile:


#8

I am very glad you are working on a fix. I just wanted to pop in and mention that I am using Manjaro linux on a HiDPI Lenovo yoga 2 pro (3200x1800 ~13 inch screen) and I have this same issue. Looking forward to it being resolved.


#9

@Peter_Edge Thank you for your patience and understanding :smile:


#10

I’m having the same problem. As soon as UI is readable I will surely buy a license :wink: great product!


#11

Is there any update on this issue?


#12

Hi I have the same issue of not scalling the Insync GUI on 4K display with Ubuntu 14.04 and Unity.


#13

@Michal_Mlejnek: Please send the output of the command gsettings get org.gnome.desktop.interface scaling-factor, thanks.


#14

Ok, here’s the output

uint32 1


#15

Any news? I have the same issue on a UHD screen (3840x2160). InSync is ridiculously small.

May I kindly suggest to follow suit in existing desktop applications rather than to create yet another scaling setting? I have configured my KDE desktop to use a scaling factor of 1.5 and have increased the system DPI to 168 so that I get reasonable sizes in applications that use these settings (which actually most applications do). Adding separate DPI settings for each application doesn’t make it easier to use.


#16

@Michal_Mlejnek: How did you enable scaling in your desktop? Did you change the scale value in the Display settings: http://i.stack.imgur.com/rK9ep.png? What is the value in your case?

@EWal: Scaling is only supported on GNOME based desktop environments currently, apologies. The org.gnome.desktop.interface scaling-factor value in gsettings is the one used by GNOME, so it’s not a new scaling setting.


#17

Yes I enabled the scaling and in my case its 1.5


#18

I also have the same problem. The scaling-factor for me is 2. But insync does not seems to honor it

Valerio


#19

@Michal_Mlejnek: I see. Currently Insync only scales in whole number steps (x2, x3, etc.). Since your scaling value is 1.5 it’s rounded down to 1. This will be changed in a future release.

@Valerio_Mariani: What Linux distribution and version are you using, and what desktop environment?


#20

I tried with: Unity on Ubuntu 16.04 and Gnome 3.18 on Fedora 23

Thanks for looking into this