High resolution/DPI causes app window to be too small/unreadable


#1

It’s like… teeeeeeeny tiny. Wondering if there is a fallback to the old, native menu.


#2

@allan We’re not working on a fallback to the old native menu for now, apologies for the inconvenience.


#3

@allan But we’re currently looking into fixing the high resolution scaling issue in Linux.

Thanks for your feedback.


#4

Thanks @lpugoy and @marte! Not sure if it’s an nw.js app (sure looks like it), but if it is–please expose the --force-device-scale-factor=2 flag as a launch option. I use this with great success on many other apps, and it could be a quick, easy fix.

As it stands, I can only use the UI if I put my face like 2 inches from the screen. Thanks, and keep up the good work!


#5

Hi all. Still have this in the latest version. Newer versions of Chromium and Electron fix this by default. Not sure about nw.js but I wouldn’t be surprised. The app is very hard to use on my Linux laptop. Thanks!


#6

I would try running sudo gsettings get org.gnome.desktop.interface scaling-factor and see what you get – setting this to 1 using gsettings set org.gnome.desktop.interface scaling-factor 1 fixed this issue.


#7

any update on this issue? it’s really hard to use…

attached screenshot:


#8

@cvasilak: What Linux distribution and version and what desktop environment are you using?


#9

Hi lpugoy,

I am using Fedora 24 which comes with Gnome 3.20 Desktop environment.

Thanks!


#10

@cvasilak: I see. How did you enable the scaling? Did you use gnome-tweak-tool?


#11

No I haven’t used any tool it’s all the defaults that come with the environment.


#12

@cvasilak: Do you mean that your display was scaled automatically? I didn’t encounter that in my test.


#13

Hi lpugoy,

that’s correct, haven’t made any changes to any settings, my assumption is that HiDPI settings are honored in Gnome shell, but can be wrong.

Let me know if you have any suggestions. Thank you


#14

@cvasilak: I see. Please try running the following commands:

  • gsettings get org.gnome.desktop.interface scaling-factor
  • gsettings get org.gnome.desktop.interface text-scaling-factor
  • gsettings get org.gnome.settings-daemon.plugins.xsettings Gdk/WindowScalingFactor

#15

Hi @lpugoy

after playing with the HiDPI instructions as suggested in the Arch Wiki[1], somehow it got fixed and the application window is currently displaying correctly.

Thank you for your help!

[1] https://wiki.archlinux.org/index.php/HiDPI


#16

@cvasilak: Glad to know it worked for you. Let us know if you encounter any more issues.


#17

I am having this issue to. New System 76 laptop with Ubuntu 18.04. The app window is so small it is unusable, regardless of the display settings I use.


#18

Running gsettings set org.gnome.desktop.interface scaling-factor 2 fixed it.


#19

App is again too small to be used on my laptop with a high resolution screen. Issue has return with latest update (v1.5.2). Previous gesettings trick no longer works.


#20

Hey @seth,

Thanks for bringing this up. I’ll raise this issue with our engineer. :slight_smile: