Insync (manic) -] : Access denied (13)

Sstem info:
Operating System: Kubuntu 24.04
KDE Plasma Version: 5.27.10
KDE Frameworks Version: 5.113.0
Qt Version: 5.15.10
Kernel Version: 6.6.0-14-generic (64-bit)
Graphics Platform: X11
Processors: 2 × Intel® Core™2 CPU 6700 @ 2.66GHz
Memory: 5.7 GiB of RAM
Graphics Processor: NVC3

insync (manic) not starting on Ubuntu Noble …

what does this mean? how do i set correct permissions?
“[18674:18674:0209/] : Access denied (13)”

INFO 2024-02-09 15:21:01,791 [mainlogs:_log_run:138] Core(app_version=, platform=Linux-x86_64-ubuntu/24.04) initialized
WARNING 2024-02-09 15:21:01,815 [base_events:_run_once:1782] Executing <Task pending coro=<init() running at ideskcore/> wait_for=<Task pending coro=<SettingsMain._load_settings( ) running at ideskcore/> cb=[_log_tb_after_delay() at ideskasync/, <TaskWakeupMethWrapper object at 0x7a2ee173ab50>()] created at ideskcore/> cb=[_log_tb_after_delay( ) at ideskasync/, _chain_future.._call_set_state() at asyncio/] created at asyncio/> took 0.129 seconds
INFO 2024-02-09 15:21:01,902 [mainsettings:_load_settings:236] Loaded settings, machine fingerprint = axKVH50AHtoWwkWP2zxrTQ0zixI=
[18674:18674:0209/] : Access denied (13)

Let me escalate this to our Linux Team for investigation so we can deploy a fix/workaround as soon as possible.

Thank you for reporting this, and my apologies for the trouble, @Andre_Verwijs!

found solution for:
“[18674:18674:0209/] : Access denied (13)”

its apparmor (security)

add this to /etc/sysctl.conf:

kernel.apparmor_restrict_unprivileged_userns = 0
kernel.apparmor_display_secid_mode = 0
kernel.apparmor_restrict_unprivileged_io_uring = 0
kernel.apparmor_restrict_unprivileged_unconfined = 0
kernel.apparmor_restrict_unprivileged_userns = 0
kernel.apparmor_restrict_unprivileged_userns_complain = 0
kernel.apparmor_restrict_unprivileged_userns_force = 0

I’m not familiar with the deeper configurations of apparmor, but is it safe to set these settings?

I can confirm that your setup also fixed my problems with insync, I’m glad about that and thank you very much.

But should I be worried about these settings?

Do you know if these settings are actually better to be enabled?


Hello! I’m following up with our Linux Team so we can deploy the necessary fixes to ensure this doesn’t occur again.

Thank you!

Hi @Andre_Verwijs @neuhausjulian

We have an updated build for Ubuntu 24.04. Please update all system packages first before installing the build
Let us know if it has issues for you

@neuhausjulian I believe it’s better to keep those settings enabled

1 Like