Insync 3.9x vs previous version

Insync 3.9x will not open, the previous version worked fine.

Henry

PS: Using Ubuntu 24.04

2 Likes

Same here, reported in another thread. Had no issues until I did a clean install of the beta a couple of days ago.

1 Like

I installed Fedora 40 RC and Insync 3.9 works fine.

Henry

1 Like

Hello @hewjr100 @Iain_Hamilton!

For APT: please check your /etc/apt/sources.list.d/insync.list file and make sure it’s updated based on your distribution.

For YUM: check your /etc/yum/repos.d/insync.repo file to make sure it’s the correct distro. Then do sudo yum install insync.

Thank you!

1 Like

Manually downloaded the Debian/12.5/bookworm version directly from the insync web site and installed. just runs as a process, uses no cpu, does nothing. Reinstalled the previous version from .deb file. Runs fine. Broken it seems. Perhaps since the release notes state that this release provides security improvements, there is a login procedure we need to follow?

Hi @freelsjd,

Let me forward this to our engineer for further investigation.

Hi @freelsjd

Can you send us the output of:
lsb_release -a
apt-cache policy insync

Also, are your system packages updated? You can check by running sudo apt update && sudo apt upgrade

1 Like

Thank you for responding,
lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description: Debian GNU/Linux 12 (bookworm)
Release: 12
Codename: bookworm

More precisely

cat /etc/debian_version
12.5

Of course, I routinely update/upgrade using apt; at least daily.

Incidently, insync is not updating though apt. In order to upgrade, as stated above, I had to download manually from the insync web site, and manually dpkg -i that file. That is what the report above states and how I determined it is not working,

apt-cache policy insync
insync:
Installed: 3.8.7.50516-bookworm
Candidate: 3.8.7.50516-bookworm
Version table:
*** 3.8.7.50516-bookworm 500
500 http://apt.insync.io/debian bookworm/non-free amd64 Packages
100 /var/lib/dpkg/status

With v3.9 manually installed with dpkg -i

apt-cache policy insync
insync:
Installed: 3.9.0.60000-bookworm
Candidate: 3.9.0.60000-bookworm
Version table:
*** 3.9.0.60000-bookworm 100
100 /var/lib/dpkg/status
3.8.7.50516-bookworm 500
500 http://apt.insync.io/debian bookworm/non-free amd64 Packages

1 Like

Sending this update to Kurt. Thank you, @freelsjd!

Hi @freelsjd

We haven’t updated our repos yet to the v3.9 version, but we’ll update it soon

Also, what’s your desktop environment? Unfortunately, I’m not encountering the same issue you are experiencing in Debian 12.5

Additionally, can you try re-installing v3.9 via:
sudo apt remove insync && sudo rm -r /usr/lib/insync
sudo apt install ./[INSYNC INSTALL FILE]

1 Like

Hello Kurt_Ko

Thank you for responding. The desktop I am using is Trinity Desktop Environment (TDE) now at 14.1.2. It still works fine at the previous version of insync. I implemented the more rigorous remove/install steps that you recommended above, and still no luck. Here is the output to the console:

sudo apt install ./insync_3.9.0.60000-bookworm_amd64.deb
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
Note, selecting ‘insync’ instead of ‘./insync_3.9.0.60000-bookworm_amd64.deb’
The following NEW packages will be installed:
insync
0 upgraded, 1 newly installed, 0 to remove and 2 not upgraded.
Need to get 0 B/163 MB of archives.
After this operation, 417 MB of additional disk space will be used.
Get:1 /commercial/insync/insync_3.9.0.60000-bookworm_amd64.deb insync amd64 3.9.0.60000-bookworm [163 MB]
Selecting previously unselected package insync.
(Reading database … 1013351 files and directories currently installed.)
Preparing to unpack …/insync_3.9.0.60000-bookworm_amd64.deb …
Unpacking insync (3.9.0.60000-bookworm) …
Setting up insync (3.9.0.60000-bookworm) …
OK
Insync installation has finished. You may now start it.

fs.inotify.max_user_watches = 1048576
Processing triggers for gnome-menus (3.36.0-1.1) …
Processing triggers for man-db (2.11.2-2) …
Processing triggers for shared-mime-info (2.2-1) …
Processing triggers for mailcap (3.70+nmu1) …
Processing triggers for bamfdaemon (0.5.6+repack-1) …
Rebuilding /usr/share/applications/bamf-2.index…
Processing triggers for desktop-file-utils (0.26-1) …
Processing triggers for hicolor-icon-theme (0.17-2) …
Scanning processes…
Scanning processor microcode…
Scanning linux images…

Running kernel seems to be up-to-date.

The processor microcode seems to be up-to-date.

No services need to be restarted.

No containers need to be restarted.

No user sessions are running outdated binaries.

No VM guests are running outdated hypervisor (qemu) binaries on this host.

The “fs.inotify.max_user_watches = 1048576”? Perhaps a limit that previous version did not have ? Yes, I found this entry in /etc/sysctl.conf

added by Insync

fs.inotify.max_user_watches=1048576
Was this something I put in or automatically by insync ?

Anyway, I can go back to the previous version to keep using insync.

Are you actually running Debian 12.5 to be consistent with this test? I am not the only person who has had this similar issue in this thread.

Also, just to be clear, insync 3.9.0 starts but seems to stay hung in a loop and never shows an icon in the systray, nor runs the instances of “usr/lib/insync/PySide2/Qt/libexec/QtWebEngineProcess”. By all appearances it seems “hung in a loop”. Whereas, the previous version within a few seconds after starting, the systray icon comes and the 3 instances “usr/lib/insync/PySide2/Qt/libexec/QtWebEngineProcess” appear in the process list. Just something missing in 3.9 here.

2 Likes

Hi @freelsjd

Yes, I’m testing on a fresh install of Debian 12.5 using GNOME, I’ll test it out using TDE

1 Like

Kurt Ko, I can also login under gnome desktop and see if it works there and report back here.

Kurt Ko,

I started up gnome and insync behaves identically to what it does in tde. That is, under 3.9, it issues the start command and never goes beyond that point. I have left it for 24 hours just to make sure it wasn’t resetting all configuration or something. Then I reinstall 3.8.7, restart it, and all works as normal.

I did notice that the 3.9 install was running the 3.8.7 apt postinst which did not make sense. Must be some stray apt from previous version ?

1 Like

Hello @freelsjd,

Sending this to @Kurt_Ko to notify him of your findings. Thank you very much :slight_smile:

Hi @freelsjd

I see, does insync show bring up the UI?

Could you quit Insync and then send us the output of insync start --no-daemon ?

Hello Kurt_Ko.

One thing I just thought of that might explain. I use the commercial nvidia graphics package that is available directly through debian package system these days. I do not use Wayland which is the default. Maybe that could have something to do with this ?

To answer your questions, with v3.8.7.50516 “insync show” certainly works. With v3.9.0, no it does not because insync is not starting and that is the error message I do get.

I am attaching the outputs from “insync start --no-daemon” for both versions and the output from “insync show” error message for 3.9.

Incidently, because I do not get the gui with v3.9, I have to manually kill it using the process id.

Looks like this forum has no way to upload a .txt file ? If you want me to send the outputs, please inform me how to do it. Perhaps by direct e-mail.

Hi @freelsjd! Mia here, stepping in briefly for Kurt :slight_smile:

Could you please email the .txt file to support@insynchq.com with the link to this post? Thank you!

sent it to support@insynchq.com

1 Like

I’m pretty sure this is a Wayland compatability issue (suddenly appearing?). The app works fine in an xorg session.

1 Like