Insync 3 update fail (reverting to default folder)


I tried to update to Insync 3 and followed the steps at (Ubuntu 19.10 + Google Drive account, upgraded to

For some reason, instead of taking me to the “File matching in progress” screen, it asked me to pick which Google Drive folders to sync, which was extremely confusing since I would have thought it should already know that from the 1.5 version.

After having painstakingly picked the right folders, insync started downloading every file to sync, even though they were already on disk, using gigabytes of bandwidth and disk, and filling up my hard drive till it was full. :frowning:

After several rounds of trying to clear up space and unsyncing folders, I finally realised Insync had initially picked a different base folder in place of the existing one, and was therefore re-downloading all my files into the new location. :frowning:

I decided to restart from scratch by removing my account from the app, uninstalling the app and deleting the incorrect base folder. My base folder from version 1.5 is still there, untouched by 3.x but I have made changes in it when 3.x was running, assuming it would pick up the changes. Now I’m assuming that will result in conflicts/duplicates at best, if&when things start working again.

Now after re-installing the app, it doesn’t give me the option of re-using my existing folder anymore! After adding my account, the only next step I have is “Please confirm the Base Folder for your items”. I’m too scared something else is going to go wrong again to proceed now. All I wanted was just to upgrade to the latest version, not download GB of stuff I already have or risk loosing my data :sob:

What should I do now??

1 Like

I had a look at this article, but when I point Insync 3.x to my existing base folder, it doesn’t say “Insync has detected that you selected an existing folder”. Instead, it takes me to the screen where I have to select which Google Drive locations to sync. This is not what I want! What am I supposed to do now??

Hi @Antoine,

So sorry you had to go through that!

Could you remove the account (if it’s been added), uninstall Insync 3.1.3 and then run 3.1.4?

After re-adding your account, you should see a “Change” button on the page where it says “Please confirm the Base Folder for your items”? It should be the blue button as shown here:

After you’ve chosen the old folder, the files should be matched to what’s on Google Drive.

That “Change” button is also available in 3.1.3. The behaviour in 3.1.4 is still exactly the same as with 3.1.3: after changing the base folder to be the old folder, I’m presented with the “Select items you want to sync” screen instead of insync doing the matching and/or picking up from where 1.5 was.

1 Like

Hi, I got no answer from you about how to fix this. I’ve tried uninstalling 3.1 and re-installing 1.5.7. Using 1.5.7 and pointing it at the old sync folder, it does detect that it is an existing sync folder and says “items will be matched and synced”, but then it proceeds to ask me which folders to sync! There are no blue badges on the folders, all the checkboxes are unticked in the selective sync UI, and I’m concerned that if I click “resume syncing”, insync is just going to wipe out everything! What am I supposed to do here??

Hi @antoine,

My apologies for not responding sooner to you!

When you are asked to “Sync now” and find that all the items are unchecked, you may click “Cancel” instead of selecting everything. Insync will still pick up the items from your sync folder and be able to file-match that with the cloud copies. :slight_smile:

Confirming that I rolled back to 1.5.7 and did the steps aforementioned, and my files have matched as expected. Let me know if you have any other questions.

I have tried that. Insync just seems to be stuck. The progress window says “Scanning for changes…” for hours, the feed is empty, and nothing else happens.

After two days, insync seems to have finally woken up and started syncing. It did do some file-matching, but it also tried to download all the content from Google Drive folders that I had only partially synced in the past (i.e., it downloaded all the subfolders from folders that were under folder that I had selectively only partially synced), which filled up my hard drive again. I had to manually un-sync and delete all those folders again.

This is incredibly unreliable. I can’t believe such basic workflows are not QA’d. I am scared of trying to upgrade to 3.x again now.

1 Like

The same thing just happened to me, so it apparently hasn’t been fixed in the last year and a half. I selected " re-use my existing Insync Folder" but it picked a different folder anyway. I had to reelect all my sync folders and then they downloaded to the wrong location.

Hi @Matt_Lichti!!

Could you please send your logs.db and out.txt files to with the link to this post? These 2 files should be found by following this guide:

This issue on Insync reverting to the default folder is a serious bug and we will look into the root cause to create a more permanent fix.