Insync fails to start with Gnome 3.20

After an upgrade to Gnome 3.20 (Arch Linux), Insync will not start.

I’ve tried a manual “insync start” and not errors are reported. Nothing syncs at that point. When I try other commands such as force_sync and quit, i get “Insync doesn’t seem to be running. Start it first.”

I’ve also reinstalled, etc without success.


I have exact same problem. (EDIT: After upgrading to gnome 3.20 in Arch Linux)


$ insync start --no-daemon
./insync: symbol lookup error: /usr/lib/ undefined symbol: FcWeightFromOpenType

Same here. I found that In GTK3.20 version, they have changed most of previous things about UI and it occured problems within most gtk themes… I guess it might be a kind of reason of this issue.

This is what I can find in ~/.config/Insync:

./insync: symbol lookup error: /usr/lib/ undefined symbol: FcWeightFromOpenType

1 Like

Same here (after upgrade to Gnome 3.20 on Arch Linux):

$ insync start --no-daemon ./insync: symbol lookup error: /usr/lib/ undefined symbol: FcWeightFromOpenType

Apologies for the trouble. If possible could you test if downgrading pango lib resolves the issue?

Yeah… It works after I downgraded from pango (1.40.0-1 to 1.39.0-1) in Arch Linux.

Additionally, there is no need to downgrade lib32-pango package.


Same here - downgrading pango makes insync start again

Same here as well; downgrading pango to 1.39.0-1 makes insync start again.

If you can’t downgrade pango lib one user has the following workaround:

One thing I did find by googling was this issue that seemed related:

It mentions libfontconfig, so I tried renaming the bundled with Insync and then symlinking the system one (from the fontconfig-infinality-ultimate 2.11.95-3 package from That seemed to have fixed the issue for now.

Thanks! :slight_smile: I had the same issue, and downgrading pango to 1.39 is a workaround that I’m happy to accept for a while.

I’d love to be notified when Insync works with the latest pango version though, because I prefer not having downgraded packages.

I got insync working on Arch using the 1.3.7 Debian 64bit package and making a new PKGBUILD that referenced that release. Thread for download link:

It works after I downgraded from pango (1.40.0-1 to 1.39.0-1) in Arch Linux.


Strangely enough, downgrading to Pango 1.39 does not resolve the error for me, I am still getting:

./insync: symbol lookup error: /usr/lib/ undefined symbol: FcWeightFromOpenType

Hey, could you go into more detail what exactly to rename and what to symlink?
That would be really helpful, thank you in advance!

For me, the following seems to work:

ln -sf /usr/lib/ /usr/lib/insync/

This will overwrite the bundled with insync and replace it with a symlink to the system library; so if you want to keep the insync one, rename it first.

To proceed more cleanly, you could also modify the insync PKGBUILD to include
ln -sf "/usr/lib/" "${pkgdir}/usr/lib/insync/"
in its package() function and then rebuild and reinstall the package.

rzels solution works for me too. I am running Xfce. Thanks!

The PKGBUILD on the AUR has been updated to include the symlink fix.

1 Like

The same here, on Gnome Ubuntu 16.04, after upgrading to Gnome 3.20
Anyway, the solution posted by rzei (create a symlink to system version of libfontconfig) worked for me.


It seems that anyone upgrading to Gnome 3.20 has the same problem; insync will not start. The problem has apparently been diagnosed. The fix is to downgrade from pango (1.40.0-1 to 1.39.0-1). Exactly what is the command to do that? Thanks!