Insync freezes up, queue gets clogged, no timeout

Insync runs for a while but the queue gradually fills up with stalled uploads. They never timeout so the number of active threads gradually reduced over a period of about 30 minutes, after which there are 12 stalled upload threads so no more uploads can start.

I can make it work again for a while by quitting and restarting the app but then is rescans the whole disk again and it is taking forever to upload all my files because I’ve had to restart it about 20 times already.

Not sure why the uploads are stalling but in any case there should be a timeout setting so the stalled uploads abort and/or retry after a few seconds of inactivity.

There should also be a setting to increase the number of threads because when 12 slots are full of stalled tasks then the whole sync process becomes frozen.

Note also that the scanning task at the top stops scanning new folders once all 12 slots are blocked with frozen uploads.

I’m running insync on Windows 11 with about 500gb of files to sync up to google drive, including many thousands of small files. It’s often very small files which stall, not usually large ones.

Possibly related to: File Sync Freezes/Stops for no reason - Linux Mint running Insync 3.0.27
It looks like that bug was never fixed but that report was on linux.

1 Like

Hi @Chris_C,

I’d be happy to check this out for you as this issue definitely sounds familiar. Could you send your logs.db and out.txt files to with the link to this post, in case you have not?

The logs.db and out.txt should be in %AppData%\Insync. Click the Windows key on your keyboard then type %AppData%\Insync. Your File Explorer should launch and direct you to the folder where your logs are located.

thanks very much. files sent.

I am having the exact same issue on Mac OSX (M1). I’ve been trying to debug it for a couple months with no results. The log files show no errors. It just seems to get overwhelmed with the large dataset. I am really frustrated because I can never get to a point where everything is synced and I really have little idea of what is and is not synced because the status indicators are all over the place.

Hi Dan, I sent the log files to Insync and they said the problem is related to “rate limiting” but they did not offer any solution. Very disappointing as I’m a paying user of Insync. I’m guessing it is triggered when a lot of very small files are uploaded rapidly together.

Obviously if Insync is uploading files too fast and triggers a rate limit, then Insync should respond by slowing down the rate it uploads files until the problem goes away and it should also retry the stalled transfers rather than just leaving them stalled. As a minimum stalled transfers should have a timeout on them so they don’t sit there forever.

There should also be configurable settings for the number of upload threads, bandwidth limits and a delay between uploads so that we can fix this ourselves if Insync is not clever enough to do it. Insync often seems to make my computer grind to a halt, I would like to be able to throttle it so it can run in the background more slowly, then it would not monopolise my internet connection and probably not trigger rate limits either.

This is really not good enough in a product I have paid for.

I also encountered a problem where Insync got into a loop uploading its own log files, then updating the log to record the upload, then having to upload the log again due to the update. Surely Insync should automatically include its own log files in the “ignore” list? I had to track them down and add them manually.

Hi @Chris_C,

Thank you for taking the time to update the post! I would like to apologize once more for the trouble, as it seems like our proposed workaround via email to have users chunk the uploads into smaller batches (manually) is not a sustainable option for you. We understand your sentiments completely and are continuously working to put this long-standing issue to rest.

I am following up on the issue with our engineers to be able to deploy improvements as soon as possible based on the more recent user reports, keeping in mind your feedback and suggestions.

Re: log files – I’ll have this brought up with our team as well to prevent issues like that moving forward.

@Dan_Mattrazzo Hi! Would you like for us to check this out to confirm the rate limit errors? If so, feel free to email your logs.db and out.txt to Do include the link to this post, and kindly address the email to me! :slight_smile: