Insync locking files on Windows

Recently I have found that Insync is locking files which it is uploading on Windows. This is causing a big problem because I am using software which is trying to create a file, do something with it, then delete it. But it keeps failing immediately because as soon as the file is created Insync opens it and then the file can’t be deleted. Did Insync always do this and can it be stopped?

Since this has happened to me again today, the reproduction steps are essentially:

  • Ensure Insync is idle
  • Create a reasonably large file
  • Try to rename, delete or move the file in explorer
  • You will most likely receive a message saying you can’t because the file is open in Insync. Obviously the larger the file, the longer Insync takes to upload it and therefore the longer it takes to be able to touch the file.

Most annoyingly, pausing Insync won’t make it let go of the file either. You have to terminate it, pause it, then create your large file. I don’t recall having this problem so much in the past, but right now it’s causing me to have Insync permanently paused, which makes it somewhat pointless.

Hi @jbr,

Can you let me know if this is happening to a particular file type or is it happening to any large file you tried to modify?

I’ll open an issue for this so we can investigate further. Could you send your log files to with the link to this post?

Just wanted to update that this is definitely independent of file type or anything like that. And the problem isn’t with large files specifically, it’s just more obvious with large files. It is quite simply that Insync is locking files while uploading them, which means if I try to write to that file during this time, I get an error. For example, I am currently working in Blender and my blend file takes about 45 seconds to upload. If I’m doing something important and keeping hitting Ctrl+S in blender to save, I get errors from Blender because it can’t write to the file. This is actually pretty dangerous - I could lose data during this time.

I sent log files a few weeks ago, will try to send more if I can.


Hi @jbr,

The latest logs would be really helpful. Could you also include the data and live folders? These are in the same location as your logs.db.

Our engineers are currently looking into this to prevent Insync from locking files in an upcoming build.

this is being worked on and we have identified the issue and a fix is coming soon :ok_hand:

1 Like

Just confirming that this is an issue for me as well. I’m working with very large video files so if I move something to the wrong directory by accident it becomes locked and I have to wait until InSync has finished uploading before I can fix the mistake. Very annoying.

Far worse, I host some databases with pretty large files in my Google Drive that change constantly while I’m working. Those files suddenly locking while manipulating them often results in application crashes.

This was one of the main reasons I held off for so long moving to V3, this issue happened on the very first day I tried V3 at launch and it completely wrecked my workflow. Within an hour I was back on 1.5.7. Unfortunately, due to some recent bugs in 1.5.7 it’s no longer an option so I guess I’m stuck with this.

Hopefully the fix comes some day, it’s been an issue since release.

this is coming in the next release: 3.1.0

1 Like

here you go!

Hey guys-- we temporarily removed 3.1.0 due to some bugs we found. We’ll repost it with the fix asap. Thanks for bearing with us!

Hi @fifthlegion @jbr,

The latest build is available here: New Insync version: 3.1.0.

Please let me know if the issue persists! Thanks! :slight_smile:

Haven’t seen this issue yet in 3.1 so it might be fixed? I’ll report back if it shows up at some point after more use.

1 Like

We deployed a fix in 3.1.0, yes! :slight_smile: Glad to know it’s working well on your end. Just shoot me an email at with your logs in case it happens again.

Thank you!