Insync-nautilus not working with Manjaro Gnome and Nautilus 3.30.3-1


#1

I just installed the application and while the standalone app seems to work fine, I get no integration with nautilus file manager. I did try several things, such as installing python2-gobject as indicated in the forum here. I also tried to adapt the code for python 3 syntax, that is, some print x statements. I also removed another extensions, so insync was the only extension installed… so now i don’t get any error message. Now i reverted everything to the default files. I installed insync and insync-nautilus from AUR.

the output of nautilus is

$ nautilus 
<IntrospectionModule 'Nautilus' from '/usr/lib/girepository-1.0/Nautilus-3.0.typelib'>
Insync Nautilus Plugin
<class 'insync_plugin.InsyncExtension'>
('[__init__ insync plugin]', <insync_plugin.InsyncExtension object at 0x7f54bd4b5280 (uninitialized at 0x(nil))>)

how could I go on?

version

Nautilus (nautilus) 3.30.3-1
insync-nautilus 1.3.12.36116-2
insync 1.5.5


#2

I got it to work. I did so many modifications that I can not pin point what was the issue, and what fixed it, if I have some time, I might install it again and check one change at a time. Possibly, what needed to be done was:

  • install python2-gobject
  • install python2-nautilus

there seems to be conflict with other extensions that uses python-nautilus, which runs python 3 by default. I could not have both running at the same time. If anyone could suggest something, I would