Insync no longer works on Fedora 28


#1

After upgrading to Fedora 28, I discovered (to my dismay) that insync no longer worked. It apparently has to do with Gnome removing the Gnome Status Icon Bar from the desktop. A workaround that worked for me was to install the Gnome Shell Extension Topicons-plus available on the Gnome Extension website. Insync still will not open as a GUI, but it will start and run where before it did not. I’m sure that there will be a fix eventually, but for now, this works.


#2

Hello @Dale_Raby,

Thank you for sharing this! I’ll raise it to our engineers so we can work on deploying a fix. :slight_smile: By any chance, have you tried to run insync show to open the GUI?

**
Update:

Could you also try the TopIcons extension (not Plus) found here? Let us know if there are any improvements. :slight_smile:


Changing InSync settings running Ubuntu with simple Gnome Desktop
#3

Hi @Dale_Raby

Sorry for the inconvenience. Can you try installing this build and let me know if it works?
Fedora 28 64-bit
Fedora 28 32-bit
Thanks!


#4

My Fedora 28 computer is at work, so I do not have it available today. As my connection at home is really bad (antenna atop a silo relayed to the house via wireless access point then routed through a WiFi extension) so upgrading one of my other computers to Fedora 28 in a timely manner is not feasible. Rockland, Wisconsin has some good points, but fast Internet is not one of them.

I will be baclk at work tomorrow and will try your new build. I am not an IT professional, so hopefully everything will go smoothly.


#5

If memory serves, “show” had no effect until after Topicons-plus was installed, and then it just showed a short dropdown menu. I will try the Topicons link before I install the new build linked to below when I get to work tomorrow.


#6

Good Morning: Topicons would display my Dropbox icon, but not my SpiderOak or Insync icons. It also created an error with even an inactive Topicons-plus extension. So far as I know, Insync was not active under Topicons.

The new build shows an RPM label as insync-1.4.7.37099-fc25.x86_64.rpm, but installs as:
Installing:
insync x86_64 1.4.7.37098-fc25 @commandline 78 M
(note the last digit is “8” and not “9”
insync-show displays a dropdown list from the right corner instead of the top center.

It seems to be working so far. I am using it with Insync-Nautilus and Topicons plus. I will advise you if something goes wrong.


#7

Confirm the same here: wasn’t working on F28. The new build works fine (1.4.7.37099-fc25)