Insync not working on Gnome 40 (with workaround)

Hi all! Apologies for the trouble. Let me forward this to our Linux team to assist further!

Just to confirm that this workaround works for me while the problem is being fixed.

QT_SCALE_FACTOR=1.5 insync start --qt-qpa-platform=wayland

Still not working with v3.3.10 @miamoran for your information.
With the
QT_QPA_PLATFORM=wayland insync start --no-daemon
it works for the moment via the terminal.
Do we have to wait for v3.4.x or are there some fixes in a minor version?

Hi @Jonas! I’ll follow this up with our engineers to double-check where this is in our pipeline.

I appreciate the follow up!

1 Like

Fedora 34, Gnome 40, Wayland, insync 3.3.9.40955 and 3.3.10.40961

This is not working:

insync start --no-daemon
Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.
Segmentation fault (core dumped)

This command instead:

QT_QPA_PLATFORM=wayland insync start --no-daemon
Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.
QSocketNotifier: Can only be used with threads started with QThread
Using Wayland-EGL
libEGL warning: MESA-LOADER: failed to open radeonsi: /usr/lib/insync/libstdc++.so.6: version `GLIBCXX_3.4.29’ not found (required by /usr/lib64/dri/radeonsi_dri.so) (search paths /usr/lib64/dri)

libEGL warning: MESA-LOADER: failed to open swrast: /usr/lib/insync/libstdc++.so.6: version `GLIBCXX_3.4.29’ not found (required by /usr/lib64/dri/swrast_dri.so) (search paths /usr/lib64/dri)

failed to initialize EGL display
WARNING:root:While reading /usr/share/applications/mimeapps.list
Traceback (most recent call last):
File “idesklinux/application_manager.py”, line 53, in __index_default_apps
File “configparser.py”, line 696, in read
File “configparser.py”, line 1091, in _read
configparser.DuplicateOptionError: While reading from ‘/usr/share/applications/mimeapps.list’ [line 331]: option ‘image/tiff’ in section ‘Default Applications’ already exists
WARNING:root:While reading /usr/share/applications/gnome-mimeapps.list
Traceback (most recent call last):
File “idesklinux/application_manager.py”, line 53, in __index_default_apps
File “configparser.py”, line 696, in read
File “configparser.py”, line 1091, in _read
configparser.DuplicateOptionError: While reading from ‘/usr/share/applications/gnome-mimeapps.list’ [line 331]: option ‘image/tiff’ in section ‘Default Applications’ already exists
WARNING:root:While reading /usr/share/applications/gnome-mimeapps.list
Traceback (most recent call last):
File “idesklinux/application_manager.py”, line 70, in __index_apps_for_mimetypes
File “configparser.py”, line 696, in read
File “configparser.py”, line 1091, in _read
configparser.DuplicateOptionError: While reading from ‘/usr/share/applications/gnome-mimeapps.list’ [line 331]: option ‘image/tiff’ in section ‘Default Applications’ already exists
WARNING:root:While reading /usr/share/applications/mimeapps.list
Traceback (most recent call last):
File “idesklinux/application_manager.py”, line 70, in __index_apps_for_mimetypes
File “configparser.py”, line 696, in read
File “configparser.py”, line 1091, in _read
configparser.DuplicateOptionError: While reading from ‘/usr/share/applications/mimeapps.list’ [line 331]: option ‘image/tiff’ in section ‘Default Applications’ already exists
libpng warning: iCCP: known incorrect sRGB profile
INFO 2021-05-18 09:06:20,896 [mainlogs:_log_run:139] Core(app_version=3.3.9.40955, platform=Linux-x86_64-fedora/34) initialized
INFO 2021-05-18 09:06:21,125 [fswatcher:_start:57] LinuxFSWatcher._start
INFO 2021-05-18 09:06:21,125 [inotify_manager:_pull_loop:312] Inotify loop enter
INFO 2021-05-18 09:06:21,242 [fswatcher:watch:77] watch origin: /home/andream/Insync/maan559@CIRA.IT/OneDrive Biz
INFO 2021-05-18 09:06:21,246 [fswatcher:_start:57] LinuxFSWatcher._start
INFO 2021-05-18 09:06:21,247 [inotify_manager:_pull_loop:312] Inotify loop enter
WebEngineContext used before QtWebEngine::initialize() or OpenGL context creation failed.
INFO 2021-05-18 09:06:21,303 [fswatcher:watch:77] watch origin: /home/andream/Insync/artu72@gmail.com/Google Drive
INFO 2021-05-18 09:06:21,307 [main:start_core:49] core started
INFO 2021-05-18 09:06:21,307 [unix_socket_server:start:57] unix socket server thread start
libpng warning: iCCP: known incorrect sRGB profile

apart a lot of warning, it is working.

UPDATE: I then found the workaround in this link: Insync not start and now it is working again.

1 Like

Thank you for letting me know what you tried and what worked!

Our engineers are already working on this and we will update you guys when a fix is available. :slight_smile:

From repository I have just upgraded to insync-3.3.10.40961-fc34.x86_64 and now it is all fine! Thanks.

1 Like

Hi all! Following @artu72’s update – please let me know if any issues come up after updating to 3.3.10 via the repository. :slight_smile: Thank you!

As reported in the previous post, now it is all ok. Thank you!

1 Like

Hey @miamoran

I’m also on insync 3.3.10.40961 (from Archlinux AUR) and unfortunately still have all the same issues:

  1. insync on it’s own gives “Ignoring XDG_SESSION_TYPE=wayland on Gnome”, an error about “Settings schema 'org.gnome.settings-daemon.plugins.xsettings' does not contain a key named 'antialiasing'”, and a trace/breakpoint trap/crash. I didn’t try the .so workaround posted previously (I can if it will help).

  2. insync start --qt-qpa-platform=wayland loads, but is super small and has the mouse pointer mapping issue I described previously.

  3. QT_SCALE_FACTOR=1.1 insync start --qt-qpa-platform=wayland is still the only way I can load insync (but the scaling is a little off).

  4. For all the above, no icon in the tray but insync show works. I am using a tray extension, and other tray icons are showing (Dropbox, etc)

I’m on Gnome 40 with HiDPI. I’m actually currently not using Fractional Scaling anymore, but am on Zoom 200% for the HiDPI.

1 Like

+1 with the same setup and issues

1 Like

Hey @Martin_Asenov and @gadicc!

Apologies for the trouble you’re facing. Let me check this with our Linux team.

When you can, could you please send your logs.db and out.txt files (found in ~/.config/Insync) to support@insynchq.com? Do include a link to this post for reference.

Thank you and have a great weekend!

Thank you @miamoran, have done so. Have a great weekend too :smiley:

1 Like

Just sent an email as well. Thank you for looking into the issue!

Got your logs too, @Martin_Asenov! :slight_smile: I have forwarded them to our engineers for further investigation. Thank you so much!

1 Like

My Arch linux has error like this :
Gnome 40.1
Xorg

(insync:9812): Gtk-WARNING **: 14:21:00.210: Could not load a pixbuf from icon theme.
This may indicate that pixbuf loaders or the mime database could not be found.
**
Gtk:ERROR:…/…/…/…/gtk/gtkiconhelper.c:494:ensure_surface_for_gicon: assertion failed (error == NULL): Failed to load /org/gtk/libgtk/icons/16x16/status/image-missing.png: Unrecognized image file format (gdk-pixbuf-error-quark, 3)
Fatal Python error: Aborted

Hi @PamungkasJayuda!

I’ve sent this to our Linux team and I’ll advise you on the next steps to take for your setup.

Thank you for your patience!

Hi @PamungkasJayuda

Can you send us the output of find / -name "loaders.cache" 2>/dev/null?

Thanks!

1 Like

On the latest ArchLinux AUR package (3.4.2.40983-2), this all started working again for me.

That update includes the workarounds mentioned in Crash when changing sync folders (Linux; with solution) and Crash changing sync directory (with fix).

Note: I wasn’t trying to change my sync folder. Maybe I did once a long time ago. At some point with an update, things just stopped working, or maybe it was when I upgraded to Gnome 40 and switched to Wayland.

So, with this update:

  • No special flags are needed to load
  • Sizing / scaling is all correct
  • Mouse mapping is correct
  • Tray icon is back

and everything works.

Thanks also to @miamoran who has been working with me by email for a long time on this too!

1 Like

I appreciate that you posted your updates here @gadicc!!

1 Like