Insync slows down and crashes Windows Explorer + other Bugs


#1

Hey there.

So after many attempts on Intercom and after the sending of multiple logs and dbs and no real helping answer up until today and after multiple version incrementations which did not fix the issue:

On v1.5.1 Insync still crashes Windows Explorer and slows it down significantly. It crashes when trying to create a new folder, rename files or just right-clicking anywhere on the desktop or inside the windows explorer as long as Insync is sitting in the task bar - syncing or not syncing, that does not matter: its simple presence is sufficient to create problems. I tried multiple weekends to narrow the problem down to insync and try to start and restart and quit other programs, try different physical drives as the location where the files downloaded to/synced from, multiple clean windows installations, heck I even bought a new computer.
It tried everything to solve it on my own. Problem always did reoccur. So whenever I quit Insync… my machines run well and windows behaves as it should.

A screenshot of how the windows explorer behaves: Not loading properly when starting/opening it, the green loading bar then moves extremely slowly over multiple hours to the right and nothing happens if you click anywhere. Frustrating. To create a new folder I have two options: Quit insync, create folder, restart Insync. Or just attempt to create a folder and see windows crash immediately and let it restart the windows explorer, navigate where I wanted to create the new folder in a new explorer window and then find a new folder labeled “New Folder” and then attempt to rename it - hitting enter after the renaming then results in another crash so I repeat the step with the navigation in a new explorer afterwards. Yeah. So therefore the best option is to work, without insync enabled and sync stuff at the end of the day after starting the client. Guess what? My coworkers hate me! Because no files are synced up until the end of the day! Nice! …not.

As a bonus: I get multiple “Can not sign into account blabla…” errors during the day and a lot of “Can’t start a new thread” errors although the corresponding files seem to be fine. Sometimes a restart of Insync helps, sometimes it doesn’t. Sometimes a computer restart helps, sometimes it doesn’t…

inb4: All types of drives/discs I was using were partly factory new products or not that old and read perfect health status via S.M.A.R.T. All drivers and versions of windows where updated to the latest versions. The old computer was an Intel, the new computer an AMD. Both with absolutely stable RAM-Configurations, enough computing power and stress tested for at least 2 hours on heavy load on all components with no error occuring.

PLZ HELP. I’m driving crazy and my last resolution would be calling the police. :joy: :oncoming_police_car::rotating_light:


#2

Try this for at least a temporary workaround:

  • Uninstall Insync
  • Reinstall Insync, BUT when the installer asks for admin privilege, deny it.
  • Insync will then tell you it can install without admin privilege (but some features will be limited), accept this option.
  • Continue to install and run Insync

Insync needs admin privilege to interact with Windows Explorer, to show overlay icons and add entries to context menu etc. Without it, Insync shouldn’t interfere with Windows Explorer.

It’s odd that you’re having these problems even on new Windows machine though. I’m not having such problems on Win 7 or Win 10. Could it be that another program is in conflict with Insync?


#3

Hey @JohaWeber!

Apologies for the delay. Tagging our Windows engineer @Rajat o take a look again at the issue. :slight_smile:


#6

Thank you for the tips! But sadly, I already tried to use and install Insync with and without administrator permissions… Always the same problem.

I don’t think, that another program could be in conflict with it - because it also happens if nothing is installed on a fresh windows installation than insync.


#7

Now, out of nowhere, today Insync tells me that a lot of stuff got removed although I DID NOT REMOVE any of those files nor did any of my coworkers!

I checked some of the notifications and it seems to affect both my personal Google account as well as the G Suite account of my company. BUT: when checking all the files online - everything is still there and in the Insync UI those folders are set to be synced but when checking the synced folders on the computer, those files and folders are actually removed!!! I repeat myself: Nobody did remove those files! There are a lot of team drives and folders of projects that no one is working on since … the upload of those files!

EDIT: About 50GB of data were actually moved (by insync!) in the related .insync-trash folders of the affected team-drives and at this moment Insync starts to recreate all those folders… and hopefully redownloads the files. that are still available online… wtf… I never deleted those folders/files!


#8

I experienced similar problems when testing an early test build of 1.5. In all occurrences, files remain in the cloud. So you probably don’t need to worry too much.

I do think Insync released 1.5 too early. Some more beta testing seems necessary.


#9

@JohaWeber Please send the Insync logs and dbs to us so that we could look into this. Create a copy of the “dbs” folder (present next to the logs.db file), compress it and send it to us along with the log.db file at support@insynchq.com.


#11

Any updates on this one? I have already sent the logs…


#12

Hey @JohaWeber,

I’ll follow this up again. :slight_smile:


#13

It’s now almost a week ago and I did not even get a “guess” of what could be the problem. Still a lot Errors with “can’t start a new thread”, failed access of accounts, missing folders and files, problems with the Windows Explorer and so on…


#14

Also when right-clicking on a folder or a file in the Insync UI and choosing “View on Drive Web” - there’s a 50% chance of Insync crashing and shutting down. I then have to manually restart the program…


#15

Hey @JohaWeber,

We’re been taking a look at the issue and have replied to your email. :slight_smile:


#16

@dipesh @Gregory and people that stumble across this issue and have the same problems: After unsyncing some of the folders with either lots of files (100+) or few very big files (1GB+) the windows explorer works properly again.

This temporary solution until the real issue is solved was brought to me by Insync’s support-team (just for the record).


#17

Problems still persist in the version 1.5.4


#18

There are certainly at it will manage the part for the valuable part in sync slowing down it where the crashed windows explorer and other which canon error b200 will be going it for the process to catch it.


#19

@david_brat I don’t really get your message/point - sorry! :frowning: Perhaps you can explain it further? :slight_smile:

@Gregory Still a lot of important files that get removed only on my machine (not online) and then resynced when opening the folder on drive.google.com - very frustrating! And it drives one insane when you think “I absolutely know I put the file in this folder and Insync is done with its syncing stuff and every folder and team drive and file has a green check mark on it in the UI” and then: WHOOPS! Nothing there! Taking a look at drive.google.com then shows the file in the right location. And the big resync-and-opening-files-and-folders-game starts again just to trigger Insync to download the stuff properly… Which I thought is the whole point of having insync!? To not have to worry about syncing processes? :triumph::rage:


#20

Thank you for the information.


#21

It’s possible that an earlier faulty version of Insync corrupted your sync database (specifically selective sync settings), leading to the file loss you’re experiencing now. It’s not necessarily the fault of the current Insync version.

I had confirmed similar experiences with an early test build of 1.5, and unconfirmed suspicion of a 1.4.x build. I was able to fix the problem using a custom script (playing around with GD API and SQL query) to fix all the selective sync settings in the database.

@dipesh any thoughts? Any plan on releasing tools / features for users to refresh / verify / fix their Insync database?


#22

@hawk that sound like a possible error! Any way to get this custom script?

@dipesh a function to fix / verify / refresh insyncs database would be more then helpful…


#23

The script is something I wrote myself. I don’t seem to have saved it. It’s very user-unfriendly anyway.

What it does to the database is very simple, just find the file_id of all the files & folders you want synced, and set their corresponding value to “S” (sync) in the table responsible for selective sync settings.
The difficult part is getting all the file_id’s. The most powerful method is of course playing around with GD’s public API directly, but it’s quite messy. Some tools that can probably help ease the pain are gdrive and rclone.

A caveat is that, while I’m sure this process can help prevent future file loss, I’m not sure if it can trigger a resync for files that are already unsynced.