Insync stopped working, crashes with exception

Insync worked for years. After latest update (apt upgrade) stopped working.
roman@rxps:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 22.04.4 LTS
Release: 22.04
Codename: jammy

roman@rxps:~$ insync start --no-daemon
Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.
QSocketNotifier: Can only be used with threads started with QThread
Exception in thread Thread-1:
Traceback (most recent call last):
File “threading.py”, line 980, in _bootstrap_inner
File “threading.py”, line 917, in run
File “idesklinux/app.py”, line 58, in start_core
File “idesklinux/platapp_impl.py”, line 28, in init
File “idesklinux/application_manager.py”, line 26, in init
File “idesklinux/application_manager.py”, line 82, in __index_apps_for_mimetypes
File “idesklinux/application_manager.py”, line 179, in __record_desktop_files
File “idesklinux/application_manager.py”, line 134, in __canonicalize_mimetype
File “xdg/Mime.py”, line 58, in lookup
File “xdg/Mime.py”, line 72, in new
AttributeError: ‘NoneType’ object has no attribute ‘lower’
Terminated

roman@rxps:~$ insync version
3.9.1.60010

It was installed through apt.
I tried to unuinstall and install it again with removing ~/.config/Insync between that.

Please help. Thanks,
Roman

@Roman_Gezikov My apologies! Kindly refer to my response here for more information: New Insync Version: 3.9.0

Thank you!

Hello! The fix is available when you update to 3.9.2.60014: https://www.insynchq.com/downloads/linux

Thank you!

1 Like

I confirm that version 3.9.2.60014 works. Thank you, insync team!

1 Like

Thank you for the update, @Roman_Gezikov! :slight_smile: