Insync will not update or autostart KDE Neon [with workaround]

I just installed KDE Neon 5.26. I believe the Ubuntu base for it is 20.04. I have 2 issues.

First, it will not update when I run “sudo apt update”. I get this message: The repository ‘ jammy Release’ does not have a Release file. I’ve searched but could not find an answer.

Second, Insync will not autostart. I found several posts but it seems it does not work.

Thank you.

Hello, @Ron_McIlvaine! Could you try the focal build instead?

Once you have that build installed, please let me know if the autostart issue persists. Please also let me know if you’ve set Insync to autostart on your 1) machine settings and 2) app settings.

Thank you!

@mia - Hi, I’m also having this problem in KDE Neon 5.26. I’ve worked around it for the time being, by creating an insync.service in “~/.config/systemd/user/”, and setting a delay before Insync starts.

I learnt how to do this from this thread on your forum: [workaround provided] Insync stopped starting automatically (Fedora 34, KDE)

According to the answer I received from you on the thread above, this was due to be fixed with the latest LTS release of Neon. However, when I enable “Start Insync on login” in App Settings, Insync does not run on login. I’m using Insync version 3.8.0. Any further help appreciated.

1 Like

Hi @Paul_W,

Thank you for sending the relevant details. I’ll have this investigated by our Linux team, and I’ll update this thread as soon as I have more information.

Hi! This is under investigation by our Linux team. We don’t have an ETA for the fix yet, but I’ll work closely with them to check for the progress. :slight_smile:

1 Like

@mia - Thanks for the update. I’ll keep watching this topic then, just so I can be notified of any new posts. Thanks once again! :pray:

1 Like

Appreciate it, @Paul_W! :slight_smile:

1 Like

Hi, please, try to edit apt repository from to

1 Like

@Vitor_Pereira_Barros - Hi, thanks for your help. According to my insync.list (which I found in /etc/apt/sources.list.d), I am already using the repository.

Should I try disabling my insync.service, and see whether “start Insync on login” is working now?

Hi, I don’t found yet how to make Insync autostart on KDE Neon. I’ve tried many things, but nothing worked.

Following up on this with our Linux engineer.

Apologies for the long wait, guys!

Same problem here, my .desktop looks exactly like that of Dropbox or Mega, however, they autostart and Insync doesn’t

Hello everyone and thank you for your patience as well as for the generosity in sharing your workarounds.

I will be revisiting this issue with our Linux engineer in order to line it up accordingly for a fix. Happy New Year!


Hi! Posting a @metoo… Has this issue been resolved? I just noticed this issue started for me after upgrading to Ubuntu LTS 22.04. Running KDE neon 5.26

Hi @Carlos.Thank you for reporting and my apologies for the trouble! This has not been resolved; it is still under investigation. I will be updating this thread as soon as I have more information on the next steps to take. :slight_smile:

The same problem here.

I hope the Insync Linux Team resolve it soon!

Thank you for reporting this. I have followed it up with our Linux Team!

kwriteconfig5 --file startkderc --group General --key systemdBoot false

1 Like

@Mateusz_Pietrzyk - Hi, I see that this command was mentioned in the following KDE bug report, about malformed .desktop files not autostarting with systemd boot (an issue that was first introduced in KDE 5.25):

Do you know if this is the same issue that caused this bug with Insync in KDE, or would it be better to hear back from Insync’s Linux Team?

I don’t know. It works for me.

1 Like