Insynch menu not showing when right click on folders

Hello Luis,

Are you able to see the usual right click Insync menu on the files that are being sync’d?

If the Insync folder location is not mapped to a network drive, then please send to us an email at, let’s schedule a remote desktop support session so that we could assist you further.


Hello Insync Support -

I’m on a business account and I’m having the same issue as mentioned above. Has this issue been resolved?



It would be great to have a backup from an external SD memory card.

Is there any plan to include this feature in the upcoming months?

Hi I am running Ubuntu gnome 14.04 LTE an need to add a folder on a second hard drive to insync but the right click option is not available anywhere. is there another way ?

@Matthew_S: On Windows, “Add to Insync” is not available in following scenarios:

  1. Your main Insync folder is set up on a network drive or an external drive.
  2. For files on Windows XP/Server 2003
  3. For files & folders on external/network drive on Windows XP/Server 2003

Kindly send to us the Insync logs so that we could confirm why it is not available for you.



Please send to us the Insync logs at How to find the log files

Hi dipesh -

I’m no Windows Server 2012 (like I said in my post) and my insync folder is on a local hard drive for our server. I did contact support 5 days ago via email and have yet to get support (which is very disappointing considering I pay for the Business Plan and that advertises 2 day email support). Hopefully support will email me back soon.



Hi Dipesh, Roald,

I’ve sent the logs as requested.

Please assist.


Hi Dipesh -

It’s been 21 days since I sent you the logs to my Windows 2012 Server and I’ve received NO RESPONSE. AGAIN THIS IS VERY DISAPPOINTING CONSIDERING I PAY FOR THE BUSINESS PLAN WITH PREMIUM SUPPORT.

Please respond with support.


@Matthew_S: Apologies that we didn’t get back to you after initial questions. We have not been able to get to the bottom of this issue yet. We have received a couple of other tickets where Insync icon overlays and context menu aren’t working on Windows Server 2012. We will look into this soon.


I have the same issue on my 2012 R2 server, please speed-up the fix! :smile: :stuck_out_tongue_winking_eye:

Hello guys,

Sorry for the long silence on this. For those of you, who are encountering context menu and overlay icons not working on the Windows Server 2012, here are our findings:

It appears that starting Windows Server 2012, the shell extensions registered under the HKEY_CURRENT_USER (HKCU) registry hive do not load for the default administrator. Since Insync’s is a per user installation, we use the HKCU registry hive to register the context menu and overlay icons shell extensions. This seems to be working for all other accounts (admin as well as non-admin where Insync is installed with admin rights) except for the default administrator. We think that the ideal workaround to it is to do common system wide installation for shell extensions and register those under HKEY_LOCAL_MACHINE (HKLM) registry hive. However, with the current installation scheme and auto-update implementation. this means a big change and may pose other issues. Since we have other high priority syncing issues/features to address, we have decided to defer the feasibility study of this change. Therefore, we request you to use Insync under Windows account other than the default administrator for now.

Apologies for the inconvenience caused.


i am having same problem with windows 8.1, i am logged in as a user with admin provileges.
it has workes for weeks and now disapperead. i tried to reinstall but no success.

what can i do?

@Ibottan: Did you recently upgrade to Windows 8.1 from Windows 8? Does it work for a non-admin user who has installed Insync as administrator?


Hi…no recent upgrades.
8.1 installed from scratch.

What can I do?

@lbottan: Could you check if it works for another Windows user account?

hi, i logged in as admin and it didn’t work. no sign of insync in the menu.
i tried to reinstall it as admin, nothing.

@Ibottan: Try logging in from a non-default account i.e. try creating a new windows account, install Insync and see if it works. It may not work with the default administrator. Let us know how it goes.


Hi. I have recently upgraded to Windows 10 and discovered InSync. I downloaded a trial and was going to buy but thought I should try it out first. I think am having this same issue. I see no way to add a second account after the initial installation… and I think that is my only gain with this product since google drive can do 1 account for me.

Right click shows Pause, Open or Quit. Left Click shows Feed, Progress, Shares, etc.

I tried to “run as Administrator” and tried under my regular account, which is the local administrator…

Any thoughts on when this is getting fixed? I assume this has moved up your priority list since it is now going to affect every Windows user you have not just those on Server 2012.

@susiehl02: Click the Insync tray icon and hover over to the + sign on the top right of the Insync app window, then click “Add Google account…”