Items created in cloud don't auto sync locally

Just auto updated to 3.0.20.40428 but it appears the issue was present in previous versions.

New files and directories that I create through the drive website will show up in the “My Drive” UI in insync but will not actually be created locally unless I actively click the sync button. It also appears files I create locally on my laptop that are properly automatically synced to the cloud also require actively clicking the sync button to get them locally on my desktop.

I would expect the behavior to automatically sync any cloud files to the local directory. Is there an option or something I need to set for this to happen? Thanks

I see the same behavior in Linux after the update to Insync 3. Its very annoying and doesn’t act like other cloud sync applications. I hope it is a bug that can be simply fixed.

Usage scenario:

2 computers (“computer A” and “Computer B”) and one cloud drive (“OneDrive”). Both computers A and B configured initially to sync the entire base folder.

This no longer works:

New item added to base folder on computer A → OneDrive → computer B receives new item.
New item added to base folder on computer B → OneDrive → computer A receives new item.

In order for the new item to appear on the 2nd computer, the new item must be selected on the 2nd computer in the InSync app using the “selective could sync”. It will not be included automatically on the 2nd compouter, even though it is in the base folder of the 1st computer (that was was initially set up to sync all items).

This is my experience. Forgot to mention I’m using G Drive though. So it seems:

Item(s) uploaded/created directly in [Cloud Drive] or created/synced from an Insync client are not automatically synced by other Insync client(s)

We currently have a behavior issue in Insync where we weren’t able to implement this behavior in Insync 3: Where Insync automatically uploads files or folders uploaded on root from the cloud – however, it uploads files on folders already synced.

I apologize for this. We will have this available as soon as possible.

Is the folder you’re looking for shown on the Insync window? If so, you can sync it manually from there for now.

I’m not understanding. Is the above quote maybe supposed to say

These files and folders do appear in the insynq ‘my drive’ tab but it’s tedious to manually enable syncing. Especially when I’m not the only one adding items. So now I have to check the tab every couple hours for unsynced items. Interesting that insync chose to release a version that is missing probably the highest core functionality. Hopefully implementing this is of the highest priority.

This is probably a global issue affecting all systems (e.g. Linux) and not just Windows it seems.
Often a file or folder created (even renamed, sometimes?) on Google Drive website is not synced automatically to local Drive but we need to locate it in the app window and manually poke it to sync.
If it will take long to fix this I’d rather go back to the latest insync 2.x really.
Can you please provide a link to downgrade?

This issue is fixed in an upcoming release.

1 Like

It seems this has been fixed in today’s release: 3.0.21.40435.
Thanks to the developers! :slight_smile:

Unless there is a setting I missed somewhere, the issue still remains for me in 3.0.21.40435 with windows 10 Pro 1903. In google drive web interface, I create a test folder and test file in root directory. Both appear in insync ‘my drive’ tab but will not sync unless I manually click the sync button next to each. Not sure if my computer has been rebooted since the update installed. I’ll be sure to check again after the next reboot.

It seems strangely this fix affects only the sub-folders but not the root!
I have instant autosync of iles and folders created in those folders, but still no autosync in the Google Drive cloud root folder.

Insync 3.0.22 release notes included:
Add a setting to automatically sync new cloud items under My Drive / Files and make it the default

Happy to report the root sync issue has been resolved for me in Windows 10 Pro 1903 in the latest insync 3.0.22.40446. Hopefully it’s resolved for all platforms as well. Much appreciated.

For those wondering, the setting should default to enabled but if you want to confirm or disable, you can find it on ‘My Drive’ tab then click on ‘Cloud Selective Sync’ menu. This is a per account setting.

insync%20auto%20sync%20option%20screencap

2 Likes

Unfortunately the problem still persists (here and there, new and then) as of the latest release 3.0.23 and I think I’ll go back to the latest pre-3.x release here: Insync 1.5.7 builds
I hope everything goes well with this regression.
Maybe Inync staff can let us know when this failure to autosync items created/moved in the cloud is finally and definitely over…

@jaduenas @terpua
Upgraded to version 3.0.24 but unfortunately there are still similar problems as well as some progress.

Some things done remotely gets synced locally, some don’t.

I create a file locally, move it to a Drive folder. It gets uploaded to Cloud.
I then open it (LibreOffice file - .odt, .ods) in Google format (removing the redundant extension from the name) and move the old file to the Bin as it’s no longer need.
The old file gets deleted locally but its new version is not downloaded. I have to manually poke it.

Hi @Sadi,

Auto-sync of new children (files inside folders) has been implemented in 3.0.25. :slight_smile: Could you give it a go for me?

Hi @miamoran,
Thanks. I first thought it was worse, then no change, and then I realized I forgot to manually enable auto-sync for lower level folders in My Drive as well. :wink:
Why on earth do developers choose to leave it disabled by default? :wink:
Anyway, I’m so happy that this problem is finally left behind (fingers crossed) :wink:
Best regards…

1 Like

Hi @miamoran,

I should let you know that unfortunately this seems still a bit buggy:

  1. Created a new Google Doc file, it was instantly downloaded as “Untitled document.odt”
  2. Started editing and renamed it to “Some Filename”, I could see all this in the feed, but the name of the local remained “Untitled document.odt”
  3. Manually changed (corrected) the name of the local file to “Some Filename”, syncing in both directions continued.

Hi @Sadi,

We had some backend challenges re-implementing the autosync feature since we rebuilt Insync’s core from scratch. Your constant user feedback, however, has been extremely helpful. :slight_smile:

What’s your OS? I’m on Windows 10 and have been unable to replicate the renaming issue. :frowning: It just took a couple of seconds for the rename to appear on my app and folders.

Sorry @miamoran, Windows tag above escaped my attention.
I’m on Linux Mint 19.2 (based on Ubuntu 18.04) 64-bit.