Missing files in subfolder on Linux

As per title: i’m using the last version and i’m still in trial. At first seems like the program worked well. When i checked some directory for some files i’ve found empty directories. I’ve many directories so i can’t be sure about what synced and what not.
I think this is a really bad bug because i can’t be really sure about which files are synced and which aren’t.

I’m guessing that the program dosen’t sync file deeper then 4 directories. Is this possible?

Have a look here: https://forums.insynchq.com/t/directories-sync-but-files-do-not-temp-solution/, it appears I may have found a temporary solution. In your case all directories should be o+rx and all files in those directories also need to be o+r.

Link not working! I’ve done chmod o+rx --recursive on my Google drive directory. Let’s see if it works.
Thanks in advance

Hi guys, I will tag our engineers @dipesh and @lpugoy in this and they will get back to you on this matter :smile:

@Federico_Ponzi: Please send your logs to support@insynchq.com for investigation: How to find the log files.

Hi and thanks for the support! I’ve tried that, and seems working. To force the sync of all the subdirectories, i’ve used the selective folder sync to remove and then readd a big directory. Now i’m waiting for all files being downloaded, anyway i can already see the folder more depth then 5 childs so seems working well.
I’ll let you know as soon as finished if it went good.
In the meanwhile i’ve sent the requested logs :slight_smile:
Thanks again,

Any update on this? I have a subdirectory that’s not getting synced. I wonder if there’s a name crash, as there’s a directory named “Firmware Home”. Maybe spaces are not handled properly.

@VanGaylord: Please send your logs for investigation as well.