New Insync version: 3.0.22 - macOS Catalina compatible

Release notes:

  • Add support for macOS Catalina (10.15)
  • Add a setting to automatically sync new cloud items under My Drive / Files and make it the default
  • Fix Google format files with certain special characters in their names not being downloaded
  • Better handle cases when both a file and its parent scheduled for syncing are moved/deleted
  • Improve hover menu tutorial orb positioning
  • Linux: Fix Debian Jessie builds
  • Linux: Add Dolphin file manager integration
  • Linux: Fix Nautilus file manager integration for OpenSUSE
  • Linux: Disable Insync window resizing

Windows 7 and later
macOS 10.10 (Yosemite and later)

Ubuntu (16.04 Xenial) & (18.04 Bionic)
Linux Mint (18.x) & (19.x)
Debian (8 Jessie) , (9 Stretch) & (10 Buster)
Fedora (27) , (28) , (29) & (30)

4 Likes

Thanks for the update. I see several improvements but there is one severe issue that does not seem to be fixed yet.

Can you please confirm if you are aware of this bug?

  • For me often times content from team shares sub-folders (not sure about private share as I work mostly with company team shares) is not synced from cloud to local destination.

  • For example I am going to the local folder and look into an invoicing folder where several pdfs should be but somehow two or three are missing locally that should be there.

  • When I open the insync app window and open the exact folder in the GUI the app suddenly detects that it did not yet sync all files and downloads the them.

  • I have not yet noticed any pattern - seems to be random. Sometimes several files, sometimes also sub-folders.

For me personally that is the last thing that noticeable makes working with v3.0 hard. Other than that I like the new version so far.

It’d be good if brave and good people shared their experience with this update.

I have been so burned with this v3 so far that I am very wary of making the plunge again (still on v1.57 and happy with it).

Thanks!

@Vladimir_Oka

I use multiple Insync installations on Ubuntu 19.04 w/ Nautilus integration with multiple Google Drive accounts (1 private drive, 1 company drive with a multitude of team shares).

I’m on 3.x since 3.0.15 and with 3.0.22 the only problem really bugging me is the behavior described in my post above. Luckily it does not destroy data but it causes a lot of wasted time manually syncing content that should be synced automatically.

Only other thing I am missing is the Activities section that is still under construction. That does not bother me much though, as quite similar information is visible in the status bar of the app windows anyways.

Currently no other problems and very happy with v3.

1.5 was very unreliable for me since around autumn 2018. Multiple posts to that on this forum. Don’t know yet if I want to laugh or cry but the exact same problem that makes 3.0.22 hard to use currently is bugging me since at least 1.5.5 (see Does not keep Team Drive sub folders in sync since several weeks on Ubuntu 18.10)

Funny that…

I’m on Mint 19.2 (Ubuntu 18.04 based) and 1.5.7 works just fine for me (don’t use Teams, though).

Installing 3.0.20 was insane. It was playing up in the UI to no end and also wanted to do humongous amount of syncing even though everything was already synced. And the mere “under construction” bits made me extra cautious. Who knows what other, not UI related, bits are still “under construction”.

Might well hold off on upgrading until v3 is much more mature, possibly at least past 3.1.x

Add a setting to automatically sync new cloud items under My Drive / Files and make it the default

Good to see this. It is unclear to me how v3 could be released with such blatant bugs. I’m quite annoyed with v3 given that I paid for this software. Lots of the feature that worked well in previous versions are gone now and half of the UI says “Under construction”.

Linux: Add Dolphin file manager integration

So is this built-in…? Nice to have this back.

Since upgrading to v3 and fighting with it for a few days, I am considering removing the software altogether. I use Insync with Google drive, running on Xubuntu 19.04. Any changes made to Google drive through the web interface are instantly synced to my laptop. But the other way just doesn’t work very well. Insync just doesn’t seem to pick up on filesystem activity and the only way to sync a new file to Google drive seems to be by opening the Insync app window, pausing then resuming the sync. Even then it takes about three minutes to notice the new file and upload it.
I am not keen on downgrading for fear of losing data.

Well, my ‘root’ directory I sync to/from is still frozen/locked, nothing syncs from it, cant manually select anything. Any subdir OFF that, syncs just fine. I went back to 1.5.7 and it all worked again.

I just did an apt-update on a Debian Buster machine and 1. this version actually updated through apt and 2. it finished a sync that wouldn’t finish because of errors.

So far–so good! Fingers crossed.

Thanks for the good work.

2 Likes

What about XFCE Thunar integration plugin? When will be available?? Any progress???

Hey guy does anyone know how to install the program on ubuntu arm64, I am having some issues trying to install it

Coming up on 3.0.23. :slight_smile: Emailed you about this too, @michal.kvasnicka!

Hi @Sebas_Pask,

Is this a CLI-only setup?

It is for Ubuntu 16.04 that run on Samsung Linux on dex https://www.linuxondex.com/ @miamoran

Hi @miamoran, I’m glad to know that the Dolphin plug-in is now available, but could you tell me how to install it or activate it? I have already updated Insync to version 3.0.22 and I don’t have Dolphin integration.

Hi @axius!

I responded to the other thread regarding the same question. :slight_smile: For reference, the instructions are found here: https://help.insynchq.com/en/articles/2352071-linux-installation-guide

Hi @miamoran. Do you have an ETA for 3.0.23? 3.0.22 is unusable for me at the moment. Thanks.

3 Likes