New Insync version: 3.2.3

Hi guys! This has been raised to our engineers and will update here as soon as I receive their updates.

For Linux users experiencing the issues despite the workarounds, please downgrade to 3.2.2 first while we work on this.

Hi everyone!

We found the bug, we’re working on releasing a hotfix!

In the meantime, please delete the insync[#].sock file (the [#] is a number and can vary) in the /tmp directory. Let us know how this goes.

1 Like

Ok, it works after deleting tmp file.
Env : F32 KDE

This seems to work on 3.2.4.

I updated the last version today 3.2.4 but it didn’t start.
I removed the insync[#].sock file and now it’s working.
Ubuntu 20.04

Confirmed that the fix works on 3.2.4

(Ubuntu 18.04)

I am wondering if anyone else is getting the following error on Ubuntu 20.04:

W: GPG error: focal InRelease: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY A684470CACCAF35C
E: The repository ‘ focal InRelease’ is not signed.

I have retrieved the key (successfully) using:

sudo apt-key adv --keyserver --recv-keys ACCAF35C

but no joy. Any tips on how to resolve this would be much appreciated (it seems like many others on Ubuntu 20.04 can update from the repo no problem?)

removing the insync[#].sock file from /tmp directory fixed the issue here too, on Arch Linux and version 3.2.4

Hi @hjelmj

Can you send me the contents of your /etc/apt/sources.list.d/insync.list?

Deleting the sock file makes insync works again, thanks.

Confirm this works on Linux Mint 19.1 Cinnamon. Didn’t have a problem on same system when logging into Mate.

1 Like

It works on Ubuntu 20.04

1 Like

Hi @Kurt_Ko - it is:

deb focal non-free contrib

The good news is that the error I got earlier “E: The repository ‘ focal InRelease’ is not signed.” doesn’t appear anymore. Tried it today and returned no errors, while it didn’t work 5 days ago. I guess the repo is signed now. Cheers!

1 Like

Ubuntu Mate 18.04
Didn’t work for me. I deleted the sock file, and still nothing.

After deleting the sock file from /tmp, and the program still failing to run, I reinstalled “insync_3.2.4.40856-bionic_amd64.deb” using gdebi. When reinstalling, I get a gdebi window that says “Insync installation has finished. Start Insync.”

I click the button in this window, “Start Insync”, and moments later I get a little popup window that says something about a “Critical Error” and “Will quit now”

I can confirm that removing the insync[#].sock file from /tmp directory fixed the issue on my RHEL 8.2.

Fixed worked for 3.2.4 on ubuntu 19.10.

$ rm /tmp/insync*.sock

$ lsb_release -a
LSB Version:	core-11.0.1ubuntu1-noarch:printing-11.0.1ubuntu1-noarch:security-11.0.1ubuntu1-noarch
Distributor ID:	Ubuntu
Description:	Ubuntu 19.10
Release:	19.10
Codename:	eoan

$ dpkg --list insync
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name           Version            Architecture Description
ii  insync amd64        Sync all your Google Drive & OneDrive accounts to your local filesystem

$ ps aux|grep insync
mcarifio 12550  2.5  0.4 5158604 288060 ?      Sl   09:55   0:05 ./insync start
mcarifio 12632  0.0  0.0 324620 45284 ?        S    09:55   0:00 /usr/lib/insync/PySide2/Qt/libexec/QtWebEngineProcess --type=zygote --webengine-schemes=qrc:sLV --lang=en-US
mcarifio 12634  0.0  0.0 324620  9360 ?        S    09:55   0:00 /usr/lib/insync/PySide2/Qt/libexec/QtWebEngineProcess --type=zygote --webengine-schemes=qrc:sLV --lang=en-US
mcarifio 12649  0.7  0.1 1852492 108972 ?      Sl   09:55   0:01 /usr/lib/insync/PySide2/Qt/libexec/QtWebEngineProcess --type=renderer --disable-gpu-memory-buffer-video-frames --enable-threaded-c
mcarifio 13279  0.0  0.0  12240  2664 pts/8    S+   09:59   0:00 grep --color=auto insync

I realize bugs always happen (and even I’ve created a few!), but a silent failure is pretty frustrating. This was an hour out of my life (which includes this note).

Please update to 3.2.5 (we’ll update the repos when this is released on our webpage) and let us know if startup issue persists!

For me, insync 3.2.5 and openSUSE Tumbleweed has the same issue. Removig insync[#].sock file from /tmp directory fixed the issue. But I need to do this every boot.

I have same problem in openSUSE Tumbleweed. I deleted insync[#].sock but I have to do every boot.

This need to delete on every boot will be addressed in an upcoming build :slight_smile: