New Insync version: 3.2.7

Release notes:

  • Fix error when a base folder gets deleted
  • Linux: Add completions command for bash/zsh/fish shell autocompletion

Windows 7 and later
macOS 10.13 (High Sierra and later)

Ubuntu (16.04 Xenial) , (18.04 Bionic) & (20.04 Focal)
Linux Mint (18.x) , (19.x) & (20.x)
Debian (8 Jessie) , (9 Stretch) & (10 Buster)
Fedora (27) , (28) , (29) & (30)

[edit 2]
At least the re-scan seems to have been relatively quick this time. Still unnecessary, though, methinks…
[/edit]

[edit 1]
I actually sent logs in response to 3.2.5 topic:


[/edit]

Updated from 3.2.6 and once 3.2.7 started, after a little while, it started a full re-scan.

Similar to what I experienced with 3.2.6 with just logging out of the Linux session and logging back in (not logging out of Insync).

I sent some logs linked to the 3.2.6 topic (at request at @miamoran).

I guess I could gather some logs now, too, but it’s probably redundant as changelog does not point to anything that might have affected this behaviour.

Anyway, please someone have a look as it is ridiculous to have Insync spend hours re-scanning so often!

Thank you for adding the Qt5 Wayland shell extensions in this release. This works nicely on Arch Linux and Sway compositor, running Insync as a native Wayland client for the first time.

For some reason, I couldn’t get it to work in Flatpak, the only error I’m seeing is with strace and it’s a failure to allocate memory via a mincore() call.

edit: I know what the problem with Flatpak and why it works in Arch Linux. Basically when running under Wayland, Insync tries to use the Wayland EGL backend but something not working correctly.
On Arch Linux it fails early, I’m not sure why but then it falls back to software rendering of the Wayland client.
When using Flatpak, Insync manages to go further and start talking to the GPU, requesting resources but then it fails (looks like memory allocation issue) and because it already started using the EGL Wayland backend it can’t fall back to software rendering.
The workaround I’m using with Flatpak to bypass this issue is to not give access to the GPU (/dev/dri) and then Insync just falls back to software rendering.

edit2: I think the issue is that a mismatch between some of the libs that are packaged with Insync and the host system is causing this issue. It looks like I got it to work with the Wayland EGL backend after dropping a few libs.

edit3: I removed libGL{X,dispatch}.so* and now the Wayland EGL backend seems to work.

1 Like

I’ve been having all sorts of problems syncing Google Drive for a few weeks now. I’m running Fedora 32 (Wayland). It seems to get stuck on some random file or directory - usually an old directory filled with PDFs that has not been changed in years - and my CPU gets pinned.

I have a possibly stupid question - how/why does the Windowing engine whether it be X or Wayland figure so heavily? I would assume the sync’ing engine is headless. The GUI is rather simple. What would/should it have to do with syncing operations?

Exclude folder option has been removed or didn’t work in this version… upgraded and the software and it proceeded to delete a bunch of folders that were suppose to be excluded. Why do you think software has the right to delete files? If something is “excluded” and not in the cloud ignore it - don’t delete the local copy!!!

I could restore some from the recycle bin but others were just gone… this isn’t user error, I have read all documentation and followed the support… this is a major functionality issue or bug.

These files are part of my job and I expect more from a company handling files like this!

Very PO-ed… created this account to warn other people…

Uninstalled :frowning: there is no other option by go back to google drive at this point.

I am giving up, and moving to the google app, at least on my Mac…
There are just too many bugs and things like the huge memory leak have not yet been fixed after months.
I may give another chance to insync when a usable version will be released, but for now it is really a mess :disappointed:

stuck on 3.2.6 because of this error when running apt-get update:

W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://apt.insync.io/ubuntu focal InRelease: The following signatures were invalid: EXPKEYSIG A684470CACCAF35C Insynchq Inc services@insynchq.com

System info:
$ inxi -b
System:
Host: _______ Kernel: 5.4.0-7642-generic x86_64 bits: 64
Desktop: Xfce 4.14.2 Distro: Ubuntu 20.04.1 LTS (Focal Fossa)
Machine:
Type: Laptop System: System76 product: Galago Pro v: galp3
serial: <superuser/root required>
Mobo: System76 model: Galago Pro v: galp3
serial: <superuser/root required> UEFI: American Megatrends v: 1.05.08RSA
date: 12/08/2017
Battery:
ID-1: BAT0 charge: 32.3 Wh condition: 35.9/36.5 Wh (98%)
CPU:
Quad Core: Intel Core i5-8250U type: MT MCP speed: 600 MHz
min/max: 400/3400 MHz
Graphics:
Device-1: Intel UHD Graphics 620 driver: i915 v: kernel
Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: fbdev,vesa
resolution: 1600x900~60Hz, 1920x1200~60Hz
OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.0.8
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
driver: r8169
Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi
Device-3: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152
Drives:
Local Storage: total: 1.36 TiB used: 494.57 GiB (35.4%)
Info:
Processes: 318 Uptime: 8d 23h 56m Memory: 15.52 GiB used: 4.84 GiB (31.2%)
Shell: bash inxi: 3.0.38

Hi @Vincent_Farberg! Please refer to this post: Apt key expired (with solution)

Let me know if it persists :slight_smile: