Problem with installing insync on openSUSE Tumbleweed


#1

Hi,

I am using openSUSE Tumbleweed, and I have downloaded the insync-1.3.22.36179-fc25.x86_64.rpm from https://d2t3ff60b2tol4.cloudfront.net/builds/insync-1.3.22.36179-fc25.x86_64.rpm.

When I run sudo rpm -i insync-1.3.22.36179-fc25.x86_64.rpm, at first everything seems okay, but soon it prints a huge number of no protocol specified, making the console freeze.

And after installing, when I run insync start, there will be an insync process, and it will use up one cpu core. And after 1min, it will exit like nothing happens.

In ~/.config/Insync there is only one file out.txt:

No protocol specified
insync.py: cannot connect to X server :0
No protocol specified
insync.py: cannot connect to X server :0

#2

Tagging our engineer @jimperio and he will get back to you.


#3

@JZ_H Are you aiming to use Insync on a headless system or does the machine in fact have a GUI (i.e., X window server)? Just wondering about the cannot connect to X server error message.

That is strange though. Would you mind sending the output of insync start --no-daemon to support@insynchq.com so that we may troubleshoot in more detail? Thank you!


#4

I am using openSUSE with kde.

When I run insync start --no-daemon, it will output this:

No protocol specified
insync.py: cannot connect to X server :0

And after running insync, there will be a huge increase in the cpu used by /usr/bin/X:


#5

Sorry, it seems that after the first installation, I have to kill X and relogin , then incync is ready to use.

After restarting X, insync start --no-daemon will make insync work properly. Then i ran insync start, and it starts normally.

It’s really strange.


#6

I am having the same issue now. Worked fine until I did a zypper dup (Update OS)

insync start --no-daemon gives the same error as JZ_H. insync start --no-daemon --headless works OK.

Here is what I think is the relevant strace entries:

connect(7, {sa_family=AF_UNIX, sun_path=@"/tmp/.X11-unix/X0"}, 20) = 0
getpeername(7, {sa_family=AF_UNIX, sun_path=@"/tmp/.X11-unix/X0"}, [124->20]) = 0
uname({sysname=“Linux”, nodename=“motop.codejunkie.net”, …}) = 0
access("/tmp/xauth-1001-_0", R_OK) = 0
openat(AT_FDCWD, “/tmp/xauth-1001-_0”, O_RDONLY) = 8
fstat(8, {st_mode=S_IFREG|0600, st_size=50, …}) = 0
read(8, “\1\0\0\5motop\0\0010\0\22MIT-MAGIC-COOKIE-1”…, 4096) = 50
read(8, “”, 4096) = 0
close(8) = 0
fcntl(7, F_GETFL) = 0x2 (flags O_RDWR)
fcntl(7, F_SETFL, O_RDWR|O_NONBLOCK) = 0
fcntl(7, F_SETFD, FD_CLOEXEC) = 0
poll([{fd=7, events=POLLIN|POLLOUT}], 1, -1) = 1 ([{fd=7, revents=POLLOUT}])
writev(7, [{iov_base=“l\0\v\0\0\0\0\0\0\0\0\0”, iov_len=12}, {iov_base="", iov_len=0}], 2) = 12
recvfrom(7, 0x55b31c23e800, 8, 0, NULL, NULL) = -1 EAGAIN (Resource temporarily unavailable)
poll([{fd=7, events=POLLIN}], 1, -1) = 1 ([{fd=7, revents=POLLIN|POLLHUP}])
recvfrom(7, “\0\26\v\0\0\0\6\0”, 8, 0, NULL, NULL) = 8
recvfrom(7, “No protocol specified\n\0\0”, 24, 0, NULL, NULL) = 24
write(2, “No protocol specified\n”, 22No protocol specified
) = 22
shutdown(7, SHUT_RDWR) = 0
close(7) = 0
write(2, “insync.py: cannot connect to X s”…, 41insync.py: cannot connect to X server :0
) = 41
write(6, “@”, 1) = 1
close(6) = 0
close(5) = 0
rt_sigaction(SIGCHLD, NULL, {sa_handler=0x7f60090ec950, sa_mask=[], sa_flags=SA_RESTORER|SA_SIGINFO|SA_NOCLDSTOP, sa_restorer=0x7f600fb27270}, 8) = 0
rt_sigaction(SIGCHLD, {sa_handler=SIG_DFL, sa_mask=[], sa_flags=SA_RESTORER, sa_restorer=0x7f600fb27270}, NULL, 8) = 0
exit_group(1) = ?
+++ exited with 1 +++

sgonzalez@motop:~> ls -l /tmp/.X11-unix/X0
srwxrwxrwx 1 root root 0 Feb 6 16:20 /tmp/.X11-unix/X0


#7

I was able to get it working again non-headless by logging out of KDE and running rm -rfv - - ~/.Xauthority /tmp/.X11-unix /tmp/xauth-*


#8

I have the same problem, some time it works and some times dind’t work


#9

Is there any update on this? Having to delete all the auth files is cumbersome and running headless really reduces functionality. If further details are needed I am happy to provide.


#10

Tagging our engineer @jimperio for further assistance.


#11

@sgonzalez Are you still experiencing the same issue on Insync 1.4.5? We’ll take another look at this issue. We’re sorry for the inconvenience.


#12

Yes, it is still occuring with latest insync.

sgonzalez@motop:~> insync --version
1.4.5.37069
sgonzalez@motop:~> insync start --no-daemon
No protocol specified
insync.py: cannot connect to X server :0

#13

Hi, sorry for the late response. Could you send your log files to support@insynchq.com please?


#14

I did so last week, any update?


#15

Hello, any update on this issue?


#16

Hi Sal,

Our engineers are currently working on this issue. We’ll make sure to keep you posted once we are able to resolve this. :slight_smile: I deeply apologise for the trouble.


#17

I had a hdd failure last weekend and had to re-install opensuse tumbleweed. inSync has been working fine evey day since then, I assume opensuse addressed this bug themselves or the re-install fixed it.


#18

Glad to know everything is good on your end! :slight_smile: If you need any help, just shoot us a message anytime at support@insynchq.com.


#19

I had a similar problem recently with Opensuse Leap 15.0 and Insync on one of my two machines. Got the same error “No protocol specified. insync.py: cannot connect to X server :0”.
With a little debuggin I found that the problem was that on my machine Xauthority files had the machine hostname without any domain, whereas uname reports the hostname with domain. The same difference seems to be in the strace provided in an earlier reply.
In my case I managed to solve the problem simply by adjusting my network settings.


Tumbleweed KDE5 - Unable to sart Insync
#20

I am having the same problem.
tthigpen@TonyLapTop:~> insync start --no-daemon
QIconvCodec::convertFromUnicode: using Latin-1 for conversion, iconv_open failed
QIconvCodec::convertToUnicode: using Latin-1 for conversion, iconv_open failed
No protocol specified
insync.py: cannot connect to X server :0
tthigpen@TonyLapTop:~> insync --version
1.4.9.37127

I have tried what other’s did but it still fails.

UPDATE: Re-ran the “rm -rfv - - ~/.Xauthority /tmp/.X11-unix /tmp/xauth-*” command as su and then logged off and on. Now insync is working.