[SOLVED] Cannot login after upgrade to Fedora 29


#1

Dear Support-Team,

after I encountered the same problem as mentioned in Ticket “Insync & Fedora 29” I tried to remove and add my prime account again, but neither the usual nor the alternative login are working.

Usual Login:
After browser window opens and select my google account I’m redirected to your website showing “Connecting to Insync …”. Then nothing happens.

Alternative Login:
After browser window opens I select my google account, copy and paste the auth-code into the Insync window. When clicking “Login” the auth code is removed from the field and nothing happens.

I tried insync start --debug 1 --no-daemon and got the following errors.
The first part regarding the request to www.google-analytics.com appears every 20 seconds.
The python traceback only twice.

DEBUG    2018-10-01 21:57:45,425 [clienthttpproxy:__system_proxy:102] Using system proxy: None
DEBUG    2018-10-01 21:57:45,425 [clientnet:__resolve_name_to_result:58] Resolving 'www.google-analytics.com'...
DEBUG    2018-10-01 21:57:45,494 [clientnet:__resolve_name_to_result:67] 'www.google-analytics.com' resolved.
DEBUG    2018-10-01 21:57:45,546 [clientnet:clear_name_cache:25] Address cache cleared.
DEBUG    2018-10-01 21:57:45,547 [clienthttp:request:173] Network error SSLError('failed to allocate SSL context',) while requesting to 'www.google-analytics.com'.
ERROR    2018-10-01 21:57:45,547 [clientlogging:_logged_report_error:223] Uncaught error from <AnalyticsUploaderTask at 0x7f8c00204050>
Traceback (most recent call last):
  File "gevent/greenlet.py", line 390, in run
  File "ideskmain/clienttasks/analytics.py", line 80, in _run
  File "ideskmain/clienttasks/analytics.py", line 151, in __upload
  File "idesknet/clienthttp.py", line 144, in request
  File "idesknet/clienthttp.py", line 219, in raw_request
  File "idesknet/clienthttp.py", line 238, in __request
  File "idesknet/clienthttpsconnection.py", line 93, in connect
  File "gevent/ssl.py", line 419, in wrap_socket
  File "gevent/ssl.py", line 84, in __init__
  File "idesknet/clienthttp.py", line 440, in sslwrap
  File "ssl.py", line 347, in __new__
SSLError: ('failed to allocate SSL context',)

If I should provide further information, please let me know.

Greetings
Patrick


#2

Hey @pscheid92,

What Insync version are you using? Have you downloaded the latest build here? :slight_smile:


#3

Hello @Gregory,

Sorry for missing this.
I checked it and I am using the latest build (1.5.2.37346).


#5

Hi guys,

Can you please try this build and let us know if the issue persists? Thanks!


#6

Great!
It works like a charm.
I’m now able to log in and my data is syncing successfully.


#7

Awesome! Thanks for the update. :slight_smile: Just shoot us a message at support@insynchq.com for any app issues!