Unable to sync objects with accented characters in filename

Hey guys!

Firstly, Insync rocks. It’s been solid, quietly doing its thing on a couple of my *nix boxes for months.

I think I’ve found my first bug, though. My error log has 15 entries in the form:

Can’t process [filename] - unhandled error

All of these objects have at least one accented character in the filename. Is this a known issue?



edit This is version 1.2.7 on Debian/sid (8.0) amd64, filesystem ext4 btw.

1 Like

@glambx Not an known issue so thanks for reporting :smile:



@glambx Please check if these files are encoded in UTF-8. If not try renaming them and restarting Insync. If the issue is still there please send your logs (https://forums.insynchq.com/t/how-to-find-the-log-files/19) to support@insynchq.com for investigation. Thanks.

Hmm. I’m not sure how to check if they’re UTF-8 encoded; the filenames were created by the Samsung camera app when taking photos on a street in Montreal (with French accents like é, à, etc). I pushed them to Google Drive directly from my device.

Attaching the inSync logs now.

1 Like


Indeed, the problem with accented characters is confirmed. I live in French-speaking Belgium, and use accented characters where needed to properly name my files. Unfortunately, no one file with such characters is synced by INSYNC, while they are perfectly handled on my W8 box by the Google Drive Sync utility.

Code page is French (Belgium) in Windows which, I suppose, uses single-byte characters with ASCII values above 128 for accented letters like éèçàùâêûîôäëüïö

Any help here ?

1 Like

@FVP Are you using Insync on Linux or Windows? Please send your logs as well.


Sorry for the long delay, too busy… I’m running TurboLinux (debian). Would like to send the log files, but don’t know how…

Kind regards,


@FVP Just follow the link I posted above to get the logs. Afterwards email them to support@insynchq.com. If they are too big to be emailed you could upload them to a file sharing service like Google Drive and share it with us.

1 Like

I just installed and purchased Insync Plus to be able to sync my Google Drive folders with an installation of Ubuntu 14.04 running in Crouton on a Chromebook. Filenames and folders with accented characters do not sync. Google Drive app on Windows has no problems with these files/folders. Files and folders have been created by many different programs, including MS Word, LIbreOffice, Google Docs, Windows File Manager, etc. If there is a simple setting I can configure in Insync to fix this problem, please let me know. Otherwise I will simply rename the files. I’m not interested in sending log files or reconfiguring multiple programs on my Windows machine to output in UTF-8.

@dbomeara If your locale is not set to a UTF-8 one, please try setting it then restarting Insync. You can check by running locale. The issue could also be that the file names were not encoded in UTF-8, so renaming them might also work.

Thanks! This worked.
For the benefit of anyone else with the same problem on Ubuntu 14.04:

In terminal, check locale
~$ locale
if they are all POSIX (ASCII), you’ll need to update.
see available locales on your system
~$ locale -a
then edit /etc/default/locale
for me it was
~$ sudo gedit /etc/default/locale
by default, the file was blank. I inserted the lines:
based on my actual location and the locales available on my system. I left system messages in POSIX, just to be safe. More on locale here:

1 Like

Thanks! You just saved my day! :smile:


i have an issue related to this problem. I’m on Ubuntu 14.04.
When i try to open files from Nautilus, only the files without accented chars in their name are working.
My locale is correct i think:

`[~] locale


Can you suggest anything?

@Zsolt_Janos: Apologies for the trouble. This is a known issue that would be addressed in the next release. As a workaround for now please try right clicking on the file -> Insync -> Open in Drive.

Renaming the files is not really a solution. Two reasons:

  1. Reason one: Some of the files were created directly in the Google Docs or Spreadsheets interface. We don’t know what encoding uses Google to internaly store that data.

  2. Reason two: Shared folders.

In my case - and i can say many other users too -, many of the files that are not syncing in Linux come from shared folders i don’t control, cannot enforce renaming and don’t know their content with 100% accuracy. But being shared folders i DO really need to get every bit (literaly) that my partners shared with me, with no excuse.

Someone shared the folder with me, i was asking him desperately for some graphic pieces we needed to complete a project, he said he already sent them, but i was telling him i had not them in my folder, after many lost hours i came down to realize the problem was not his, but on my side, on Insync.

I’m testing Insync to see if it suit my needs, but this isssue is going to cause more trouble than good. Not only for me but also for people in shared folders where renaming files is not an option.

@cablop: Is your locale already set to a UTF-8 locale?

If the solution is always using an UTF-8 locale, why doesn’t the insync daemon just set one? I was also bitten by this…


@spa: We’ll keep that in mind, thanks for the suggestion.

Any status when a release that fixes this will be available?
Having problems with this as well and have tried to check all locale settings in my linux box.

Files with swedish characters in their name will be ignored by Insync.

@Patrik_Falk: No ETA yet, sorry. Do you mean that your locale is already set to a UTF-8 one but there are still syncing errors? If so please send your logs to support@insynchq.com for investigation: How to find the log files.