"Your authentication token is invalid. Please try logging in again"

This message started popping up some time yesterday afternoon, and constantly keep appearing in the Windows notification area.

I have tried to use “Add a OneDrive account” in order to refresh the login, to no avail. I haven’t changed any InSync settings, or changed my OneDrive password, so I can’t tell what prompted this issue.

Any steps I can take to resolve this?

I have tried the “Alternative Login” button. I followed the instructions, which resolves the error only for a short while.

1 Like

I have the exact same issue after updating to the latest version, it doesn’t stop and if I try to login it never finishes the process. I’m using onedrive

Hi @Xavier_Limon @Jonny10,

Could you send your logs.db and out.txt files to support@insynchq.com with the link to this post? We’ll investigate this further.

Thank you!

1 Like


I also have the exact same problem (with OneDrive):
This popup is popping up every second and it is very annoying.

Tried logging in again multiple times and also tried to use the alternative way of logging in, with manually pasting the Oauth link into the application.

I already have sent my logs by e-mail.

~ Joost

1 Like

Hope this can be resolved, haven’t been able to sync any of my files for almost two weeks now.

If I try the “Login” button in the “Attention Required” section it takes me to https://www.insynchq.com/connect/ but stays on “Connecting to Insync…”

Saw in another similar thread that clearing browser cache resolved not being able to log into an account. Give it a try.

Well. Clearing the browser cache will not fix the problem for me. I have also tried using the manual login (Help --> alternative login) with another browser. It looks like the program is logged in, because files are being edited when I look at the cloud.

It still keeps popping up that I have to login though. This pop-up appears and disappears right away. It also keeps trying to upload the same files over and over again.

I have the same issue. After a couple of minutes of synchronising data i receive the message ‘Your authentication token is invalid’.

I need to login again every few minutes which is pretty annoying.

Running version on Ubuntu 20.04.

Clearing browser data did not help!

Hey guys! Sorry about this-- we’re looking into the issue and what’s causing this to keep popping up.

Please send your logs.db and out.txt files to support@insynchq.com with the link to this post. Thank you!

I am seeing this on Linux (Fedora 32) as well.

I’m also seeing this in Ubuntu 18.04 for OneDrive

Unfortunately updating to the latest version (v3.2.1.40839) didn’t make a difference. I have noticed, file changes are in fact being synced, but only when the application is running for a few minutes…

same problem here. I have tried change password/ revoke permissions in office account etc…

Any updates on this, looks like many people are having this issue… I haven’t be able to sync my files for almost a month now… @mia

Hey guys! So sorry for the trouble. We’re including better logging info on the next release to help us troubleshoot this further.

I’ll link it here when it’s out with further instructions.

1 Like

Same problem here. I’m seeing this on PopOS 20.04

Hi all! 3.2.2 is available here: New Insync version: 3.2.2

To update, please do the following:

  1. Quit your current version
  2. Run this build
  3. Start Insync afterwards

As soon as you see the pop-up message re: authentication token invalid:

  1. Do the re-login step
  2. Email your logs.db and out.txt file to support@insynchq.com
  3. Link this post in the email (so I can trace that it came from Forums)

Thank you!

1 Like

I recently enabled MFA (Multi-Factor-Authentication or 2FA) on my Microsoft 365 account.

This caused me to have to re-auth with all my connected devices.

However I get the “Your authentication token has expired. Please try logging in again.” error with Insync.

When I goto Help => Alternative Login and paste the OneDrive URL into a browser and Authenticate with Microsoft I get a blank page and no code to enter into Step 2 of the alternative login.

I have sent my out.txt and logs.db to support@insynchq.com but strangely there wasn’t even an auto-reply.

Seems to be a problem with their authentication end-points, as well as the app.

app_version=, platform=Linux-x86_64-fedora/32

Support got back to me. And the following worked for me.

  • Remove your account from the app. To know how to remove your account, visit this Help Article.
  • Close the app
  • Clear your browser cache
  • Open the app again

Log back in!

Warning: Note that removing your account from the app will erase your custom selective sync location settings and ignore rules. You’ll need to set them up again upon logging in.


Hi guys! For those who are experiencing an expired token issue on the latest version (3.2.7), please shoot us an email at support@insynchq.com-- we have an alpha build that we can send for testing before we roll it out.

So far, a couple of users have already confirmed the fix-- would love for you guys to try it out as well.