Apt repo doesn’t work with Ubuntu 18.04


#1

Seems like we just went through this with 17.10:

Please consider using the same method that Google uses with Chrome:
deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main

Benefits:

  1. Less work for you
  2. Less work for me
  3. You’ll have happier customers

Otherwise we’ll continue to log bugs like these every six months, and get frustrated when they are not promptly addressed.


#2

Just posted about this as well. This isn’t the only thread like this that’s been ignored.


#3

Any reply so far? Still no repo for 18.04?


#4

Still none as far as I’m aware. A little bit crazy that something that should be so simple is taking over 6 months!


#5

and even after the official 18.04 has been released…!


#6




All threads about this issue. Hopefully when these guys get back from their weekend this is #1 priority :confused:


#7

I’ve just installed insync 1.4.5.37069-artful on a fresh Xubuntu 18.04 install. insync works OK, I’ve seen no problems, but the repository is not signed, so sudo apt update outputs these errors:

E: Failed to fetch http://apt.insynchq.com/ubuntu/dists/bionic/InRelease  403  Forbidden [IP: 52.84.177.51 80]
E: The repository 'http://apt.insynchq.com/ubuntu bionic InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.

Here’s the repository source that insync creates:

:paulo@monk:~/Downloads$ cat /etc/apt/sources.list.d/insync.list 
deb http://apt.insynchq.com/ubuntu bionic non-free contrib

#8

But your file manager integration is not working, correct?


#9

Oh, you’re right, @Alexandre_Botelho: insync-thunar is missing from the repository:

+paulo@monk:~/Downloads$ apt show insync-thunar
N: Unable to locate package insync-thunar
N: Unable to locate package insync-thunar
E: No packages found

I use mc, so this usually slips by me.


#10

Yea, that to me is the important part of the repo not being setup (besides not being able to update of course).

It doesn’t seem like they interacted with the forums today at all, which I dunno, maybe it’s a holiday where Insync is situated?


#11

Still no reply? Is this for real? How is this “awesome support”?


#12

Hi! :slight_smile:

We’ve just added Ubuntu bionic repository. Sorry for note getting back to you sooner! :frowning: You can now install / update Insync through apt-get.

If you encounter any issues during setup, please let me know or shoot us an email at support@insynchq.com. :slight_smile: Thank you! :heart_eyes:


#13

Thanks a lot, @miamoran: I’ve just updated insync using the bionic repo.


#14

How about Linux Mint 19.1 Tessa? I get forbidden because the key is not signed.

E: Failed to fetch http://apt.insynchq.com/mint/dists/tessa/InRelease  403  Forbidden [IP: 13.33.50.58 80]
E: The repository 'http://apt.insynchq.com/mint tessa InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

I’ve added the keys beforehand as in the instructions.


#15

Hi @Robin_Beckett,

My apologies for the delayed response. Our engineer has updated the repo a couple of days back. :slight_smile: Could you please try it again and let me know if the issue persists?

Thank you!