Error "Could not delete xxxxx It still contains files"


After the latest insync client update (1.3.15) i keep getting "<folder structure> it still contains files".

The folder is empty, except for the system file desktop.ini. “desktop.ini” is in my ignore list.

For example when a user deletes a project folder (aprox 15 folders, 100 files). Some times it’s just a random folder here and there and sometimes its all the folders with in that folder that gets the error. And sometimes the folder is deleted just fine.

In the latest update a new option appeared when I get an error: “Delete anyway” is that local only?

Hi, tagging our engineer @dipesh

And you can send me your log files: How to find the log files

email :slight_smile:

An update, this is also a problem for me on OSX client. And I did some research.

The client creates a hidden “Icon?” file/folder in all folder. When this is removed, the folders will be deleted just fine, my guess is that it’s your client that adds that folder;

  1. since it’s not on google drive it self.
  2. When the Icon? (or rather Icon\r file) is removed, the folder icon with the three people is reverted to the original Mac folder look, the folder will be deleted just fine from the client.

@dipesh, @gio
Is the solution to use an older version? Can we prevent the client from auto-update it self because this is taking up to much of my time. thanks.

Ok! Logs sent.


Same error message.

I have a synchronized folder and I select to unsynch it. The app does not make the action automatically, I have to click in “Delete anyway” as many times as sobfolders it has.

I re downloaded the 1.3.14 release, that solved all my errors on this ticket. So there is a huge problem in the 1.3.15 release.

But some brilliant developer/management have deiced to auto-update the client. So it only lasted for a couple of minutes.

Is it possible to turn that off?

We are having same problem!

Where is the QA! ?! Grrrr. This sort of bug should be found in regression testing. sloppy.

Same problem. I have now 500 and counting Action Required errors. I can’t do it one by one. If I delete anyways, does it keep the copy in the cloud or deletes it as well?

That created such mess with my files. I hope there is nothing lost and can’t be restored

Same problem here. Would really appreciate a fix, Insync!

This under Mac OS 10.12.4, Insync 1.3.15

I’m gonna go out on a limb and say the latest update is not functioning as intended. The error referenced in this thread currently has my machine laboring to try to deal with what should have been a simple de-select of a large sync folder. In the past, the folder was just deleted from the local machine. Now I have nearly 3500 “Actions Required” with the message that the folder being deleted “still contains files.” Why? Why weren’t the files simply deleted?

Any idea when this issue will be resolved.

Update. This little issue ended up permanently deleting a ton of my data. I can’t find it on Google because it says it has been deleted or no longer exists.

I must say this was a monumental screw up on your part. Now I have to hope I can relocate the data that your app destroyed.

@jaduenas HELLO!?
@gio HELLO!?
It’s been a week. And not a sound from any of you.

As stated by other users, this build is just broken. Please revert, or give us an option to manually revert to an older version without the auto update function. This silence thing is just painfully awkward.

Hi guys, just released the fix. You can find it here: New Insync version: 1.3.16

I apologize for this, we’ve released a fix for this.

As for the files, please check Insync trash or your Google Drive trash to retrieve.

InSync trash? Can you tell me how to find that folder/location?

It’s a hidden folder inside of your Insync folder

If anyone is using Google Apps for Work, everything that was deleted can be restored through the admin console.

@jaduenas I still have 109 action required errors, How can I cancel that, or what should I do with that?

Please help.