File stuck uploading at 0 bytes

All 12 files in queue get stuck after a few minutes. Pausing and starting sync gets it going for a few minutes and then the same issue occurs again. No errors reported. The issue halts all further syncing. I’ve waited hours for it to resolve, tried removing and adding account again, tried with a clean folder, tried reinstalling, etc. Nothing works.

I’ve sent logs and info to, waiting on a reply…


Thank you for sending the logs @htkoca. We’ll investigate what’s causing this to happen and I’ll respond to you via email to streamline our communication. :slight_smile:

Suggest this thread be merged with File sync gets stuck randomly

htkoca - any response or fix from the “engineers” since your post 15 days ago? We are not alone in this issue - I am exactly where you are with this issue (running on Linux Mint and symptoms are the same - 12 files doing nada). And I see nothing from insync so far about A) acknowledgement of the issue and B) a possible fix in the works.

Statements like this one in a public forum “We’ll investigate what’s causing this to happen and I’ll respond to you via email to streamline our communication” always make me sad, since they negate the value of the forum and put the burden on the OP to update the community.

Hi @hueydok,

I apologise for not providing an update sooner; our testing team has been continuously running stress tests to narrow down the causes of stuck syncing.

I understand your sentiments about the email exchanges and I appreciate your feedback! We will update the related threads as soon as a fix is available. :slight_smile:

I’m now having this same issue almost 5 months later, what ever happened with this?

Our company just shut down my old GSuite account so I need to resync everything and am currently at a standstill, why hasn’t this been fixed or even updated for almost 5 months?

@mia hello??? Are you guys even monitoring these threads you promised to update?

Hi @benmeroff,

I understand the frustration of having to wait this long and I apologize for the trouble. Our engineers are still working on the stuck syncing issue as it seems to be a wide scope that we need to narrow down further.

Please send your latest logs to and include the following files in the folder:

  • logs.db
  • out.txt
  • data folder
  • live folder

If these are too big for an attachment, feel free to send us a link so we can download these.

I sent the email to support with listed log files included and referencing this page. As it is right now this issue brings Insync to a complete stop for me and for what I can only assume are many others; small bugs are understandable in what is being advertised and sold as production software and not a beta experience, but this “bug” has been apparently crippling Insync for many paid users for at least 5 months now. What are you planning to do to reimburse for the wasted money and software that doesn’t work for months on end?

1 Like

I have the same issue.

It is quite disappointing that insync still couldn’t figure out this major issue. The very basic task it needs to complete is not working. What are you doing about it? Any workarounds?


All I’ve been able to do so far is restart the app periodically and hope it lasts longer than 10 minutes or so before hanging on every upload again. Unfortunately not a great workaround if you have anything more than 40 files to upload as it won’t be feasible to keep up with it just stopping during the upload…

Yeah I have abour 40k small files so it hasn’t been working that way for me.

This makes Insync completely useless for me. I regret every paying for it now.

Sorry man, yeah that’s definitely not doable for your use case… I’ve been using Insync for years now, and there have always been random issues or bugs as far back as I can remember but the Google Drive sync app was always worse so I just kept using their poorly-made software. They even completely removed the “Share” context menu feature in one update without notifying anyone, and took weeks after that to only bring back a fraction of the functionality that we still only have.

Overall just a lot of bad development with mostly-absent support that consistently give useless canned responses to the constant debilitating problems in their software. These things would be expected from a single developer’s beta freeware project, not a company’s paid production software.

@mia when will your company’s paid software actually be usable again?

1 Like

has this really been an issue for 5 months?? having the same issue with my macbook right now but hadn’t purchased it yet, don’t think I will now lol

Yeah it has unfortunately, and honestly man I’d just go with Google Drive’s Backup and Sync app at this point. From what I’ve been reading recently it’s a lot better than it used to be feature-wise and a whole lot more stable than this poorly-managed software, even if you miss out on a couple extra features using Google’s software. I’ve been along for this bumpy ride for too long now, but don’t want to waste the money I’ve spent on the license I unfortunately just bought for my company’s new GSuite account, so I’m holding out that they can actually fix this for now and it goes back to being usable.

1 Like

damn that’s a shame…I thought I’d found a good alternative for the sync app but I guess not and hearing all of your issues I’ll stick with the sync app after all. haha ironically I was about to recommend insync to our company so I’m glad I found this first when my computer just stopped syncing

1 Like

Yeah don’t even think about recommending this to your company.

Hey guys!

Thanks for voicing out your sentiments about this issue. It’s indeed frustrating to have to keep looking for workarounds on your end. We understand it’s been sitting here for a while and we apologize for any delays of putting this to rest.

Our engineers are working round the clock to dig deeper into the problem and be able to come up with a solution for you. There are multiple layers and possible causes of stuck syncing which we needed to look into further but we will make sure to give an update when the initial fix is available. Thank you for the patience and persistence. :slight_smile:

A temporary workaround that seems to work for me at least, when this happens I upload the stuck file to Google Drive via the normal web interface, and insync detects it and moves on without sticking on that file again.

Not a perfect solution of course, but it at least gets through the problem when it happens to a small number of files.

I am considering to buy this software, but this issue and the no fixed for such a long time scares me.