IMPORTANT: Insync 1.4.4 release addresses stuck syncing and selective sync issues


#19

Wait a second - I just looked up INSYNC with Synaptic and found insync-nautilus 1.3.x also installed. Should this be also installed?


#20

For all those in distress, downgrading to 1.3.24 on OSX immediately solved my issue.


#21

I’m on latest MacOS, upgraded to 1.4.4 and still having sync stalling issues. Do NOT want to re-download my GDrive from scratch. Will following the 4 steps to re-setup my account cause everything to be re-downloaded if it already exists on my local computer and GDrive?
Thanks.


#22

For the record, the problem is still there.
I have followed the procedure even though the problem whas happening with v1.4.4.37065.
It was stuck with about 200 or more in the queue.
I removed the account, added it again and selected a different directory (empty).
Then synced only the folder that was problematic.
It worked initially, however got stuck again later. Now 4 files are in the queue and only part of the files are being uploaded.
If necessary I will try the next option suggested above, which is downgrading… but that doesn’t seem like a long term solution.
Insync is crucial to my work. I hope you succeed in finding the problem.

Thank you always.


#23

Still having the problem also. Afraid starting over might not be an option as I was moving folders and files around before I noticed this. So now some things have moved/deleted some not between local and cloud. I’m afraid if I removed local and start over I’ll lose things that didn’t sync/move yet. Will anxiously await solution before I try to move/change any more files.

Also, any chance to downgrade and be OK until a fix is in place. What version should I use?


#24

I had 400+ items in que and after about 2 days it finally completed syncing! I don’t know if it helped but I regularly toggled the ‘Sync new children’ feature, that seemed to push some (30-40) files shortly after changing it but then it stopped again. Eventually, it did about 200 items on its own after an unusually long time. So, just have patience?


#25

I was feeling lucky as I hadn’t experienced the stuck syncing problem, but now it’s hitting me as well.

No matter how fancy new features are, the core feature, i.e. syncing, should not have such big problems in a release version.


#26

Update on the issue: the next day the (4) files were synced.
So it’s not stuck forever. Maybe simply a hint that it’s doing something about the queued files would be a temporary solution.

Thank you.


#27

Thank you - worked like a charm to save the day.


#28

Agreed, their current product waits until it scans the structure of your entire drive before beginning sync. Which is crazy.

Untitled


#29

I updated to 1.4.4 (on Ubuntu) and also here it syncs a few files after which it gets stuck with remaining files gueued. Restarting Insync will make it sync a few files again, after which it gets stuck again with remaining files gueud.


#30

Hello all!

We have identified the issue and working on a solution. We hope to have it in a week or two.

Thanks for all the reporting and apologies for the massive hassle.


#31

If you have identified the issue, then can you please update the original post? I wasn’t having this problem until I upgraded to 1.4.4.37065. If you are now saying that there is a different problem, then what do we do in the meantime? A week or two is huge… I’m already subtracting the 5 days from the post in my head - because I’m seriously stuck until this issue is resolved.

Do we go back to 1.3xxx? Please advise! I bought this software to do the one thing it is now no longer doing.


#32

My apologies. Yes, you may go back to 1.3.24 in the meantime.


#33

Thanks. Wasn’t sure I could downgrade that easily. I just closed Insync and ran the installer for the version above and now it’s back to syncing along! Thanks.


#34

I followed the instructions:

  1. Files have stopped syncing (files are stuck on queue, no progress is happening) or Insync is syncing everything from Google Drive automatically upon initial setup (no option to Selectively sync files)

This problem has been found to occur across newly set-up accounts on Insync. The recommended fix for this is to re-setup your account:

Install Insync 1.4.442 (if it has not auto-updated for you already)
Remove account
Add account again and select an empty folder as Insync folder during setup
Selectively sync the items you want to sync

But throughout the day, I got a new project on a flash drive, copied the files to the local synchronized directory. The insync started uploading some files and then froze the sync.

I ran the instructions described at IMPORTANT: Insync 1.4.4 release addresses stuck syncing and selective sync issues again

I made tests with other files from other projects that were arriving during the week and the error repeats itself, when I copy a new directory with about 100 files or more (which does not yet exist in the local synchronized folder), the inscync freezes.

I ran Downgrade to version 1.3.24 that works perfectly.

Version Considerations 1.4.4

1- Fix the file upload bug from the local directory for Google Drive.

2- You need to have the checkbox to select which folders to sync. right click and sync one by one is very labor intensive for those who have large amounts stored in GDrive.

3- The synchronization of version 1.3.24 is much faster than version 1.4.4

The computers in our Marketing Agency use:

Linux Mint 18.3 Cinnamon Sylvia
Linux Mint 18.3 Mate


#36

None of those fix work.

Using Ubuntu 16.04 the sync remain stuck.

I downgraded back to 1.3 which works perfectly fine


#37

At least on Mac, downgrading is simple enough:

  1. make sure your stuffs are sync’ed (I don’t know what happens if you have unsync’ed stuffs – it may or may not work)
  2. exit insync
  3. remove insync from /Applications
  4. install the old version
  5. start it.

Seems that your configurations and files are still there.

I do want to say that keeping this downgradability seems a good thing for insync as a product – of course I hope everything goes well when new versions come, but when things go wrong, at least users are guaranteed to have a workaround.


#39

Where can I find Version 1.3?


#40

Found it in this thread… Removed 1.4.4 and added this one… Configs stayed and it is running like a champ now :slight_smile: