Insync for Ubuntu 24.04

Is there already insync for Ubuntu 24.04? I am using this development version since it is quite stable now. Snaprcraft and flatpak versions are also appreciated.
If none of those available, is there anyone already tried to install insync for Ubuntu 24.04?which version of insync did you use?


Hello! Please try the Ubuntu 23.10 version first:, and let me know if you bump into any issues. Will notify the Linux Team to develop for 24.04 :slight_smile:

I confirmed that using insync version 23.10 didn’t work in 24.04. There is no error on installation, but it didn’t show up after installation (actually, it was shown a few seconds in the top bar). I also started using CLI, but nothing happened.

bagus:~$ insync start 
bagus:~$ insync status
Insync doesn't seem to be running. Start it first.

Will be happy happy to help if you need further information.

Hi! Could you run insync start --no-daemon and send me the output? Thank you!

Hi @mia,

Here is the output:

bagus:Downloads$ insync start --no-daemon
Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.
WARNING:root:While reading /usr/share/applications/defaults.list
Traceback (most recent call last):
  File "idesklinux/", line 53, in __index_default_apps
  File "", line 696, in read
  File "", line 1091, in _read
configparser.DuplicateOptionError: While reading from '/usr/share/applications/defaults.list' [line 265]: option 'application/xhtml+xml' in section 'Default Applications' already exists
WARNING:root:While reading /usr/share/applications/defaults.list
Traceback (most recent call last):
  File "idesklinux/", line 70, in __index_apps_for_mimetypes
  File "", line 696, in read
  File "", line 1091, in _read
configparser.DuplicateOptionError: While reading from '/usr/share/applications/defaults.list' [line 265]: option 'application/xhtml+xml' in section 'Default Applications' already exists
INFO     2024-01-23 18:07:56,459 [mainlogs:_log_run:138] Core(app_version=, platform=Linux-x86_64-ubuntu/24.04) initialized
WARNING  2024-01-23 18:07:56,471 [base_events:_run_once:1782] Executing <Task pending coro=<init() running at ideskcore/> wait_for=<Task pending coro=<SettingsMain._load_settings() running at ideskcore/> cb=[_log_tb_after_delay() at ideskasync/, <TaskWakeupMethWrapper object at 0x791d35a9e950>()] created at ideskcore/> cb=[_log_tb_after_delay() at ideskasync/, _chain_future.<locals>._call_set_state() at asyncio/] created at asyncio/> took 0.125 seconds
INFO     2024-01-23 18:07:56,483 [mainsettings:_load_settings:236] Loaded settings, machine fingerprint = Dh34bdTArYvZnZbw-McrvgugxTc=
[6442:6442:0123/] : Permission denied (13)
Trace/breakpoint trap (core dumped)

Thank you for sending this my way, @bagus! I have informed our Linux engineer and I am waiting for his advise.

I have pretty much the same error message on my ubuntu installation. I also updated to the latest ubuntu version. I’m using the insync client for 23.10.
Just to confirm “bagus” is not the only one.


I’m seeing the same failure on 23.10 with freshly re-installed:
on an up to date 23.10

Failure happens under both wayland and X11

Hi @Jody_G, could you please send me the output of apt-cache policy insync and lsb_release -c?

For other users who are experiencing the issues on Ubuntu 24.04, I have escalated the issue to our engineer. Thank you!

1 Like

UX31A/~ ] apt-cache policy insync
Version table:
*** 500
500 mantic/non-free amd64 Packages
100 /var/lib/dpkg/status
UX31A/~ ] lsb_release -c
No LSB modules are available.
Codename: noble

Basicly 23.10 with all updates as of 2024-Feb-5

We will update this thread when the Ubuntu 24.04 (Noble) build is ready. Thank you all for your patience!

To be clear this is with 23.10 with current updates, it is not the dev 24.04
Not sure why it calls itself noble

1 Like

Hey @Jody_G!

Hmm, let me check with our Linux Team why it says noble even if your OS is still on mantic.


That output (`lsb_release -c) is from Ubuntu and is not related to insync. Since the 24.04 (dev) was built from the 23.10, they (Ubuntu developers) may change the codename directly once they switch the development from 23.10 to 24.04.

1 Like

I reviewed the laptop that was tested and realized that it actually is noble. It was accidentally upgraded from 23.04 to the dev tree of 24.04 rather than 23.10.

A backtrace doesn’t turn up much
(gdb) bt
#0 __pthread_kill_implementation (no_tid=0, signo=5, threadid=) at ./nptl/pthread_kill.c:44
#1 __pthread_kill_internal (signo=5, threadid=) at ./nptl/pthread_kill.c:78
#2 __GI___pthread_kill (threadid=, signo=signo@entry=5) at ./nptl/pthread_kill.c:89
#3 0x00007ffff7c42856 in __GI_raise (sig=5) at …/sysdeps/posix/raise.c:26
#4 0x000055555555a213 in ?? ()
#5 0x000055555555815d in ?? ()
#6 0x00007ffff7c280d0 in __libc_start_call_main (main=main@entry=0x5555555564d0, argc=argc@entry=3, argv=argv@entry=0x7fffffffe3e8) at …/sysdeps/nptl/libc_start_call_main.h:58
#7 0x00007ffff7c28189 in __libc_start_main_impl (main=0x5555555564d0, argc=3, argv=0x7fffffffe3e8, init=, fini=, rtld_fini=,
stack_end=0x7fffffffe3d8) at …/csu/libc-start.c:360
#8 0x000055555555650a in ?? ()

1 Like

A solution was proposed in Insync (manic) -] : Access denied (13)

Confirmed: The apparmor config changes restore functionality on the latop running noble with updates as of Feb-21

1 Like

I confirmed it works on Ubuntu 24.04, solving my problems above.

1 Like

Hello! I’m following up with our Linux Team so we can check what happened prior and deploy the necessary fixes so that workarounds shall not be needed moving forward.

Thank you!

Hi @Jody_G @bagus

We have an updated build for Ubuntu 24.04. Please update all system packages first before installing the build
Let us know if it has issues for you