Insync process dosent start after upgrade to ubuntu 21.10

I re-installed and tried but the process doesn’t start and am stuck here.
kindly help


(base) vipulpopat@vipulpopat-XPS-13-9370:~$ insync start
(base) vipulpopat@vipulpopat-XPS-13-9370:~$ ps -fax | grep insync
12116 pts/0 S+ 0:00 _ grep --color=auto insync
(base) vipulpopat@vipulpopat-XPS-13-9370:~$

Hi, could you run insync start --no-daemon and send the output here?

Additionally, could you let me know if these workarounds (here and here) work?

I get the same issue: Installed Ubuntu 21.10 and insync is not starting anymore.
Here are the asked logs:

Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.
(insync:9758): GLib-GIO-ERROR **: 09:24:54.195: Settings schema 'org.gnome.settings-daemon.plugins.xsettings' does not contain a key named 'antialiasing'

The first workarround didn’t work for me, but the following one did:

env GDK_BACKEND=x11 insync start
1 Like

Hey @Jordan :slight_smile: Thanks so much for letting me know that the 2nd workaround was helpful. We’ll let our users know as soon as the Ubuntu 21.10 Insync installer is available :slight_smile:


Thanks for the workaround! Saved my day.


Neither fixes work in this configuration:

/:-------------:\ toddb@fedora
:-------------------:: ------------
:-----------/shhOHbmp—:\ OS: Fedora Linux 35 (Workstation Edition)
/-----------omMMMNNNMMD —: Host: AB350N-Gaming WIFI
:-----------sMMMMNMNMP. —: Kernel: 5.14.10-300.fc35.x86_64
:-----------:MMMdP------- —\ Uptime: 1 hour, 44 mins
,------------:MMMd-------- —: Packages: 2264 (rpm), 5 (flatpak)
:------------:MMMd------- .—: Shell: bash 5.1.8
:---- oNMMMMMMMMMNho .----: Resolution: 1920x1080, 1920x1080
:-- .+shhhMMMmhhy++ .------/ DE: GNOME 41.0
:- -------:MMMd--------------: WM: Mutter
:- --------/MMMd-------------; WM Theme: Adwaita
:- ------/hMMMy------------: Theme: Fluent-round-dark [GTK2/3]
:-- :dMNdhhdNMMNo------------; Icons: Win10Sur-blue-dark [GTK2/3]
:—:sdNMMMMNds:------------: Terminal: gnome-terminal
:------:://:-------------:: CPU: AMD Ryzen 5 2400G (8) @ 3.600GHz
:---------------------:// GPU: NVIDIA GeForce GTX 1050 Ti
Memory: 4257MiB / 15937MiB

Hi @ToddJBB11 - I’ll announce once the F35 build is ready for users like you!

Thanks for the workarounds. By doing both commands:

env GDK_BACKEND=x11 insync start

Everything works, including the app window. Looking forward to a new version!

1 Like

Thank you for your patience, @brianr0922!

There is one thing about which I am curious. I was using Wayland the entire time I had 21.04, but Insync worked fine. What has changed in 21.10 that now requires x11?

It requires X11? That would not be good since most large distros are moving to Wayland now. I could swear I used InSync on Ubuntiu 21.04 with Wayland, but maybe I’m wrong?

I say that since the workaround:


seems to indicate so. For sure I used Wayland on 21.04 as well and it worked, so it is strange that it is not working in 21.10.

@cdysthe @brianr0922 Hi! :slight_smile: I have confirmed that you don’t have to run X11 once we’ve deployed the fix in an upcoming release. Switching to X11 is a temporary solution to get Insync to run again, but this shouldn’t be required in an upcoming Insync version. Thank you!

I am getting this error since I upgraded to Ubuntu 22.04 and none of the above fixes help

Apologies for the delayed reply, @cwfparsonson.

Could you please send the output of insync start --no-daemon to with the link to this Forums post, please?

Getting this error

qt.qpa.xcb: could not connect to display
qt.qpa.plugin: Could not load the Qt platform plugin “xcb” in “” even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, webgl, xcb.

Aborted (core dumped)


Hi @Daniel_Perez, could you confirm your desktop environment?

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04.3 LTS
Release: 18.04
Codename: bionic

Could you try DISPLAY=:0 insync start --no-daemon? Then if it works, please run DISPLAY=:0 insync start.