Blank screen on ubuntu 21.10 and Fedora 35 KDE/GNOME (with workaround)

I am using the latest insync deb package on Ubuntu 21.10. I can see the insync icon in the notification zone but when I click on “Open App Window”, the insync window is just a black window and nothing happens.

I don’t think insync is using electron but that could be a similar bug than the one affecting electron users due to a libc issue. See https://bugs.launchpad.net/ubuntu/+source/glibc/+bug/1944468 for details.

Here is the content of out.txt:

QXcbIntegration: Cannot create platform OpenGL context, neither GLX nor EGL are enabled
WARNING:root:While reading /usr/share/applications/defaults.list
Traceback (most recent call last):
  File "idesklinux/application_manager.py", line 53, in __index_default_apps
  File "configparser.py", line 696, in read
  File "configparser.py", line 1091, in _read
configparser.DuplicateOptionError: While reading from '/usr/share/applications/defaults.list' [line 265]: option 'application/xhtml+xml' in section 'Default Applications' already exists
WARNING:root:While reading /usr/share/applications/defaults.list
Traceback (most recent call last):
  File "idesklinux/application_manager.py", line 70, in __index_apps_for_mimetypes
  File "configparser.py", line 696, in read
  File "configparser.py", line 1091, in _read
configparser.DuplicateOptionError: While reading from '/usr/share/applications/defaults.list' [line 265]: option 'application/xhtml+xml' in section 'Default Applications' already exists
WebEngineContext used before QtWebEngine::initialize() or OpenGL context creation failed.

Hi @hadim! It seems to be a compatibility issue between our latest Ubuntu Insync installers and the latest Ubuntu OS version. Per our engineer, we would need to wait for Linux to officially release Ubuntu 21.10 (Oct 14) to be able to properly build the installer because doing so during the beta stages of 21.10 may cause further issues.

Here is the associated ubuntu ticket: https://bugs.launchpad.net/ubuntu/+source/glibc/+bug/1939993

Do you bundle your own Qt or do you use the one installed by the system?

1 Like

From the above link, it looks like the fix has been released in twebengine-opensource-src - 5.15.5+dfsg-2.

Waiting for things to be back to normal the following trick, make it works:

$ export QTWEBENGINE_CHROMIUM_FLAGS="--no-sandbox"
$ insync start
1 Like

$ export QTWEBENGINE_CHROMIUM_FLAGS="–no-sandbox"
$ insync start.

Working on Budgie 21.10

Thanks

2 Likes

We use the one installed by the system as far as my knowledge on this topic goes but let me clarify that with our engineers and will get back to you!

Thank you so much for sending the fix to let things run again - I’ll send this to our Linux team so we can follow suite :slight_smile:

This also solves the issue on OpenSuSE Tumbleweed.

3 Likes

This also solves the issue on Fedora 35 KDE Beta.

1 Like

@linuser Thank you for updating this thread! :slight_smile:

Just for completeness sake, this solves the issue for Fedora 35/Gnome 41 as well.

1 Like

Works on Kubuntu 21.10 ! ; To avoid restarting at each reboot :

1 - Create .sh with :
#!/bin/bash
export QTWEBENGINE_CHROMIUM_FLAGS="–no-sandbox"
insync start

2- Edit launch application command Insync and browse to the .sh location.

This launches the program normally while waiting for the official patch

1 Like

Woah, thanks for this @JacobJS!! :slight_smile:

this does not solve the problem for me. Tumbleweed and insync 3.5.4.50130-fc34. After the export command nothing has changed and the app window is still blank.