Insync stuck with high cpu usage

I’m using insync on Ubuntu. I just stopped insync after too much cpu usage. It constantly keeps the CPU at 100%. I gave it 92 hours, but I am running out of patience. It doesn’t seem to sync, the overview only shows one file, and that never changes.

Has anyone else experienced that? Are there any solutions to this? This software is absolutely unusable.

I’m having the same problem. Laptop fans go crazy with CPU usage, nothing syncs, and insync keeps getting stuck at scanning. It is indeed unusable at the moment.

Hi guys! So sorry about that. Does it say “Syncing…” or “Scanning…” at the bottom? Is this a fresh install or are you updating from an older version?

Please also send your logs.db and out.txt files to support@insynchq.com with the link to this post. Thanks!

It is “scanning…” at the bottom. I’m using Insync 3.2.6.

How do I get the logs.db and out.txt files to send to you?

Found it: https://help.insynchq.com/en/articles/1834816-locating-the-log-files

1 Like

Same for me, it’s says scanning, and the list/overview only shows one folder.

Can you try to pause-resume the sync and restart the app? Let me know how that goes.

Same. After Pause-Resume and restart the app, the sync works again. Also, “The following signatures were invalid: EXPKEYSIG A684470CACCAF35C Insynchq Inc services@insynchq.com” when running an update…

same for me! I am using the newest version of Insync 3.2.7.40868 on my Ubuntu 20.04 .

It didn’t happen when I was using Ubuntu 18.04

Hi @victor @Guilherme_Parreira! Please run this for APT:

sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys ACCAF35C

We’re currently fixing this for the next version. Sorry about that!

Tks @miamoran.

But it didn’t fix to me. See the output from my terminal (I tried this command both with Insync on and off):

[IT WORKS NOW] I restarted my PC, and it thankfully works!! (But I am not sure if this was the cause to work).

1 Like
sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys ACCAF35C

That also seems to have fixed my issue, it seems to be working again for the first time in weeks.

1 Like

Hi there! The problem still happens for me some times.
For example, when I restart my PC, or when I turn off the app and turn it on again, my CPU gets 100% due to Insync.
So, it was not solved 100% yet.

However, the files are now uploaded/downloaded successfully and no longer appears “Scanning” on app window.

Hi Guilherme,

I’m also facing this problem. I have Insync installed on 3 machines, one with Linux Mint 20, other with Manjaro XFCE and other with Windows 10. Now and then I realize Insync is constantly consuming 12% CPU, but all files are synced and no scanning on app window. For now, the only solution I found was to restart the app.

Also, I have two accounts added to Insync, one personal account and one business account. It may be a coincidence, but I think the problems started when I added the business account.

Hi Lucas.
I think that the business account is just a coincidence (because I have only one account).

After using sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys ACCAF35C Insync improved its performance a little bit (without using 100% of CPU). Also, I constantly update my Ubuntu 20.04 system, and it seems that it is all solved (due to Ubuntu…)

Right now the app is smooth, but I don’t know for how long.

Thanks for sharing your status.

I had already replaced the keys and my Linux installations are up to date, but the problem persists.

Version 3.2.8 was released today, later I’ll give it a try.

Update: all packages are up to date and I’m running Insync 3.2.8.40877 - now and then it is still constantly consuming 12% CPU.

Note: the problem occurs only on my Linux setups.