Insync version: 3.0.13 - sync OneDrive!


#1

Insync 3’s official release is almost here!

Over the years, customer feedback has been loud and clear: improve syncing and add OneDrive support.

We’re excited to announce Insync 3 fulfills both these requests (and a bunch of improvements and fixes) with the help of Core 3 --our new sync engine that was built from the ground up!

Core 3 makes syncing faster and more reliable for users while making it possible for us to develop features more easily, such as OneDrive support.

Features and improvements

– Cloud Selective Sync:

– Local Selective Sync:

Still in the works

These aren’t available yet and will be on upcoming versions:

  • Share (via Shortcuts and context menu)
  • Preview dialogs
  • Symlinks (syncing of the actual symlink, not the target file)
  • Cloud Shortcuts (open, rename, delete, etc.)
  • Feed: activities and error handling

Insync 1.5-only features

Due to the limited time and resources of our team, we had to make trade-offs for Insync 3. These features will only be available on Insync 1.5 but we might spin-off headless / command line interface support as a separate product if users demand it:

Updating from Insync 1.5 to Insync 3

There will be no auto-update for Insync 1.5 to 3. Existing 1.5 users will have to manually download and install Insync 3 and go through a one-time migration process.

  1. Download and install Insync 3

  2. Sign in with your Google Account/s

  3. Insync will detect if your account was previously on Insync 1.5

  4. You can choose to reuse your existing sync folders or choose to sync to a new location

IMPORTANT: Once your Insync account and sync folders have been migrated to Insync 3 (from Insync 1.5), reverting back to Insync 1.5 will require resyncing of files.

For more details, refer to our Migration Help Center Article.


Downloads

Current version: 3.0.13.40199

Windows 7 and later
macOS 10.10 (Yosemite and later)

Ubuntu (16.04 Xenial) & (18.04 Bionic)
Linux Mint (18.x) & (19.x)
Debian (8 Jessie) & (9 Stretch) & (10 Buster)
Fedora (27) , (28) , (29) & (30)

Nautilus plugin (deb) & (rpm)
Caja plugin (deb) & (rpm)
Nemo plugin (deb) & (rpm)

Note: anyone can use Insync 3 freely during the beta and is not required to buy a license. Also, previously bought licenses are still active so disregard the section indicated below.

*


Support

If you’re experiencing any bugs or issues with Insync 3, kindly email us at support@insynchq.com with the following details:

  • OS/distro
  • Build installed
  • Detailed description of error/bugs. Include screenshots/screen recording if needed
  • Log files (read our Help Center Article to learn how to locate these)

Happy syncing!
Team Insync


Fedora 30 and Insync 1.5.7.37371
Remote changes in team drives are not detected
listed #2

#3

I was updated automatically last night and things aren’t working.

  • The UI hangs. A lot. It’s basically unusable.
  • When the UI does work, it shows that no transfers are occurring.
  • UI icons in the left bar disappear.
  • I can’t change any settings. Clicking on the confirmation to apply settings doesn’t do anything.

It’s crashed on me several times in the last hour. I don’t know if it matters, but I have over 300k files in my Google Drive which v1.5 didn’t like much but it got it done.


#4

Hey @James_Bailey, what OS are you running? And you were updated automatically from 1.5? There’s supposed to be no auto-updated from 1.5 to 3.

Can you kindly send your logs to support@insynchq.com along with some screenshot of the bug you’re experiencing on the UI so our team can investigate? :slight_smile:


#5

Insync-3.0.11 beta is working well so far on Fedora 30.
Insync-nautilus-3.0.11 doesn’t appear to do anything in nautilus however.

It would be nice, for example, to be able to include the “Shared folder” for Onedrive in the Root folder for Onedrive.
I think this was possible in the previous version of Insync-1.5

Thanks.


#6

Good to hear about Fedora. For the nautilus issue, your log files may help with the investigation :raised_hands: Please send to support@insynchq.com cc @Kurt_Ko @nikki

Re: Shared folder location – I’ll note this as a feature request, thanks! Kind of… we synced “My Drive” and “Shared with me” files in the same sync folder.


#7

I seem to be strugling synching folders with more than 10k files. I have slowly be assigning new folders from the sync list so more files can be downloaded. I’m not sure it’s exactly 10k files but anything under downloads without issues, anything with more stops the engine.

OS: Ubuntu 18.04
Build installeD: 3.0.11.40167


#8

Hi @CaptainJawZ,

Can you let me know more about your syncing activity?

Are you syncing on One Drive or Google Drive? If on Google Drive is it a migration case or a new sync?


#9

Hello, I am trying to use OneDrive to sync a cloud drive which contains about 567gb wirth of files. And I’ve encountered a number of breaking bugs which prevent me from having a full sync experience.

right now the biggest one I’ve found is that it seems like the app isn’t able to handle the scan of over 10k files. I made 3 folders with dummy files, one containing 9k files, another 10k files and a last one containing 11k files.

I was able to sync the folder containing 9k files twice, while breaking the app if I tried to sync the other two folders, Even removing the folders from the list would crash the app.

Here are two videos I recorded, while they were recorded with the previous 3.0.9 version the bugs presented here still remain: https://1drv.ms/u/s!AsPHe5lOdL1hqb8q_Q5cnBFV0aCZKw?e=cQIeDt

Also I have uploaded my logs file and sent it by email to Nikky, I believe.

Basically the way I’ve managed to bring about 400gb worth of files trough InSync was trough lots of trial and error, adding a parent folder to the sync, then finding out which folder caused the crash (would get an X icon on the file manager) and removing it from the sync list, which also is a bit of a chore since to be able to edit that list I have to do all the steps from one of the videos I just shared pretty much

  1. pause the engine
  2. reopen
  3. edit sync list

It used to be worse on 3.0.9 since it crashed a lot more than it does now.

Overall I think the experience is extremely unreliable at its current state, tho I have to say that once all of these issues are sorted out it looks like the app is going to be really great for users who rely on these cloud services which dont have real support on Linux.


#10

Hi @CaptainJawZ,

Really sorry for the redundancy, but can you please send over an email containing the details above to support@insynchq.com so I can properly endorse it to our testing and engineering teams? :slight_smile:


#11

Oh I’ve sent several of them detailing more bugs and steps to replicate them to that email! just look for the ones sent by contact@captainjawz.art some of them may have been sent to Mia && Nikki

I can forward all of the emails again to insynchq if you want, but would rather not clutter the inbox with duplicates.


#12

Hi @CaptainJawZ,

Thank you! We’re on it :slight_smile:

-Nikki


#13

Any chance for openSUSE rpms for the beta? I’ve tried the Fedora one, but when I try to add an account, after going through the OneDrive (or Google) account selection, it just sits on the page saying it’s contacting Insync.


#14

I’m giving this a chance on Fedora 30 and 1.5 wasn’t working very well there. My local folder and my google drive were already in sync before installing the 3.0 beta, so I’m curious why it appears every file is being re-uploaded.


#15

Just installed insync-3.0.11.40167-fc30.x86_64.rpm on Fedora 30. On confirming my existing Google Drive folder it is now uploading the entire thing when it doesn’t need to. This is ridiculous.

Also, the UI under KDE is flaky. I can’t seem to move or resize the window.

If you’re in any doubt about providing a CLI version, please do so. This is Linux after all.


#16

please suport for arch linux


#17

Hi @darthzen, please send your log files to support@insynchq.com so we can investigate :slight_smile: Thanks!

I’ll forward your question about openSUSE cc @Kurt_Ko


#18

Hi @jason, the files may have just been “file matching” which may appear like it’s re-uploading in the Progress window.

Can you confirm if the files were re-uploaded – were files duplicated on your Google Drive?


#19

Thanks for reporting @POC. Were files re-uploaded and duplicated on your Google Drive? If so, please send your log files to support@insynchq.com for investigation.


#20

Hi @darthzen,

As of now, we don’t have any openSUSE builds :frowning: