New Insync version: 1.2.13/1.2.14


#1

Release notes:

  • Fixed issue introduced in 1.2.12 where ‘shared by’ activities are shown for files the user created remotely.
  • Synced folders that are still using old folder icons are now going to be updated to use the new icons for the version of their operating system. This applies to Mac OS X Yosemite and above and Windows Vista and above.
  • ‘Selectively unsync’ context menu item will now disappear on already selectively-unsynced files and folders.
  • It’s now indicated if Insync is just syncing metadata but not data.
  • (Linux) Fixed Insync not starting in Fedora 22.
  • (Linux) Fixed issue on handling errors on moving the Insync directory.
  • (Mac) Fixed Insync crashing in 10.11 (El Capitan).
  • (Windows) Insync now scales when using high DPI displays.
  • (Windows) Fixed issue introduced in 1.2.12 where Google Drive link files are not opening.

There are also lots of internal changes here, so please test away!

Windows
Mac
Ubuntu 13.10 and older: 64 bit, <a href="http://s.insynchq.com/builds/insync_1.2.13.35166-precise_i386.deb"32 bit headless: 64 bit, 32 bit
Ubuntu 14.04 and newer: 64 bit, <a href="http://s.insynchq.com/builds/insync_1.2.13.35166-trusty_i386.deb"32 bit
Debian: 64 bit, 32 bit headless: 64 bit, 32 bit
Fedora 20 and older: 64 bit, 32 bit headless: 64 bit, 32 bit
Fedora 21 and newer: 64 bit, 32 bit
Portable: 64 bit, 32 bit

Please help test.

Thanks!


Fedora 22 grief
Fedora 22 -- latest interface refuses to restart with
New Insync version: 1.2.12
Insync-headless move_folder seems not working
Ver. 1.2.5 Keep syncing + hdd led always on, but nothing syncs
pinned globally #2

#3

Installed Mac version on Mac OS X 10.11 El Capitan & it works like a charm :smiley: Thanks…!!


#4

I tried this on F22 to resolve the “Inync not starting in Fedora 22” issue – but it didn’t fix the issue. The dnf install command produced an error message, and the out.txt complained of missing dependencies. I was expecting any required dependencies to be resolved automatically.

Here are some output and logs:

[jcall@jcall-laptop ~]$ sudo dnf upgrade ./Downloads/insync-1.2.13.35166-fc21.x86_64.rpm
Last metadata expiration check performed 1:40:27 ago on Thu Jun 18 04:31:27 2015.
Dependencies resolved.

Package Arch Version Repository Size

Upgrading:
insync x86_64 1.2.13.35166-fc21 @commandline 62 M

Transaction Summary

Upgrade 1 Package

Total size: 62 M
Is this ok [y/N]: y
Downloading Packages:
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
Upgrading : insync-1.2.13.35166-fc21.x86_64 1/2
Error unpacking rpm package insync-1.2.13.35166-fc21.x86_64
error: unpacking of archive failed on file /usr/lib/insync/isyncd.commands-0.2.6-py2.7.egg: cpio: rename
insync-1.2.13.35166-fc21.x86_64 was supposed to be installed but is not!
Verifying : insync-1.2.13.35166-fc21.x86_64 1/2
insync-1.2.11.35149-fc20.x86_64 was supposed to be removed but is not!
Verifying : insync-1.2.11.35149-fc20.x86_64 2/2

Upgraded:
insync.x86_64 1.2.13.35166-fc21

Complete!
[jcall@jcall-laptop ~]$ sha256sum ./Downloads/insync-1.2.13.35166-fc21.x86_64.rpm
6d2efb6e380a6ef718d9d459a01aeda9621f90be506a1dd6dc0f59c8ccdaf9d7 ./Downloads/insync-1.2.13.35166-fc21.x86_64.rpm

[jcall@jcall-laptop ~]$ tail .config/Insync/out.txt
./insync: symbol lookup error: /lib64/libpangoft2-1.0.so.0: undefined symbol: FcWeightFromOpenType
Traceback (most recent call last):
File “”, line 6, in
File “main.py”, line 128, in
File “main__insync.py”, line 159, in
File “main__insync.py”, line 30, in main
File “PySide/QtGui.py”, line 26, in
File “PySide/QtGui.py”, line 17, in _bbfreeze_import_dynamic_module
ImportError: libpyside-python2.7.so.1.2: cannot open shared object file: No such file or directory
Traceback (most recent call last):
File “”, line 6, in
File “main.py”, line 128, in
File “main__insync.py”, line 159, in
File “main__insync.py”, line 30, in main
File “PySide/QtGui.py”, line 26, in
File “PySide/QtGui.py”, line 17, in _bbfreeze_import_dynamic_module
ImportError: /usr/lib/insync/libstdc++.so.6: version `GLIBCXX_3.4.20’ not found (required by /lib64/libshiboken-python2.7.so.1.2)

I manually installed these two packages, and now nothing else appeared in the log…
[jcall@jcall-laptop ~]$ sudo dnf install python-pyside-1.2.2-2.fc22.x86_64 libstdc+±5.1.1-3.fc22.i686


#5

Hi,

Fresh fedora 22 workstation install just to test this new release in a VM machine,
same problem as JohnCall:

[root@localhost ~]# dnf install ~terrence/Downloads/insync-1.2.13.35166-fc21.x86_64.rpm
Warning: failed loading ‘/etc/yum.repos.d/gtk-theme-config.repo’, skipping.
Last metadata expiration check performed 0:26:03 ago on Fri Jun 19 00:35:33 2015.
Dependencies resolved.

Package Arch Version Repository Size

Installing:
insync x86_64 1.2.13.35166-fc21 @commandline 62 M

Transaction Summary

Install 1 Package

Total size: 62 M
Installed size: 156 M
Is this ok [y/N]: y
Downloading Packages:
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
Installing : insync-1.2.13.35166-fc21.x86_64 1/1
Error unpacking rpm package insync-1.2.13.35166-fc21.x86_64
error: unpacking of archive failed on file /usr/lib/insync/isyncd.commands-0.2.6-py2.7.egg: cpio: rename
insync-1.2.13.35166-fc21.x86_64 was supposed to be installed but is not!
Verifying : insync-1.2.13.35166-fc21.x86_64 1/1

Installed:
insync.x86_64 1.2.13.35166-fc21

Complete!

The rpm does not install! :frowning:

!!! PLEASE !!! install a fresh Fedora 22 Workstation image in a desktop VM solution and test before rolling new packages intended for release…
Using your customer base for quality assurance like this is going to damage the reputation of your product in the long run…


Cannot install insync 1.2.14 on Fedora 22 64bits
#6

@Terrence_Vergauwen We have tested this and the package installed correctly in our case. Could you try deleting the /usr/lib/insync folder and retrying?


#7

1.2.14 has been released for Fedora 21 and newer to handle Insync not starting in Fedora 22 when using other desktop environments. The download links in the first post has been updated.

An error was also introduced in the 1.2.13 package for Fedora 21 and newer that prevents upgrading as reported by @JohnCall and @Terrence_Vergauwen. This has been resolved in 1.2.14. When upgrading from 1.2.13 to 1.2.14 please run the following commands first:

sudo dnf -y remove insync
sudo rm -r /usr/lib/insync

Upgrading from 1.2.12 and older to 1.2.14 should be ok. Apologies for the inconvenience.


Repository problem on OpenSUSE
Update Issues in Linux
New Insync version: 1.2.17
Fedora 22 grief
Unable to install the 1.2.14.35168-fc21 rpm release
#8

Installed insync-1.2.14.35168-fc21.x86_64 and insync-nautilus-1.2.8.35136-fc17.noarch on Fedora 22, (4.0.4-303.fc22.x86_64, Gnome v3.16.2) and it seems to be working.
Thanks!


#9

Doing the same here on version 1.2.14


#10

@Ipugoy you should pin that as it affected me also. Thanks for the workaround.


#11

Seems to be working fine to me in fedora 22! Did have to use the workaround to uninstall the previous one though.


unpinned #12