New Insync version: 1.2.17


#1

Release notes:

  • The ignore list now accepts full file/folder names and not just extensions. In general, it accepts the ‘glob’ syntax.
  • Insync will now pause if the disk that contains the Insync database comes close to being full. This is to avoid database corruption and instability.
  • Logs are now being reduced further because for some users it still gets very large.

Windows
Mac
Ubuntu 13.10 and older: 64 bit, <a href="http://s.insynchq.com/builds/insync_1.2.17.35187-precise_i386.deb"32 bit headless: 64 bit, 32 bit
Ubuntu 14.04 and newer: 64 bit, <a href="http://s.insynchq.com/builds/insync_1.2.17.35187-trusty_i386.deb"32 bit
Debian: 64 bit, 32 bit headless: 64 bit, 32 bit
Fedora 20 and older: 64 bit, 32 bit headless: 64 bit, 32 bit
Fedora 21 and newer: 64 bit, 32 bit
Portable: 64 bit, 32 bit

Please help test.

Thanks!


Ignore list: allow patterns, not just extensions
Chose where to / multiple destination folders
Sync error ... 'NoneType' object has no attribute 'ch_status'
#2

#3

I’ve been waiting for this for a LONG time! Good job, guys.


#4

I have folders that have the same name and I like to have some of them synced and some not.
But it can’t be deleted locally!

Is the selective sync still deleting local files?

Stan


#5

Hi @sbrusse

Yes it is, have you tried refreshing your Insync folder? I tried it with my own app and the changes did not reflect immediately even after clicking on APPLY CHANGES in my app so I refreshed by folder.

You can also send in your logs to support@insynchq.com with your concern so we can address this better.


#6

Bummer.
No it’s a subject that we where already discussing in several threads and had hundreds of reply complaining it was acting like that.

I’m working remotely on to my office server, and I would like to be able to not sync everything that is on the server, but everything has to stay on the server and can not be deleted. (or I’m fired)

So for all those of us who do NOT want to have local files be deleted, the selective sync is useless.
The ignore list is kind of a breath of air but doesn’t resolve the issue.

A selective sync has been asked more than a year ago, personally and by many other on the old forum and when it came, it was loudly applauded.
Till we figured out that it was deleted local files.

Since then, many (including myself) have been asking to have (at least) a simple check-box in the settings to disable the fact of deleting local files.
In stead the ignore list has been implemented, but this is just a way to circle around the issue.

Many sync software allow selective sync without deleting local files (Sugarsync, syncplicity, etc)
I just don’t understand why Insync keep ignoring this.

Stan


#7

Hello,
I started using the Insync today. Awesome tool.

But there is an annoying bug in the app window. I don’t if it’s an exclusive bug of this version, so i’m posting here.

When i click on “Open window app” and click outside of the window, the app doesn’t close… I need to click inside the app, and after click outside to close… And it’s really, really annoying.

I recorded a video and converted to gif to show the bug:

I’m using Ubuntu 15.04 and Insync version 1.2.17.

Thank you guys.


#8

@iagomelanias Thanks for the report. I’ve confirmed the issue and will try to work on this soon.


#9

Thank you @lpugoy. Nice job.


#10

Getting the message below when trying to update

==========================================================================================================================================
Package Arch Version Repository Size

Upgrading:
insync x86_64 1.2.17.35187-fc21 insync 62 M

Transaction Summary

Upgrade 1 Package

Total download size: 62 M
Downloading Packages:
insync-1.2.17.35187-fc21.x86_64.rpm 8.4 MB/s | 62 MB 00:07

Total 8.4 MB/s | 62 MB 00:07
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
Upgrading : insync-1.2.17.35187-fc21.x86_64 1/2
Error unpacking rpm package insync-1.2.17.35187-fc21.x86_64
error: unpacking of archive failed on file /usr/lib/insync/faulthandler-2.1-py2.7-linux-x86_64.egg: cpio: rename
insync-1.2.17.35187-fc21.x86_64 was supposed to be installed but is not!
Verifying : insync-1.2.17.35187-fc21.x86_64 1/2
insync-1.2.17.35187-fc17.x86_64 was supposed to be removed but is not!
Verifying : insync-1.2.17.35187-fc17.x86_64 2/2

Upgraded:
insync.x86_64 1.2.17.35187-fc21


#11

@Chris_Paquin What version were you upgrading from? Could you try the steps here: New Insync version: 1.2.13/1.2.14?


#12

Yes that worked. Apparently need to install and remove via DNF and not yum


#13

The new “ignore list” function works great here (Fedora 21 with KDE 4.14.9). Good job!


#14

Hi there. I have found there are not many Google-able references to writing exclusion lists for this product.

Can somebody please post a link to or explain what ‘glob’ format is?

Is there anywhere good examples of creative rules can be found, I am unable to get this part of Insync to work, either.

Thanks in advance for any help.


#15

@Gund_Wehsling We’re providing some examples in the next version of Insync.


#16

#17

i am using 1.2.18.35198-trusty on Mint and can find no ignore option in the GUI. Is there a config file i can mangle?

In GDrive i accidentally toggled on the option to “create Google Photos folder” before turning it off 3 seconds later, and now Insync wants to sync 8 years’ worth of photos (which i don’t want it to do).


#18

@sgbeal: Please check these links:
https://forums.insynchq.com/t/how-to-selectively-sync-google-drive-folders-and-files/31
https://forums.insynchq.com/t/how-to-ignore-a-file/43


#19

Hi there,

What am I doing wrong here?

I’ve excluded mongod.lock with glob pattern.

But I keep getting this error;

Thanks in advance.


#20

@Erik_Verheij, we’ll take a look at this issue. Thanks for the report!