New Insync version: 1.3.2


#1

This is the final preview release for 1.3. Everyone will get this version next week if there are no major issues discovered.

Release notes:

  • Changed the Progress section to display the action as ‘processing’ instead of downloading or uploading if it’s not actually being downloaded or uploaded yet. This distinction is important when files/folders are being matched.
  • Fixed an issue where the UI can become stuck in unsaved changes.
  • Fixed ‘Invalid Query’ and internal errors for filenames with apostrophe.
  • Added an alternative login option in case the normal login mechanism doesn’t work (e.g. Insync website is down or unreachable from your network). This can be accessed via ‘Support’ in the app window.
  • Fixed replacing a file/folder with a link and vice-versa to become seamless and not involve unnecessary processing.
  • (Headless Linux) Fixed issue when sharing.

Windows
Mac
Ubuntu 13.10 and older: 64 bit, <a href="http://s.insynchq.com/builds/insync_1.3.2.36049-precise_i386.deb"32 bit headless: 64 bit, 32 bit
Ubuntu 14.04 and newer: 64 bit, <a href="http://s.insynchq.com/builds/insync_1.3.2.36049-trusty_i386.deb"32 bit
Debian: 64 bit, 32 bit headless: 64 bit, 32 bit
Fedora 20 and older: 64 bit, 32 bit headless: 64 bit, 32 bit
Fedora 21 and newer: 64 bit, 32 bit
Portable: 64 bit, 32 bit

Please help us test.

Thanks!


#2

#3

File Matching definition :smile:

Introduced file matching feature. Insync will now try to match your local (in your filesystem) and remote (in Google Drive) files to avoid duplicates and unnecessary uploads and downloads.


#4

Is the limit of max upload of 2 files at a time fixed? If yes I want to use insync again!


#5

@renatomefidf it is not yet fixed, but we are working on optimizing the speed.

Thank you.


.gddoc files have appeared in my drive
#6

Is it finally here? So this is the local sync basically? Wow… Can’t believe it if true.


#7

still no hidpi support on linux :frowning: well, i’ll keep waiting…


#8

We just had to work out a lot of kinks but it finally is :smile:


#9

Hi @Sascha_Appel this is fixed in this version :smile:


#10

Hi @jaduenas, really? My UI is still tiny and unreadable, no change after update. Cannot see any configuration in Frontend to scale UI either. DPI is set to 192 via xrandr. How to activate hidpi support?


#11

@Sascha_Appel What desktop environment are you using? The high dpi fix only applies to Unity and GNOME for now.


#12

None :wink: I’m using i3 window manager. which gsetting are you querying to determine scaling? i can set this in my startup scripts…


#13

@Sascha_Appel org.gnome.desktop.interface scaling-factor. It’s an integer value, so 2 would scale 2x, etc.


#14

Have a problem with the portable release on centos64 . I get this error message:

[…]
Run insync-portable help for help with a specific command
Traceback (most recent call last):
File “”, line 6, in
File “main.py”, line 128, in
File “main__insync-portable.py”, line 106, in
IndexError: list index out of range


#15

@marcus_specht That error is just minor and shouldn’t prevent Insync from running normally. It will be fixed in the next release. Thanks for the report.


#16

As much as I love the idea of file matching, the latest update has fubared my Insync installation. "Syncing for folder is paused because it went missing.

Ubuntu MATE 15.04 x64
Synced folders symlinked to an external HDD (for portability reasons)

The above setup was working great until a subsequent update prevented me from syncing local files to the cloud. A force sync was necessary every time local content had changed. I have been emailing support forth and back but never got a final response for a fix.

With the latest update nothing gets synced anymore. Not happy, as I have over 600 GB of data.


#17

Hi @lpugoy, I have exactly the same problem of @marcus_specht .
If I run ./insync-portable start, “nothing happens”
When I run ./insync-portable get_status, then I receive the message: Insync doesn’t seem to be running. Start it first.
When I run ./insync-portable start --no-daemon, then I receive the errror bellow:

Traceback (most recent call last):
File “”, line 6, in
File “main.py”, line 128, in
File “main__insync-portable.py”, line 131, in
File “main__insync-portable.py”, line 25, in main
File “ideskmain/client.py”, line 3, in
File “ideskmain/clientconfig.py”, line 1, in
File “ideskmain/configdb.py”, line 5, in
File “idesksyncer/gdclient.py”, line 10, in
File “idesknet/clienthttp.py”, line 4, in
File “idesknet/clienthttpconnection.py”, line 13, in
File “ideskmain/clientplat.py”, line 9, in
ImportError: No module named psutil

My system has the python-psutil package installed.
I’m running the insync-armhf_1.3.2.36049_i386 version.

Have you any idea?


#18

Any idea when a new version will come out that will speed up the initial sync? I’m on a 100mbps connection and still have ~43.000 files to sync out of 60,000; it’s been running for about 5 hours now… I could use gsutils to do the initial download, but I don’t know how insync would handle that or if it would freak out. gsutils is substantially faster.

I’m using insync-headless-1.3.2.36049-fc17 on a CentOS 7 box

Edit some supporting information:
insync-gdrive-linbit/Clients# insync-headless get_sync_progress | grep files; date
42903 files queued
Thu Oct 15 15:13:18 PDT 2015

insync-gdrive-linbit/Clients# insync-headless get_sync_progress | grep files; date
41119 files queued
Thu Oct 15 15:42:31 PDT 2015

insync-gdrive-linbit/Clients# insync-headless get_sync_progress | grep files; date
39962 files queued
Thu Oct 15 16:01:16 PDT 2015
insync-gdrive-linbit/Clients# du -sh
14G .

These files are all relatively small under a meg each.


#19

@Wagner_Lima: Apologies for that. New builds have been uploaded to resolve the psutil issue. You can get them at www.insynchq.com/downloads.


#20

@TimK The issue you had before was resolved in this release as well. For your current issue please send your logs to support@insynchq.com for investigation: How to find the log files