New Insync version: 1.5.0


#1

Release notes:

  • Updated UI with a bigger, movable window
  • Fixed various UI bugs
  • Added various UI improvements
  • Fixed sync behavior for new My Drive items
  • Windows: Fixed crashing on Windows 10 when using UTF-8
  • Windows: Improved auto-update reliability
  • Windows: Improved high-DPI support
  • Windows: Improved touchscreen support
  • Linux: Improved high-DPI support

Windows
Mac

Linux, 64-bit:

These 1.5 builds are currently only available on this post. We’ll release 1.5 on our website and downloads page soon.

Here’s a temporary Insync 1.5 Setup & UI Guide.

Please help us test :smile:

Thanks!


Insync (Mac) crashing when clicking on 'files' menu
#2

Nice to see 1.5 shaping up. However, I just installed it on Fedora 28, and it doesn’t seem to run :cry:

insync start
insync get_status
Traceback (most recent call last):
  File "isyncd/linux/headless/cli.py", line 108, in ipc_insync
  File "socket.py", line 228, in meth
error: [Errno 111] Connection refused

insync show
Traceback (most recent call last):
  File "isyncd/linux/headless/cli.py", line 108, in ipc_insync
  File "socket.py", line 228, in meth
error: [Errno 111] Connection refused

EDIT: it seems there is some problem with insync’s RPM remove scripts: when I tried to remove insync, I realized there were multiple versions installed (from previous upgrades):

Removing:
 insync        x86_64        1.4.8.37107-fc25        @@commandline        208 M
 insync        x86_64        1.4.9.37127-fc25        @System              208 M
 insync        x86_64        1.5.0.37337-fc25        @System              365 M

Removing all of them and reinstalling 1.5.0 worked as expected.


#3

thanks @Costa! Tagging our Linux dev for this @Kurt_Ko


#4

Hi @Costa!
Thanks for the feedback.

Just a few questions:
What command do you use to install Insync 1.5?
Did you install 1.5.0 while you had 1.4.9 installed?


#5

It installs & runs well (on F28, here). No problem with upgrading over an existing 1.4 installation.
The HiDPI support is… interesting. :slight_smile:
I’ve got a big window now (nice), but with the same tiny fonts (not so nice). Soo… progress, I guess? :wink:


#6

Hi @edovino!

Can you show me a screenshot?

Thanks!


#7

Hi @Kurt_Ko,

I downloaded the RPM and installed with “dnf install local-path-to-rpm”. To my surprise, there were two previous versions also installed (1.4.8 and 1.4.9), I expected the new RPM to at least conflict with an existing installation, but ideally it should have done a proper upgrade (i.e. uninstall previous version before installing the new one). Since different versions are not meant to coexist, either one of the two cases should have happened.

EDIT: I just tried to manually upgrade on Ubuntu 18.04 LTS at work (without manually removing 1.4.9 before), and it also failed:

sudo apt install ./insync_1.5.0.37337-artful_amd64.deb 
[sudo] password for xxx: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'insync' instead of './insync_1.5.0.37337-artful_amd64.deb'
The following packages will be upgraded:
  insync
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/144 MB of archives.
After this operation, 176 MB of additional disk space will be used.
Get:1 /home/costalocal/Downloads/insync_1.5.0.37337-artful_amd64.deb insync amd64 1.5.0.37337-artful [144 MB]
(Reading database ... 196638 files and directories currently installed.)
Preparing to unpack .../insync_1.5.0.37337-artful_amd64.deb ...
Terminated

dpkg -l | grep insync
iFR insync                                     1.4.9.37127-artful                  amd64        Google Drive sync and backup with multiple account support
ii  insync-nautilus                            1.3.12.36116-precise                all          Google Drive sync and backup with multiple account support

Please note the “iFR” status of the 1.4.9 version that remained installed. From dpkg-query man page:

i = Installed
F = Half-configured
R = Reinst-required

sudo dpkg --configure -a
dpkg: error processing package insync (--configure):
 package is in a very bad inconsistent state; you should
 reinstall it before attempting configuration
Errors were encountered while processing:
 insync

#8

Sure - there you go:

(This is on F28, with i3wm)


#9

Another thing: starting insync takes ~15minutes, and pegs one core at 100% during that time :scream:


#10

Hi there !

When can we expect an update in the apt repositories? I may beleive the actual thing is outdated… A month ago I posted on the 1.4.9 release post but still, no changes :frowning:

“insync-headless is already the newest version (1.3.22.36179-stretch).”

Or is it me that is doing something wrong?

Thanks a lot for your work!!


#11

Hi @Costa!

We’ll look into it, but for now, could you try using dpkg instead? dpkg -i [INSTALLER]

Let me know if it worked!


#12

Hi @edovino!
Can you tell me the specs of your machine?
Laptop model (If you’re on a laptop)
Screen size
Monitor model
Resolution

Output of these commands:
xdpyinfo
xrandr | grep -w connected

EDIT:
Can you also quit Insync and then run ‘insync start --no-daemon’ and send me the output?

Thanks!


#13

Hi @BodoQC !
We’ll look into it, but for now, you can install the 1.4.9 headless package in our downloads page.

Thanks!


#14

Sure! This is an Dell XPS15 (9560), 4k screen, running it also at 3840x2160

output of xrandr | grep -w connected:
eDP-1-1 connected 3840x2160+0+0 (normal left inverted right x axis y axis) 346mm x 194mm

Output of xdpyinfo here: [https://dl.mobidapt.com/xdpyinfo.txt.gz]

If I try to redirect the output of insync start --no-daemon to a file it stops logging. Any hints?


#15

Hi Kurt_Ko !!

Thanks for the quick reply! I’ll give it a try that way, but when I look at the download page I’m just not sure what to do, since I’m not that advanced with Linux.

I already read about manually installing .deb packages using apt, but how can I be sure to upgrade my current headless installation of insync without causing havoc on my noobie server? I also read the guide at the top at this thread but didn’t find the information.

Thanks again for all the help! :slight_smile:


#16

Hi @Kurt_Ko,

I also tried with dpkg, same problem (which was expected, since apt relies on dpkg to do the actual work). After the aborted attempt broke insync’s installation, the only solution was to forcibly remove insync (a “normal” remove would not work as dpkg refused to remove it), and do a fresh install of 1.5.0. As with Fedora, the upgrade procedure is flawed, it only works with a clean installation (i.e. if there is no other version already installed).

This should be easily reproducible on both cases, just install 1.4.9 and try to upgrade it with the 1.5.0 package.


#17

Hi @Costa

I see… I was able to reproduce it through installing the package by ‘sudo apt install ./[INSTALLER]’ however using ‘sudo dpkg -i [INSTALLER]’ or ‘sudo apt upgrade’ works fine assuming you haven’t used ‘sudo apt install ./[INSTALLER]’.

Thanks for letting us know, we’ll look into it further.


#18

Hi @BodoQC!

Which distro and version are you using on your server?

Thanks!


#19

Would be nice if you could resize the new Insync window on Mac.


#20

Hi @Kurt_Ko,

I would expect no difference between attempts with apt and dpkg, so my understanding was wrong, thks for pointing that out. Live and learn :wink: