New Insync version: 3.0.20

Release notes:

  • Add an Attention Required item when invalid filename characters are automatically replaced when uploading to OneDrive
  • Add an Attention Required item when access to account has been revoked
  • Set base path in onboarding even when “skip syncing” is clicked
  • Do not delete the externally synced folders upon unsyncing
  • Fix externally synced folders not unsyncing when parent is also unsynced

Windows 7 and later
macOS 10.10 (Yosemite and later)

Ubuntu (16.04 Xenial) & (18.04 Bionic)
Linux Mint (18.x) & (19.x)
Debian (8 Jessie) , (9 Stretch) & (10 Buster)
Fedora (27) , (28) , (29) & (30)

On Ubuntu I have reported multiple times that folders are not synced properly. I have sub-folders that are missing on my local disk. Only when I open the app gui and browse to those sub-folders insync suddenly detects the contents and syncs them to the local folder. This is since several releases.

Secondly I am very interested in the “custom base folder” option. It is not present in my current install (also in 3.0.20). Is this option only available when installing freshly? Do I have to start over yet again? Or is this option completely removed?

Please take a look at the 3.0.19 thread. There are many replies and feedback but zero communication from Insync on those matters. Can you please reply to your user base?

Thank you!

2 Likes

I have same problem with MX Linux and Windows 10.
Also I have the same question as your feedback. [wolfi]
And I wondering for your awesome support…

seems to be another shitty release

looks like this can be an alternative https://www.thefanclub.co.za/overgrive

Got a reply on the 3.0.19 thread about how to select a custom base folder.
It worked as described.

Very hopeful the partial sync bug is fixed in one of the next releases. Then there are currently no more open issues for me.

Edit: https://help.insynchq.com/en/articles/2987441-your-insync-base-folder => it’s just a little hidden… I would have expected it in the account settings tabs.

I still have to learn what local selective sync and cloud selective sync mean… :slight_smile:

Edit: Sorry, have to revert my statement. I found the option but it does not accept my value. If you re-open the setting it immediately is witched back to the default.

I think is ok. Troubleshooting like below.

I close the application from each device.
I remove folder with all configuration. (Linux : ~/.config/Insync & Win : %appdata%/insync) After reinstall the application again. Set Google account again.
And start to sync all from scratch.

I use custom path for folder. I set up my old folder with data. Because now in new version it change with “insync” on path before the account
/home/karanik/my_email@gmail.com/ change to /home/karanik/**insync/**my_email@gmail.com/

Time will tell.

Let’s see if I find the time to start all over again. At the moment I really would prefer the software to be fixed and to correctly use a new path that I set. :slight_smile:

Edit: Don’t know why but after trying one more time through the GUI it worked. It somehow was able to switch to a custom folder without starting from scratch again.

Facing a bad issue, even when my based folder is set, when I add shared folder “Here” it overrides the based folder, and put everything in Insync/MYEMAIL/Google Drive - Shared with me/ etc
Really annoying, I have MANY problems with this version.

Linuxmint x64 latest version

Insync recognize changes on Google Drive, for example in screenshot the 0.Test but not sync these changes to local folder.
How can resolve this?

insync2

1 Like

One of the things that really bothers me in version 3.0.20.40428, which I’m using right now, is the fact that when I open Insync for some configuration or to pick something up on selective sync the application simply opens its icon on Mac OS dock. In version 1.49 that didn’t happen at all. Is there a way to configure Insync so the app icon does not open in Mac OS dock?
I’m running os Mojave, version 10.14.6.

I’ve sucessfully installed the new version with AUR in Manjaro Gnome.
I’m able to open de software, login, and tell the software to use my old synced directory as base dir.
However, it starts syncing but never finishes.
I’ve waited more than 12 hours, and the “sync” (the directory was previously synced) has not finished…

Is there anything I can do besides trying a new directory to sync to?

On the previous version and this version files are just not syncing to my local folder. The files being uploaded are originating on Windows 10 pc running Google Backup & Sync and are being synced to the Cloud fine as I can see them in the web interface and I can also see them in the Insync UI on Manjaro linux so Insync knows it’s there and knows it’s unsynced as it offers me the sync option. When I press that it will sync. This is a monitored folder therefore it should sync automatically. Nothing but problems. I had to move off Fedora as it was utterly broken there and the fix never came, at least before I left in spite of numerous beta versions of version 3. Looks like version 3 is still not fit for purpose.

Made the BIG mistake of upgrading yesterday, what a disappointment and I pay for this ?? I rely on Google Drive syncing 100% entirely all day long every day now it’s horribly broken. How can I go back to previous version as this clearly has not been tested. The Under Construction tab also makes it clear and evident you RUSHED to a new version number and nothing is really finished. Why did you have to break what has worked perfectly for months ???
2019-09-29_15-03_1 2019-09-29_15-03

What’s worse is that to be able to actually just work today, I had to end up disabling each folder one by one and resyncing everything because the upgrade simply wasn’t smart enough to know I had ALL the files already here on my HDD :thinking: So thanks for a wonderful 87 Gb of wasted DATA usage today !!! Utter rubbish that you can release a new version like this and so horribly break it.

I see the same thing on Insync 3 now. very annoying.

Usage scenario:

2 computers (“computer A” and “Computer B”) and one cloud drive (“OneDrive”). Both computers A and B configured initially to sync the entire base folder.

This no longer works:

New item added to base folder on computer A → OneDrive → computer B receives new item.
New item added to base folder on computer B → OneDrive → computer A receives new item.

In order for the new item to appear on the 2nd computer, the new item must be selected on the 2nd computer in the InSync app using the “selective could sync”. It will not be included automatically, even though it is in the base folder (that was was initially set up to sync all items).

I just upgrade to 3.0.20 (working on Linux Mint 18, with i3 window manager) and when I start the insync app, it appears as expected in the i3 bar. I press to open the app and see whether it is syncing or not and its progress in general, but nothing appears. If I look into the log I get the following errors

QXcbIntegration: Cannot create platform OpenGL context, neither GLX nor EGL are enabled
libpng warning: iCCP: known incorrect sRGB profile
INFO 2019-09-30 10:49:36,357 [mainlogs:_log_run:92] Core(app_version=3.0.20.40428, platform=Linux-x86_64-linuxmint/18) initialized
WebEngineContext used before QtWebEngine::initialize() or OpenGL context creation failed.
WARNING 2019-09-30 10:49:36,484 [base_events:_run_once:1771] Executing <Task pending coro=<init() running at ideskcore/core.py:114> wait_for=<Task pending coro=<SettingsMain._load_settings() running at ideskcore/mainsettings.py:135> cb=[_log_tb_after_delay() at ideskasync/coreloop.py:302, <TaskWakeupMethWrapper object at 0x7f93193ccd68>()] created at ideskcore/mainsettings.py:117> cb=[_log_tb_after_delay() at ideskasync/coreloop.py:302, _chain_future.._call_set_state() at asyncio/futures.py:355] created at asyncio/events.py:88> took 0.314 seconds
WARNING 2019-09-30 10:49:36,622 [base_events:_run_once:1771] Executing <Task finished coro=<SettingsMain._load_settings() done, defined at ideskcore/mainsettings.py:135> result=None created at ideskcore/mainsettings.py:117> took 0.137 seconds
Traceback (most recent call last):
File “idesklinux/statusmenu_impl.py”, line 102, in
File “ideskui/statusmenu.py”, line 9, in do_action
File “idesklinux/platui_impl.py”, line 64, in do_action
AttributeError: ‘NoneType’ object has no attribute ‘show_app_dialog’

The previous version was also really buggy (all bugs have been reported to support, but zero feedback has been provided), but at least the app worked and I could sync with problems my files.

Very similar experience here. Had to uninstall v3 and go back to v1.57. Wasted hours and countless GB.

v3 is such a half-baked release that I found it well nigh impossible to even compose a bug report:

  • it has “under construction” in essential places
  • it is very slow in all respects
  • it offers to set up “new” account even while its already syncing in the background
  • uploads and downloads all sorts with no reason whatsoever

v1.5 at least picked up the pieces relatively easily and cheaply (although not without some struggle).

This is really unacceptable for a paid-for solution.

Please try and make your releases more incremental and hire a few more testers. v3 was very obviously not seriously tested at all in anything close to a real world scenario. “Works on my machine” by a handful of gung-ho Python 3 developers doesn’t cut it.

The latest build today of 3.0.20.40428 seems to be working for me now for syncing up and down. Will wait see if any other issues arise but at least it syncs now.

Sadly not for me. I think I’ll wait for a more major version update. Not much confidence even 3.0.21 will be great improvement. They probably need at least 3.1.x…