No tray icon in ubuntu 17.10 (solved)

I recently had the same issue (on 16.04 LTS) and it was due to my participating in the beta v2.0 of Insync. Insync crashed silently on startup and there was no tray icon (and my files were not synced, obviously). Re-installing Insync did the trick by reverting to v1.3.

1 Like

Thanks for your reply.

option 1 (installing sni-qt) did the trick :slight_smile:

For your information: The new Gnome (3.26) removes the bottom menu for legacy tray icons, so the only way of getting the icon with the use of one of the top icon extensions.

3 Likes

Should you please give a hint, “how can"we install sni-qt” ?
Thanks in advance

open a terminal and type:

sudo apt install sni-qt

done :wink:

For some reason, it still doesn’t work for me (was using Ubuntu 16.10 LTS, just upgraded to 17.10). sni-qt is installed, and so is TopIcons Plus. I can confirm insync is running, and healthy. Still, no icon on the top bar, even if I restart insync (other icons, such as Pidgin, show just fine). My graphics card is an onboard Sandybridge, by Intel.

Here’s some information:

insync get_status
SHARE

dpkg -l | grep sni-qt
ii sni-qt:amd64 0.2.7+17.04.20170112-0ubuntu1

Any help will be much appreciated :wink:

BTW: I used "insync accept_all_new_shares " to solve the SHARED status reported by get_status, but now the status is FEED, which is not listed on this page :

insync get_status
FEED

What does it mean, and how do I change it to SYNCED?

I’m running 17.10 and not seeing the top bar icon. Insync is running (insync get_status).

Have checked sni-qt, installed Gnome “Topicon” extension.

The maddening thing is that I had the icon until recently. Then I did some system updates (can’t recall which), and now it’s gone. I tried removing and reinstalling insync from the repository.

This is especially annoying because it’s not clear how I set insync preferences except through that icon that I can’t see. Is there a workaround to get to the graphical status/options window?

Suggestions?

Note added: This may be an Ubuntu / Gnome problem. I also have an icon from the hplip package that’s trying to display in the top tray. It also is not reliable. Sometimes I get both the HP icon and Insync’s but other times I get neither.

Further added: I have been using the Gnome extension “system-monitor by Cerin”, which works fine for me. But the Insync and hp-lip icons seem to appear most reliably when system-monitor is disabled. So it looks like the Ubuntu indicators are fighting for tray space with other Gnome extensions. Who’s at fault here? Probably not Insync.

2 Likes

I desactivate all other Gnome shell extensions, without results.

I have the same problem. Can you help us ?

Okay, this looks like I didn’t have the sni-qt install to my system, so this message doesn’t show up anymor: No systemtrayicon available problem, but now this:

ERROR:root:Cannot initialize notifications.

Until on Ubuntu 17.10. It’s a pretty vanilla installation.

Also got this warning trying to make sure my nautilus was up to date.
greg@salt:~/.config/Insync$ sys:1: PyGIWarning: Nautilus was imported without specifying a version first. Use gi.require_version(‘Nautilus’, ‘3.0’) before import to ensure that the right version gets loaded.

Hi all,

I Have tried all of the following on Ubuntu 17.10 …

  1. Installed sni-qt
  2. Installed and enabled TopIcons and TopIcons Plus and Ubuntu Appindicators
  3. (Re)installed insync

… and I have no icon in the top toolbar.

Installing sni-qt made the insync icon appear, but this did not survive a reboot, and I cannot get the icon back at all.

Please advise on how to proceed.

Thanks,

Viv

I’ve installed sni-qt (but why isn’t this just a dependency of the package?), gstreamer and top-icons. No insync.

I’ll be happy to buy a new license, but can we just get the icon (= the only access to the app) back please?

Hello everyone, we’re really sorry for the delay in fixing this issue, but we are investigating it now and will report back in this thread with any progress or possible workarounds.

Thank you for your patience.

Perhaps related to this?

I have the same problem on 17.10. It worked for a while after removing and reinstalling insync, but has gone away again after some days.

This may be an Ubuntu/Wayland bug. I also have the hp-systray app running (associated with hp-doctor printer management). It also wants to show a menu as an indicator. When the hp icon shows up, so does insync’s icon, and vice versa. Somehow the indicator stuff that worked under unity/xorg does not work reliably on the current default system.

Correction: I checked my login options and found that I WAS running Ubuntu/Xorg. When I switch to the default “Ubuntu” (Wayland), the tray icons appear just fine! So you might check that under the “gear” icon on your login greeting screen.

Installing sni-qt fixed the issue for me. I was having a problem using i3wm as a window manager on top of galliumOS 16.4.

This was great - thank you!

My solution:

  • Ubuntu 17.10
  • Removing all legacy indicator applications: sudo apt purge indicator-application indicator-appmenu indicator-bluetooth indicator-common indicator-datetime indicator-keyboard indicator-messages indicator-network indicator-power indicator-printers indicator-session indicator-sound indicator-transfer indicator-transfer-download-manager
  • Check taht sni-qt is installed: apt install sni-qt
  • Install top-icons (or top-icons plus. Both worked for me)
  • Restart insync from terminal (insync quit; insync start)
3 Likes

Installing sni-qt worked for me. Thanks.

For those on Arch, try to install the sni-qt-patched package from the AUR. That fixed the problem for me.

The first option worked for me.
You are a Genius! Thanks!