[Xubuntu 15.04] insync not showing notifications


#1

Running latest versions from Insync repository:

insync-thunar: 1.2.7.35123-precise
insync: 1.2.7.35123-trusty

Ubuntu stuff:

Xubuntu: 15.04
thunar: 1.6.6-1ubuntu2
thunarx-python: 0.3.0-1~utopic

When a private or public link is copied on Thunar:

insync is not showing notifications anymore, even though notifications are enabled on insync:

I did refresh Thunar after installing insync-thunar:

paulo@monk:~/tmp$ pkill -x Thunar
paulo@monk:~/tmp$ 

The link is copied correctly to the clipboard, but the notification is not shown. Restarted both insync and Thunar, one more time, just in case, but the notifications are really not shown anymore. Previous insync-thunar version did show the notifications.


[1.2.10/Xubuntu 15.04] Notifications not being shown
[1.2.8] insync-thunar fails to create private links
#2

@marcelpaulo I am unable to replicate your issue. Do you maybe use multiple monitors? Please send your logs to support@insynchq.com for investigation: How to find the log files.


#3

No, just a plain laptop, no monitor attached.

Just emailed you ~/.config/Insync. Ops, just realized now that I didn’t include a link to your post, but I identified the issue number (918) in the Subject. Let me know if you can’t find it and I’ll send it again, including the link.

To make sure the issue was reflected in the logs, I copied a private link with Thunar before sending them.


#4

So, we’ve just concluded that insync is not showing any notifications under Xubuntu 15.04.

Any way I can configure insync to generate debug information, perhaps setting some environment variable? I could run it that way, and then recreate a scenario where a notification should be shown, so you might have adequate information to debug the issue?

Or perhaps run insync with gdb, as you explained [here] ([Xubuntu] Segmentation fault in spite of little or no syncing activity)?


#5

Solved with latest version:

insync: 1.2.8.35136-trusty
insync-thunar: 1.2.8.35136-precise

But unfortunately a much more serious bug introduced: now insync-thunar doesn’t copy the private links at all.


#6

@marcelpaulo Is there an error if you run insync start --no-daemon in the terminal and try creating the private link?


[1.2.8] insync-thunar fails to create private links
#7

Replied on issue 1076.