New Insync version: 3.0.23

I feel so very let down by Insync. They should have retained 1.x as the production version and developed 3 as a beta. Right now I’m in a position where I paid for some licences for some solid, usable software and it’s turned to c**p.

I hear you. If your OS is supported, you should be able to continue using 1.5.7 until v3 is production ready. Insync 1.5.7 builds

This release is still suffering from the same fundamental flaw under Linux: it doesn’t “see” new files added by a different Insync installation, thus they never appear on current installations.

Files deletion and modification are both propagated normally.

I still have to do multi-way rsync to keep several installations in sync. Insync can’t do that any more.

@Siamak @Konstantin_Boyandin Exact same behavior on my local install. But this affected me already before 1.5.7 - you can find multiple posts on this forum. My “workaround” is to always open the sub-folder in the GUI which then suddenly detects all folders and files and syncs them. It is so frustrating that this software is not able to deliver on it’s one core functionality that it is supposed to do well since more than a year.

I still put up with that because this manual workaround sadly is still more convenient than downloading/syncing files from the browser directly.

If there was any real alternative for Linux I would switch in a heartbeat. Sadly the alternatives do not (yet) support team shares.

Thank you for update!

In my case (Ubuntu 18.04) opening subfolder doesn’t help.

What’s also strange, many fully synced folders are displayed with yellow (‘partially synced’) icon, and there’s no obvious means to change that.

Pity the developers are too busy with more important tasks.

@Konstantin_Boyandin Do you open the subfolder in a file manager or do you use the Insync GUI? I have to open the Insync GUI and browse to the specific subfolder. Then it reloads the file structure from the online drive and downloads all missing files.

In my case (I have just checked that again):

  • when I add a file on a system (Ubuntu 18.04), Insync sends it to cloud (it appears in Web UI of Google Drive immediately)
  • when I open the folder containing the file in another system (also Ubuntu 18.04), the file appears in Insync file manager list, but not in actual local file system
  • I have to manually click “Sync” in Insync app file manager, to have file copied to local file system

I can’t fancy clicking “Sync” on multiple files every day, thus I use rsync.

(I wonder whether any of Insync developers actually read this, since my previous email exchange with them ended in smoke)

If this is happening for items in the root folder, check to make sure the sync option is set. Link to example Items created in cloud don't auto sync locally

Did you add this account as new so it reuploaded or as existing so you ended up with yellow check mark icons indicating ‘local-to-cloud file matching’ but not reuploaded? I think prior to 3.0.23 for me on windows, new items in folders with yellow check marks weren’t auto syncing but items in folders with green ones were.

Perhaps Insync team can clarify but I’m pretty sure yellow check marks are not indicating partial sync in the sense that some items contained aren’t synced. As I said above, pretty sure the yellow means that Insync has associated the local file with the cloud file but the file was not reuploaded, aka ‘local-to-cloud file matching’

@kyle There’s no ‘items created in cloud don’t auto sync locally’ option in my case (Linux version).

There’s ‘Sync new top-level cloud items automatically’ checkbox, and it’s checked.

Did you add this account as new so it reuploaded or as existing so you ended up with yellow check mark icons indicating file sync but not reuploaded?

Existing one. I have no fun re-syncing the entire Google Drive after every Insync upgrade.

When I place new file/create new folder in sync root, it gets propagated and is marked with green check. Consequently, files in it are synced from any device and gets propagated.

I wonder why some of my existing folders are marked with yellow check, and what exactly shall I do to make them sync again?

Correct, there is no setting called ‘items created in…’ that was a link to a screenshot showing the ‘Sync new top-level cloud…’ which actually appears to have moved in 3.0.23 to the settings icon next to ‘My Drive’

So it sounds like only items created in folders with a yellow check mark are not automatically downloaded locally by insync. This is pretty much the exact issue we had in windows which appears to have been fixed.

I asked about yellow checks in another thread:

The only way to change yellow icons to green is to unsync and then resync the item. I just tested and found that when I do so, the items are downloaded from the cloud (not uploaded to) and marked with green icon. The simplest way to change all items from yellow to green is to remove the account and re-add it as new so insync uploads/downloads files instead of doing the ‘local-to-cloud file matching’.

My observations based on user experience and various topics here, is that ‘local-to-cloud file matching’ (yellow icons) is not working correctly and leads to many problems including various sync errors (see Error AddCloudGDItemL(‘Unsupported file type:%r’, ‘?’)), most of which are solved by doing a full fresh sync.

@kyle Thanks for explanation. Well, I abhor fixing things in “traditional Windows” way (delete and reinstall), and I certainly hope I won’t need doing that after each upgrade.

Since I use file system level encryption with Google Drive (encfs and the like), there always will be plenty of “Unsupported file type” entities.

@kyle Do you have any explanation why syncing of sub-items will not work reliably? No yellow icons and not about new root folders… it happens with any content in sub-folders.

Re-syncing everything has no effect. The problem persists. I am affected since before 1.5.7 and was hoping that 3.x was any better. Sadly still the same issue.

Unfortunately, I’m not able to answer that. I’ve been using insync on multiple windows 7 and 10 machines for at least 3 years now with 6 free personal gdrives and one teams. insync 1.x worked pretty much flawlessly. I didn’t experience syncing issues until “upgrading” to 3.x. It has been rough to say the least but it seems to be functioning properly at the moment.

Can you provide more details regarding the installation? Which operating systems experience the issue, google cloud type (business, teams, personal), file types that fail to sync properly. Is your problem that items created locally get pushed to the cloud, but other machines aren’t automatically downloading the cloud files locally? Or is it that items created locally don’t get pushed to the cloud? Does this happen when renaming or changing existing files as well?

When you say “re-syncing” do you mean you manually unsynced and resynced or do you mean you removed the account and re-added as a new account rather than an exisitng account so it bypasses the 'local-to-cloud file matching’ entirely.

Might be better to start your own thread to discuss in more detail.

Thank you for taking your time writing that out.

Some more specific details:

  • I am using Ubuntu systems (several notebooks and desktops)
  • this bug is accompanying me since before 1.5.7 up to 3.0.23 since at least Ubuntu 18.10 (or 18.04) up to 19.04 and 19.10
  • I am using two G-Suite accounts (one private / free tier and one business G-Suite)
  • the problem is noticable on my business G-Suite account mainly with Team Shares
  • I do not use my private drive very much and I can not say much about my private Business share as I do not store much data there either
  • It’s happening definitely on Team Shares, funnily with files & folders I have created on e.g. my work PC and then my home PC does not sync the files down
  • the files are definitely available online and when opening the Insync GUI app and manually opening the affected sub-folder the app suddenly seems to re-fetch the folder/file info and starts syncing the missing data
  • it just does not automatically detect file/folder changes automatically which is quite annoying when looking e.g. through folders where we store customer files and you never can be sure if everything is in the folder or not when handling e.g. customer support requests - always have to manually check the folder online in parallel just to make sure I have all info available
  • when saying re-syncing I meant multiple strategies: using different Insync versions, removing and re-adding an account completely, removing selective sync on certain folders and then re-checking it later

I have reported the issues since last autumn in the forums and directly and received some first level support canned responses. Even though other users also report the issue in the 3.0.x beta threads on the forum the devs are painfully silent about this. I’ll wait a few versions longer and see if any Insync is addressing these comments at all.

Thanks for this extensive writeup. Great info here. I dug through the forum and found your previous threads going back to January. Posting links here in:

This should be a priority.

I have checked other Insync installations, using 3.0.23 (on Ubuntu).

Total removal (app, its settings, synced folder) and re-installation and re-sync on all devices seem to help. So far, no “yellow checks” and new files seem to propagate normally.

Thanks. I hope I won’t have to repeat total re-sync every app upgrade - it’s both time- and traffic-consuming.


Just a quick report: I have upgraded from 3.0.22 and everything seems to be working well. The new features are interesting, thanks.

I’m using Xubuntu 16.04.5.

The only downside is that I still can’t install the insync-thunar package because of some conflict, but it’s not that important for me. The console output is below:

$ sudo apt-get install insync-thunar
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 insync-thunar : Depends: thunarx-python but it is not installable
E: Unable to correct problems, you have held broken packages.

The thunar-insync plugin for insync3 does not work at all so far … :frowning_face:
I am trying to escalate this problem, but the insync developers internal priority is obviously very low, so … !!! (Debian)

Not sure why the mandatory folder “Google Drive” is needed, i should be able to use any folder for syncing Google Drive…