Sync from GDrive doesn't work / sync to GDrive OK

I just upgraded to Insync from 1.5 .
Initial sync using the same old folder did work , apart some errorß similar to (error doing ModifyCloudReg) that I solved deleting the few files.

Now I have two main machines with Max OSX Sierra 10.12.6, both can sync to GDrive , but the files from machine_1 are not copied over machine_2 and vice versa.
In GDrive I can see both file uploaded.

EDIT : I tested now that files adde to GDrive web interface do not appear on any machine, it seems that sync from GDrive isn’t working, but pushing files is fine.

Any idea?

I note that you posted this issue six days ago. Have you had an off thread response from the team? I’m having similar issues with the app since the update.

I have the same problem both on Insync 3.0.19 in Linux and 3.0.20 in Windows

No, no responses. I did solve at least my problem:
I use the “match local files with remote” option when I switched to v3.
This leave me with all Yellow badges, that I found on this forum to be “local files synced with remote”, that is different to green badge.
I guess it doesn’t work like normal files sync.
MY SOLUTION: In the preferences I unsync / resync each single folder, this downloaded the remote or uploaded modified files, leaving my with all green badges and now it works like normal.
I think the option to match local files with remote during migration leaves in a strange state, better to re-download everything for now or wait for team official answer.

Good Luck.

I Have the same problem. 2 linux machines, insync 3.0.20, upgraded from 1.5 too.
It can just push files to GDrive, but can’t download.

Tried kidpixo sugestion with a small folder (unsync & sync again to redownload everything) and sync works now. But I don’t want to download everything again.

Hi everyone, the DownloadODBlob errors are a bit scattered now, can you send in the screenshots of your errors to since the errors have specific messages after them.

Thank you.

We currently have a behavior issue in Insync where we weren’t able to implement this behavior in Insync 3: Where Insync automatically uploads files or folders uploaded on root from the cloud – however, it uploads files on folders already synced.

I apologize for this. We are now developing this fix and will be available soon.

Is the folder you’re looking for shown on the Insync window? If so, you can sync it manually from there for now.

Hi, thanks for the answer.

This happens in all folders, because I choose to match local files to remote during migration from v1.5.X to v3.
As I only found here “Yellow badges are due to local-to-cloud file matching (ie using an existing folder during setup)” .

If I unsync and resync a folder it turns green after downloading the remote content locally, and it is normally synced.